Der vollständige Name eines Netzwerkdruckers kann nicht auf einem Computer angezeigt werden, auf dem Windows Server 2003 oder Windows XP ausgeführt wird

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 937193 - Produkte anzeigen, auf die sich dieser Artikel bezieht
wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Stellen Sie sicher, dass Sie die Registrierung sichern bevor Sie Sie ändern. Stellen Sie sicher, dass Sie die Registrierung wiederherstellen kennen, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986Beschreibung der Microsoft Windows-Registrierung
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Sie verwenden einen Netzwerkdrucker, dessen Name einen vollständig qualifizierten Domänennamen (FQDN) enthält, auf einem Computer, auf dem Microsoft Windows Server 2003 oder Microsoft Windows XP ausgeführt wird. Der Name des Netzwerkdruckers wird eines der folgenden Formate:
  • print server name. different Domain Name System (DNS) domain name \ shared printer name
  • shared printer nameauf print server name. different DNS domain name
In einer Anwendung versuchen Sie den Netzwerkdrucker aus einer Liste auszuwählen. Allerdings ist ein Drucker Netzwerkname, der einen FQDN enthält so lange, dass der vollständige Name in der Liste angezeigt werden kann. Daher können Sie den Netzwerkdrucker finden, den Sie möchten.

Dieses Verhalten tritt auf, wenn folgenden Bedingungen erfüllt sind:
  • Der Netzwerkdrucker befindet sich in einer Domäne. Allerdings befindet sich der print Server, auf den Netzwerkdrucker befindet in einer anderen Domäne. Oder die Host-Namen des Druckservers in einen unzusammenhängenden Namespace konfiguriert werden.

    Hinweis: In ein unzusammenhängender Namespace unterscheidet sich vom Namen der Domäne, die den Druckserver enthält primären DNS-Suffixes des Druckservers.
  • Benutzer in einer anderen Domäne als die, die den Druckserver enthält haben Netzwerkdrucker erstellt. Dieser Drucker wurden durch Verwenden von veröffentlichte Druckern in Active Directory-Verzeichnisdienst erstellt.

Ursache

Ein Drucker muss einen FQDN sein, wenn die folgenden Bedingungen erfüllt sind:
  • Möchten Sie Netzwerkdrucker von einem anderen zu unterscheiden.
  • Diese Netzwerkdrucker haben denselben freigegebenen Druckernamen.
  • Diese Netzwerkdrucker sind in verschiedenen Domänen.
Wenn die Namen der Netzwerkdrucker nicht FQDNs enthalten, kann aus einem anderen nicht der Netzwerkdrucker unterscheiden. Jedoch wird ein Druckernamen ein viel länger sein, wenn dessen Namen einen FQDN enthält. Daher kann nicht der vollständige Name des den Netzwerkdrucker in einer Liste angezeigt werden.

Lösung

Sie können dieses Problem beheben, durch einen Hotfix anwenden. Allerdings müssen die folgenden Bedingungen für den Hotfix erfüllt sein:
  • Die Host Namen von den Druckservern können richtig aufgelöst werden.
  • Jeder Druckserver hat einen eindeutigen Host Namen im Netzwerk.
  • Jede Netzwerkverbindung Drucker in allen Benutzerprofilen wurde getrennt.
Hinweis: Wenn diese Bedingungen nicht erfüllt sind, können Sie Zugriff auf Netzwerkdrucker verlieren, nachdem Sie den Hotfix installiert haben.

Windows Server 2003 Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix installieren, muss eines der folgenden Windows Server 2003 Service Packs auf dem Computer installiert sein:
  • Windows Server 2003 Service Pack 1 (SP1)
  • Windows Server 2003 Service Pack 2 (SP2)

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.

Informationen zur Registrierung

Um diesen Hotfix installieren, müssen Sie die Registrierungsänderungen vornehmen. Weitere Informationen hierzu finden Sie unter "So um diesen Hotfix anwenden".

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Server 2003 mit SP1, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Printui.dll5.2.3790.2933577,02410-Mai 200705: 46X 86
Windows Server 2003 mit SP2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Printui.dll5.2.3790.4077568,83210-Mai 200706: 04X 86
Windows Server 2003 mit SP1, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Printui.dll5.2.3790.29331,184,25609-Mai 200715: 51IA-64SP1Nicht zutreffend
Wprintui.dll5.2.3790.2933577,02409-Mai 200715: 51X 86SP1WOW
Windows Server 2003 mit SP2, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Printui.dll5.2.3790.40771,184,25609-Mai 200715: 59IA-64SP2Nicht zutreffend
Wprintui.dll5.2.3790.4077568,83209-Mai 200715: 59X 86SP2WOW
Windows Server 2003 x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Printui.dll5.2.3790.2933950,27209-Mai 200715: 51X 64SP1Nicht zutreffend
Wprintui.dll5.2.3790.2933577,02409-Mai 200715: 51X 86SP1WOW
Windows Server 2003 mit SP2, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Printui.dll5.2.3790.4077950,27209-Mai 200715: 58X 64SP2Nicht zutreffend
Wprintui.dll5.2.3790.4077568,83209-Mai 200715: 58X 86SP2WOW

Windows XP Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix auf einem X 86-basierten Computer zu installieren, benötigt Windows XP SP2 installiert.

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.

Informationen zur Registrierung

Um diesen Hotfix installieren, müssen Sie die Registrierungsänderungen vornehmen. Weitere Informationen finden Sie Abschnitt "Hotfix anwenden".

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows XP Mit SP2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Printui.dll5.1.2600.3135560,64010-Mai 200706: 52X 86
Windows XP mit SP2, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Printui.dll5.2.3790.4077950,27209-Mai 200715: 58X 64SP2Nicht zutreffend
Wprintui.dll5.2.3790.4077568,83209-Mai 200715: 58X 86SP2WOW
Windows XP mit SP1, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Printui.dll5.2.3790.2933950,27209-Mai 200715: 51X 64SP1Nicht zutreffend
Wprintui.dll5.2.3790.2933577,02409-Mai 200715: 51X 86SP1WOW

Wie Sie diesen Hotfix anwenden

Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine das Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.

Um diesen Hotfix installieren, müssen Sie den Registrierungseintrag ConnectPrintersWithShortNames hinzufügen. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Klicken Sie auf folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
  3. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  4. Geben Sie ConnectPrintersWithShortNames , und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie mit der rechten Maustaste auf den Registrierungseintrag ConnectPrintersWithShortNames , und klicken Sie dann auf Ändern .
  6. Geben Sie in das Feld Wertdaten 1 ein, und klicken Sie dann auf OK .
  7. Beenden Sie den Registrierungs-Editor.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.

Weitere Informationen

Dieser Hotfix ändert standardmäßige Verhalten. Nachdem Sie diesen Hotfix angewendet haben, sind Netzwerkdrucker in der Domäne mithilfe ihrer eindeutigen Namen zu einem Druckserver verbunden. Diese Namen sind kürzer als die Namen, die FQDNs enthalten.

Nachdem Sie den Hotfix angewendet haben, kann den Namen eines Netzwerkdruckers das folgende Format haben:
  • print server name\ shared printer name
  • shared printer nameauf print server name
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 937193 - Geändert am: Donnerstag, 11. Oktober 2007 - Version: 2.6
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional SP2
Keywords: 
kbmt kbautohotfix kbfix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB937193 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 937193
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com