O nome completo de uma impressora de rede não pode ser apresentado num computador com o Windows Server 2003 ou Windows XP

Traduções de Artigos Traduções de Artigos
Artigo: 937193 - Ver produtos para os quais este artigo se aplica.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Está a utilizar uma impressora de rede cujo nome contém um nome de domínio totalmente qualificado (FQDN, Fully Qualified Domain Name) num computador com o Microsoft Windows Server 2003 ou Microsoft Windows XP. O nome da impressora de rede está a ser um dos seguintes formatos:
  • print server name. different Domain Name System (DNS) domain name \ shared printer name
  • shared printer nameno print server name. different DNS domain name
Numa aplicação, tente de seleccionar a impressora de rede a partir de uma lista. No entanto, um nome de impressora de rede que contenha um FQDN, Fully Qualified Domain Name é tempo que o nome completo não pode ser apresentado na lista. Por conseguinte, não consegue localizar a impressora de rede que pretende.

Este comportamento ocorre caso se verifiquem as seguintes condições:
  • A impressora de rede está localizada num domínio. No entanto, o servidor de impressão que hospeda a impressora de rede estiver localizado noutro domínio. Ou, os nomes de anfitrião do servidor de impressão configurados no espaço de nomes disjunto.

    Nota Num espaço de nomes disjunto, o sufixo DNS primário do servidor de impressão é diferente do nome do domínio que inclua o servidor de impressão.
  • Utilizadores num domínio diferente do domínio que inclua o servidor de impressão criou impressoras de rede. Estas impressoras foram criadas utilizando impressoras publicadas no serviço de directório do Active Directory.

Causa

Um nome de impressora tem de ser um FQDN, Fully Qualified Domain Name se verifiquem as seguintes condições:
  • Pretender distinguir impressoras de rede entre si.
  • Estas impressoras de rede têm o mesmo nome de impressora partilhada.
  • Estas impressoras de rede estão em domínios diferentes.
Se os nomes das impressoras de rede não contiverem FQDNs, não consegue distinguir as impressoras de rede entre si. No entanto, um nome de impressora será muito mais tempo se o respectivo nome contém um FQDN, Fully Qualified Domain Name. Por este motivo, o nome completo da impressora de rede não pode ser apresentado numa lista.

Resolução

Pode resolver este problema, aplicando uma correcção. No entanto, as seguintes condições têm de estar verdadeiras para aplicar a correcção:
  • Os nomes de anfitrião dos servidores de impressão podem ser resolvidos correctamente.
  • Cada servidor de impressão tem um nome de anfitrião único na rede.
  • Cada ligação de impressora de rede em todos os perfis de utilizador foi desligada.
Nota Se estas condições não for verdadeiras, poderá perder o acesso a impressoras de rede depois de aplicar a correcção.

Informações sobre a correcção do Windows Server 2003

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para instalar esta correcção, tem de ter um dos seguintes Windows Server 2003 service packs instalados no computador:
  • Windows Server 2003 Service Pack 1 (SP1)
  • Windows Server 2003 Service Pack 2 (SP2)

Requisito de reinício

Terá de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções disponibilizadas anteriormente.

Informações de registo

Para aplicar esta correcção, tem de efectuar alterações ao registo. Obter mais informações, consulte a secção "Como aplicar esta correcção".

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Windows Server 2003 com SP1, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Printui.dll5.2.3790.2933577,02410 De Maio de 200705: 46x 86
Windows Server 2003 com SP2, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Printui.dll5.2.3790.4077568,83210 De Maio de 200706: 04x 86
Windows Server 2003 com SP1, versões baseadas em Itanium
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Printui.dll5.2.3790.29331,184,25609 De Maio de 200715: 51IA-64SP1Não aplicável
Wprintui.dll5.2.3790.2933577,02409 De Maio de 200715: 51x 86SP1IMPRESSIONANTE
Windows Server 2003 com SP2, versões baseadas em Itanium
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Printui.dll5.2.3790.40771,184,25609 De Maio de 200715: 59IA-64SP2Não aplicável
Wprintui.dll5.2.3790.4077568,83209 De Maio de 200715: 59x 86SP2IMPRESSIONANTE
Windows Server 2003, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Printui.dll5.2.3790.2933950,27209 De Maio de 200715: 51x 64SP1Não aplicável
Wprintui.dll5.2.3790.2933577,02409 De Maio de 200715: 51x 86SP1IMPRESSIONANTE
Windows Server 2003 com SP2, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Printui.dll5.2.3790.4077950,27209 De Maio de 200715: 58x 64SP2Não aplicável
Wprintui.dll5.2.3790.4077568,83209 De Maio de 200715: 58x 86SP2IMPRESSIONANTE

Informações sobre a correcção do Windows XP

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para instalar esta correcção num computador x 86, tem de ter instalado o Windows XP SP2.

Requisito de reinício

Terá de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções disponibilizadas anteriormente.

Informações de registo

Para aplicar esta correcção, tem de efectuar alterações ao registo. Para mais informações, consulte a secção "Como aplicar esta correcção".

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Windows XP Com SP2, x 86 versões
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Printui.dll5.1.2600.3135560,64010 De Maio de 200706: 52x 86
Windows XP com o SP 2, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Printui.dll5.2.3790.4077950,27209 De Maio de 200715: 58x 64SP2Não aplicável
Wprintui.dll5.2.3790.4077568,83209 De Maio de 200715: 58x 86SP2IMPRESSIONANTE
Windows XP com SP1, versões baseadas em 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Printui.dll5.2.3790.2933950,27209 De Maio de 200715: 51x 64SP1Não aplicável
Wprintui.dll5.2.3790.2933577,02409 De Maio de 200715: 51x 86SP1IMPRESSIONANTE

Como aplicar esta correcção

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Para aplicar esta correcção, tem de adicionar a entrada de registo ConnectPrintersWithShortNames. Para fazer, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
  3. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  4. Escreva ConnectPrintersWithShortNames e, em seguida, prima ENTER.
  5. Clique com o botão direito do rato na entrada de registo ConnectPrintersWithShortNames e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , escreva 1 e, em seguida, clique em OK .
  7. Saia do Editor de registo.

Ponto Da Situação

Este comportamento ocorre por predefinição.

Mais Informação

Esta correcção altera o comportamento predefinido. Depois de aplicar esta correcção, as impressoras de rede no domínio estão ligadas a um servidor de impressão, utilizando os respectivos nomes exclusivos. Estes nomes são menos do que os nomes que contêm o FQDN.

Depois de aplicar a correcção, o nome de uma impressora de rede poderá ter o seguinte formato:
  • print server name\ shared printer name
  • shared printer nameno print server name
Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 937193 - Última revisão: 11 de outubro de 2007 - Revisão: 2.6
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional SP2
Palavras-chave: 
kbmt kbautohotfix kbfix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB937193 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 937193

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com