WDS kann nicht mehr als 255 Clientnamen generieren, wenn Sie WDS, verwenden um die Bereitstellung von Windows Vista

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Problembeschreibung

Stellen Sie sich das folgende Szenario vor. Sie versuchen, Windows Vista mithilfe von Windows Deployment Services (WDS) in einer Umgebung Active Domäne bereitstellen. Sie haben den neuen Client Benennen von Richtlinien für WDS konfiguriert. Um jeden Clientnamen eindeutig zu machen, gelten die automatischen Benennung Optionen eine zunehmende Anzahl jedes neuen Client-Namen. Beispielsweise verwenden Sie % [0] [n] # wie der Ausdruck für den neuen Client Richtlinie benennen.

In diesem Szenario kann nicht mehr als 255 Clientnamen WDS generiert werden. Daher können nicht Sie mehr als 255 Computer Kontoobjekte (MAO) in der Domäne hinzufügen. Benutzer können Windows Vista auf mehr als 255 Clientcomputern installieren. Allerdings werden nur die ersten 255 Computer automatisch mit der Domäne verknüpft. Sie können nicht die Windows Vista-Bereitstellung für andere Computer daher zentral verwalten.

Ursache

Dieses Problem tritt wegen eine fest codierte Einschränkung in der Datei Wdsclient.dll.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Vista, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
935791Wie Sie das neueste Windows Vista Servicepack erhalten

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Es gelten keine Voraussetzungen.

Neustartanforderung

Sie müssen Ihren Computer nicht neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Vista x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Wdsclient.dll6.0.6000.20602235,00818-Mai 200710: 35X 86
Windows Vista, 64-Bit-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Wdsclient.dll6.0.6000.20602250,88018-Mai 200710: 24X 64

Informationen zum Hotfix-installation

Gehen Sie folgendermaßen vor um den Hotfix zu installieren, der in diesem Artikel erwähnt:
  1. In diesem Artikel erwähnte enthält ein CAB-Paket. Extrahieren Sie die Wdsclient.dll-Datei aus dem CAB-Paket in einen temporären Ordner. Doppelklicken Sie dazu auf das CAB-Paket.
  2. Installieren Sie Windows Automated Installation Kit (Windows AIK) oder Windows OEM-Vorinstallationskit OEM Preinstall Kit (Windows OPK).
  3. Deaktivieren Sie das Startabbild auf dem WDS-Server die Boot-Image für den Download verfügbar. Zum Beispiel können Sie den folgenden Befehl an einer Eingabeaufforderung ausführen:
    wdsutil.exe /set-image /image: <ImageName> /imagetype:boot /architecture: <Platform> / aktiviert: keine
    Hinweis: Die <ImageName> Platzhalter für den Namen des Boot-Image darstellt. Ersetzen Sie die <Platform> Platzhalter mit X 86 , X 64 oder ia64 je nach Ihrer Situation.
  4. Exportieren Sie das Startabbild aus den WDS-Server. Zum Beispiel können Sie den folgenden Befehl an der Eingabeaufforderung den Befehl ausführen:
    wdsutil.exe /export-image /image: <ImageName> /imagetype:boot /architecture: <Platform> /destinationimage /filepath: <PathToBootWIM>
    Hinweis: Die <ImageName> Platzhalter für den Namen des Boot-Image darstellt. Ersetzen Sie die <Platform> Platzhalter mit X 86 , X 64 oder ia64 je nach Ihrer Situation. Die <PathToBootWIM> Platzhalter repräsentiert die Windows Imaging Format (WIM)-Datei, die Boot-Image exportiert werden sollen.
  5. Bereitstellen der Boot-Image, die in Schritt 4 exportiert. Wenn Sie dies tun, geben Sie einen Index 2, und geben Sie Lesezugriff und Schreibzugriff. Beispielsweise können Sie den folgenden Befehl an der Eingabeaufforderung den Befehl ausführen:
    ImageX.exe/mountrw <PathToBootWIM><MountLocation>
    Hinweis der <PathToBootWIM> Platzhalter steht für den Speicherort, in denen das Startabbild in Schritt 4 exportiert. Die <MountLocation> Platzhalter steht den Speicherort der Boot-Image bereitgestellt werden soll. Weitere Informationen zu diesem Vorgang finden Sie in der Dokumentation, die in das OPK von Windows bereitgestellt wird.
  6. Suchen Sie die Wdsclient.dll-Datei, die Sie extrahiert haben, in Schritt 1. Kopieren Sie die Datei Wdsclient.dll in den Ordner Datenquellen am Speicherort bereitstellen, die Sie in Schritt 5 angegeben, und Ersetzen Sie die vorhandene Datei.
  7. Entladen Sie die WIM-Datei, die Sie durch alle Änderungen in Schritt 5 angegeben. Zum Beispiel können Sie den folgenden Befehl an der Eingabeaufforderung den Befehl ausführen:
    imagex.exe/commit / Entladen von <MountLocation>
    Hinweis: Die <MountLocation> Platzhalter steht für den Bereitstellungspunkt-Verzeichnis, in Schritt 5 angegeben.
  8. Fügen Sie die WIM-Datei wieder hinzu den WDS-Server. Zum Beispiel können Sie den folgenden Befehl an der Eingabeaufforderung den Befehl ausführen:
    wdsutil.exe /replace-image /image: <ImageName> /imagetype:boot /architecture: <Platform> /replacementimage /imagefile: <PathToBootWIM>
    Hinweis: Die <ImageName> Platzhalter stellt den Namen des Boot Bildes, das Sie angeben möchten dar. Ersetzen Sie die <Platform> Platzhalter mit X 86 , X 64 oder ia64 je nach Ihrer Situation. Die <PathToBootWIM> Platzhalter steht für die WIM-Datei, die Sie in Schritt 5 angegeben.
  9. Löschen Sie alle temporären Ordner.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Vista Service Pack 1.

Weitere Informationen

Informationen zu WDS finden Sie auf der folgenden Microsoft TechNet-Website:
http://technet2.microsoft.com/windowsserver2008/en/library/7d837d88-6d8e-420c-b68f-a5b4baeb52481033.mspx?mfr=true
Informationen über Windows-Vorinstallationsumgebung in Windows Vista finden Sie auf der folgenden Microsoft TechNet-Website:
http://technet.microsoft.com/en-us/windowsvista/aa905120.aspx
Weitere Informationen zum Windows Automated Installation Kit (Windows AIK) der folgenden Microsoft-Website:
http://www.microsoft.com/downloads/details.aspx?familyid=C7D4BC6D-15F3-4284-9123-679830D629F2&displaylang=en
Weitere Informationen Standardterminologie, die zur Beschreibung der Microsoft-Softwareupdates verwendet wird, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 937333 - Geändert am: Mittwoch, 21. Mai 2008 - Version: 3.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Vista Ultimate
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Enterprise 64-bit edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 937333
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