WDS Impossibile generare nomi di client pi¨ di 255, quando si utilizza WDS per distribuire Windows Vista

Traduzione articoli Traduzione articoli
Identificativo articolo: 937333 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si consideri lo scenario seguente. Si tenta di distribuire Windows Vista, utilizzare servizi di distribuzione Windows (WDS) in un ambiente di dominio Active. ╚ stato configurato il nuovo client Criteri di denominazione per WDS. Per rendere univoca ogni nome di client, le opzioni di denominazione automatiche si applicano un numero crescente ogni nuovo nome del client. ╚ ad esempio, utilizzare % [0] [n] # come l'espressione per il nuovo client Criteri di denominazione.

In questo scenario, WDS Impossibile generare nomi di client pi¨ di 255. Non Ŕ pertanto possibile aggiungere gli oggetti account computer pi¨ di 255 (MAO) nel dominio. Gli utenti possono installare Windows Vista su pi¨ di 255 computer client. Tuttavia, solo i primi 255 computer automaticamente vengono aggiunti al dominio. Non Ŕ pertanto possibile gestire centralmente la distribuzione Windows Vista per altri computer.

Cause

Questo problema si verifica a causa di una limitazione hardcoded nel file Wdsclient.dll.

Risoluzione

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack pi¨ recente per Windows Vista. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
935791Come ottenere il service pack pi¨ recente per Windows Vista

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Non Ŕ richiesto alcun prerequisito.

NecessitÓ di riavvio

Non Ŕ necessario riavviare il computer dopo avere applicato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
Windows Vista, versioni basate su 86 su x
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Wdsclient.dll6.0.6000.20602235,00818 Maggio 200710: 35x 86
Windows Vista, versioni a 64 bit
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Wdsclient.dll6.0.6000.20602250,88018 Maggio 200710: 24x 64

Informazioni sull'installazione di hotfix

Per applicare l'hotfix menzionato in questo articolo, attenersi alla seguente procedura:
  1. L'hotfix menzionato in questo articolo contiene un package CAB. Estrarre il file di Wdsclient.dll dal pacchetto CAB in una cartella temporanea. Per effettuare questa operazione, fare doppio clic sul pacchetto CAB.
  2. Installare Windows Automated Installation Kit (Windows AIK) o il Kit preinstallazione OEM di Windows (Windows OPK).
  3. Disattivare l'immagine di avvio sul server WDS per disattivare l'immagine di avvio per il download. Ad esempio, Ŕ possibile eseguire il seguente comando al prompt dei comandi di:
    wdsutil.exe /set-image /image: <ImageName> /imagetype:boot /architecture: <Platform> / enabled: nessun
    Nota Il <ImageName> segnaposto rappresenta il nome dell'immagine di avvio. Sostituire il <Platform> segnaposto con x 86 , x 64 o ia64 , a seconda della situazione.
  4. Esportare l'immagine di avvio dal server WDS. ╚ possibile, ad esempio, eseguire il comando seguente al prompt dei comandi:
    wdsutil.exe /export-image /image: <ImageName> /imagetype:boot /architecture: <Platform> /destinationimage /filepath: <PathToBootWIM>
    Nota Il <ImageName> segnaposto rappresenta il nome dell'immagine di avvio. Sostituire il <Platform> segnaposto con x 86 , x 64 o ia64 , a seconda della situazione. Il <PathToBootWIM> segnaposto rappresenta il file di formato Windows Imaging (WIM) a cui si desidera esportare l'immagine di avvio.
  5. Installare l'immagine di avvio esportati nel passaggio 4. Quando si esegue questa operazione, specificare un indice di 2 e specificare l'accesso in lettura e l'accesso in scrittura. Ad esempio, Ŕ possibile eseguire il comando seguente al prompt dei comandi:
    ImageX.exe /mountrw <PathToBootWIM><MountLocation>
    Nota il <PathToBootWIM> segnaposto rappresenta la posizione in cui Ŕ stata esportata l'immagine di avvio nel passaggio 4. Il <MountLocation> segnaposto rappresenta la posizione in cui si desidera montare l'immagine di avvio. Per ulteriori informazioni su questa operazione, vedere la documentazione disponibile in Windows OPK.
  6. Individuare il file di Wdsclient.dll che Ŕ stato estratto nel passaggio 1. Copiare il file Wdsclient.dll nella cartella di origine nel percorso di montaggio specificato nel passaggio 5 e sostituire il file esistente.
  7. Disinstallare il file WIM specificato nel passaggio 5 eseguendo il commit di tutte le modifiche. ╚ possibile, ad esempio, eseguire il comando seguente al prompt dei comandi:
    imagex.exe/commit / smontaggio <MountLocation>
    Nota Il <MountLocation> segnaposto rappresenta la posizione di montaggio specificato nel passaggio 5.
  8. Aggiungere il file WIM nuovamente il server WDS. ╚ possibile, ad esempio, eseguire il comando seguente al prompt dei comandi:
    wdsutil.exe /replace-image /image: <ImageName> /imagetype:boot /architecture: <Platform> /replacementimage /imagefile: <PathToBootWIM>
    Nota Il <ImageName> segnaposto rappresenta il nome dell'immagine di avvio che si desidera specificare. Sostituire il <Platform> segnaposto con x 86 , x 64 o ia64, a seconda della situazione. Il <PathToBootWIM> segnaposto rappresenta il file WIM specificato nel passaggio 5.
  9. Consente di eliminare tutte le cartelle temporanee.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema Ŕ stato innanzitutto corretto in Windows Vista Service Pack 1.

Informazioni

Per ulteriori informazioni su WDS, visitare il seguente sito Web Microsoft TechNet:
http://technet2.microsoft.com/windowsserver2008/en/library/7d837d88-6d8e-420c-b68f-a5b4baeb52481033.mspx?mfr=true
Per ulteriori informazioni sull'ambiente di preinstallazione di Windows in Windows Vista, visitare il seguente sito Web Microsoft TechNet:
http://technet.microsoft.com/en-us/windowsvista/aa905120.aspx
Per ulteriori informazioni su Windows Automated Installation Kit (Windows AIK), visitare il sito di Web di Microsoft:
http://www.microsoft.com/downloads/details.aspx?familyid=C7D4BC6D-15F3-4284-9123-679830D629F2&displaylang=en
Per ulteriori informazioni sulla terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 937333 - Ultima modifica: mercoledý 21 maggio 2008 - Revisione: 3.1
Le informazioni in questo articolo si applicano a:
  • Windows Vista Ultimate
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Chiavi:á
kbmt kbautohotfix kbvistasp1fix kbexpertiseinter kbwinvistapostrtmfix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB937333 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 937333
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com