Der Computer Host reagiert nicht mehr, wenn Sie versuchen, eine Datei in eine virtuelle Festplatte zu kopieren, die Sie mithilfe des VHDMount-Dienstprogramms in Virtual Server 2005 R2 SP1 bereitgestellt

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 937366 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Sie installieren Microsoft Virtual Server 2005 R2 Service Pack 1 (SP1).
  • Sie erstellen einen virtuellen Computer, der eine dynamische virtuelle Festplatte (VHD) verfügt.
  • Sie verwenden das Dienstprogramm VHDMount (Vhdmount.exe), um die VHD-Datei als virtuelle Festplatte in Windows-Betriebssystems bereitstellen.
  • Sie verwenden den Befehl Vhdmount/p an einer Eingabeaufforderung, um die VHD-Datei bereitstellen.
  • Sie haben eine Datei in die VHD-Datei kopieren. Die Datei, die Sie kopieren, ist größer als der physischen Festplatte auf dem Computer.
In diesem Szenario reagiert der Host-Computer möglicherweise nicht mehr (hängt).

Ursache

Dieses Problem tritt auf, weil die VHD-Datei und das Dateisystem auf dem Computer Host nicht erkennen, dass die physische Festplatte voll ist.

Abhilfe

Überprüfen Sie um dieses Problem zu vermeiden, ob der physikalische Datenträger genügend Festplattenspeicher verfügbar um die VHD-Datei bereitstellen und die erforderlichen Vorgänge durchzuführen hat. Wenn die VHD-Datei mit einer Rückgängig-Datenträger bereitgestellt wird (Dies ist die Default-Einstellung.), erforderlich freier Festplattenspeicher, der doppelt so groß die VHD-Datei ist.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Die VHD-Datei kommuniziert der Treiber Ebene auf das Dateisystem auf dem Computer Host. Die VHD-Datei kann daher nicht erkennen, dass die physische Festplatte voll ist. Darüber hinaus wird das Dateisystem auf der Host-Computer nicht erkannt, dass die physische Festplatte voll ist. Das Dateisystem interpretiert Fehler beim Schreiben als Datenträgerbeschädigung.

Hinweis: Wenn dieses Problem auftritt, wird das Dateisystem auf der Host-Computer nicht ordnungsgemäß freigegeben VHD-Dateihandle Wenn Sie den Kopiervorgang abgebrochen und dann Sie die VHD-Datei entladen. Daher müssen Sie den Host-Computer neu starten.

Eigenschaften

Artikel-ID: 937366 - Geändert am: Dienstag, 12. Juni 2007 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Virtual Server 2005 R2 Standard Edition
  • Microsoft Virtual Server 2005 R2 Enterprise Edition
Keywords: 
kbmt kbtshoot kbprb KB937366 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 937366
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com