L'ordinateur ordinateur hôte cesse de répondre lorsque vous essayez de copier un fichier vers un disque dur virtuel monté à l'aide l'utilitaire VHDMount dans Virtual Server 2005 R2 SP1

Traductions disponibles Traductions disponibles
Numéro d'article: 937366 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Envisagez le scénario suivant :
  • Vous installez Microsoft Virtual Server 2005 R2 Service Pack 1 (SP1).
  • Vous créez une machine virtuelle ayant un dynamique disque dur virtuel (VHD).
  • Vous utilisez l'utilitaire VHDMount (Vhdmount.exe) pour monter le VHD comme un disque virtuel dans le système d'exploitation Windows.
  • Vous utilisez la commande /p Vhdmount à partir d'une invite de commandes pour monter le VHD.
  • Copier un fichier dans le VHD. Le fichier que vous copiez est supérieure au disque dur physique sur l'ordinateur.
Dans ce scénario, l'ordinateur ordinateur hôte peut cesser de répondre (se bloquer).

Cause

Ce problème se produit car le VHD et le système de fichiers sur l'ordinateur ordinateur hôte ne reconnaissent pas que le disque dur physique est plein.

Contournement

Pour éviter ce problème, vérifiez que le disque physique dispose de suffisamment d'espace disque dur à monter le VHD et effectuer les opérations nécessaires. Si le VHD est montée avec un disque d'annulation (il s'agit du paramètre par défaut.), vous devez disposer espace disque dur est doubler la taille de la VHD.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Le VHD communique au niveau du pilote au système de fichiers sur l'ordinateur ordinateur hôte. Par conséquent, le VHD ne reconnaît pas que le disque dur physique est plein. En outre, le système de fichiers sur l'ordinateur ordinateur hôte ne reconnaît pas que le disque dur physique est plein. Le système de fichiers interprète l'échec d'écriture comme disque endommagé.

note Lorsque ce problème se produit, le système de fichiers sur l'ordinateur ordinateur hôte ne correctement libère pas le descripteur de fichier VHD lorsque vous annuler l'opération de copie, puis vous démontez le VHD. Par conséquent, vous devez redémarrer l'ordinateur ordinateur hôte.

Propriétés

Numéro d'article: 937366 - Dernière mise à jour: mardi 12 juin 2007 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Virtual Server 2005 R2 Standard Edition
  • Microsoft Virtual Server 2005 R2 Enterprise Edition
Mots-clés : 
kbmt kbtshoot kbprb KB937366 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 937366
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com