Help and Support

文書番号: 937379 - 最終更新日: 2007年12月4日 - リビジョン: 3.2

Games for Windows ゲームから Games for Windows - LIVE にサインインしようとすると "更新をダウンロードできません" エラー メッセージが表示される

重要: この記事には、レジストリの変更方法に関する情報が含まれています。変更前に必ずレジストリをバックアップしてください。問題が発生したときのためにレジストリの復元方法を確認しておく必要があります。レジストリのバックアップ、復元、および変更方法の詳細は、次のマイクロソフト サポート技術情報の記事を参照してください。
256986? (http://support.microsoft.com/kb/256986/ ) Microsoft Windows レジストリの説明
重要: この記事には、コンピューター上でセキュリティ設定を低くする方法や、セキュリティ機能をオフにする方法に関する情報が含まれています。特定の問題を回避するために、このような変更を行うことができます。これらの変更を行う前に、お客様の環境でこの回避方法を採用することによって伴うリスクを考慮することをお勧めします。この回避方法を実行する場合は、適切な手段を実行してシステムを保護してください。

目次

すべて展開する | すべて折りたたむ

現象

Games for Windows ゲームから Games for Windows - LIVE にサインインしようとすると、アップデート (更新) をダウンロードする必要があることが表示されます。しかし、アップデートはインストールされずに、次のエラー メッセージが表示され、Games for Windows - LIVE にサインインできません。
更新をダウンロードできません。

原因

この現象は、次の理由のうちのいずれかが原因で発生します。
  • PC に 2 つ以上のネットワーク アダプターが存在します。ファイアウォール クライアントがネットワーク アダプターの 1 つを使用してインターネットに接続し、Games for Windows - LIVE の接続に他方のネットワーク アダプターを使用しています。このとき、Games for Windows - LIVE ゲームがサービスに接続しようとしても、通信はインターネットへ届きません。
  • ファイアウォールまたはウイルス対策プログラムが TCP ポート (3074) の使用を妨げています。

対処方法

PC に 2 つ以上のネットワーク インターフェイス カードが存在する場合は、次の手順を表示される順番に実行します。PC に 1 つのネットワーク アダプターが存在する場合は、次の「方法 2」の手順を実行します。

方法 1: ネットワーク アダプターの接続の順番を変更する、または余分なネットワーク アダプターを無効にする

  1. Windows XP で [スタート]、[ファイル名を指定して実行] を順番にクリックし、「ncpa.cpl」と入力して [OK] をクリックします。

    Windows Vista で [スタート]
    元に戻す画像を拡大する
    スタート ボタン
    をクリックし、「ncpa.cpl」と入力して Enter キーを押します。
  2. [詳細設定] メニューの [詳細設定] をクリックします。
    注意: Windows Vista を使用しているときに [詳細設定] メニューが表示されない場合は、Alt キーを押します。これで、メニュー バーが表示されます。
    Windows Vista でこれ以降の手順を実行するには、アクセス許可が必要です。
  3. [接続] 領域の [アダプタとバインド] タブで、表示される一覧から使用する接続を選択し、矢印ボタンを使用して上方へ移動します。

    注意
    • [アダプタとバインド] タブは、ネットワーク サービスによってアクセスする順番で接続を一覧表示します。接続の順番は、TCP/IP または次に利用可能なプロトコルがネットワーク アダプターに使用する順番です。リモート アクセス接続の接続は、すべてのリモート アクセス接続に適用します。
    • [プロバイダの順序] タブは、PC のネットワーク プロバイダーの一覧を表示します。プロバイダーにアクセスする順番は、矢印ボタンを使用して変更します。PC がネットワークについての情報にアクセスする順番を変更できます。PC は、プロバイダーと他の接続を表示される順番で使用します。
  4. [OK] をクリックし、Games for Windows ゲームを使用します。同じ現象が引き続き発生する場合は、次の手順を実行します。
  5. Windows XP で [スタート]、[ファイル名を指定して実行] を順番にクリックし、「ncpa.cpl」と入力して [OK] をクリックします。

    Windows Vista で [スタート]
    元に戻す画像を拡大する
    スタート ボタン
    をクリックし、「ncpa.cpl」と入力して Enter キーを押します。
  6. 無効にするアダプターをマウスの右ボタンでクリックし、[無効] を選択します。
  7. [ネットワーク接続] ウィンドウを閉じます。
  8. Games for Windows ゲームを使用します。
同じ現象が引き続き発生する場合は、次の「方法 2」の手順を実行します。

方法 2: Windows Vista のファイアウォールの例外を設定する

警告: この回避方法を実行すると、使用しているコンピューターまたはネットワークに対する悪意のあるユーザーまたはウィルスなどの悪質なソフトウェアの攻撃を受けやすくなります。この回避方法はお勧めしませんが、自己責任でこの回避方法を実行できるように情報を提供しています。この回避方法は自己責任で使用してください。
注意: 使用するプログラムに必要かどうかわからないポートを開かないでください。
  1. Windows XP で [スタート]、[ファイル名を指定して実行] を順番にクリックし、「wscui.cpl」と入力して [OK] をクリックします。

    Windows Vista で [スタート]
    元に戻す画像を拡大する
    スタート ボタン
    をクリックし、「wscui.cpl」と入力して Enter キーを押します。
  2. [Windows ファイアウォール] をクリックします。
  3. [例外] タブの [プログラムおよびサービス] 一覧でプレイするゲームを見つけます。ゲームがファイアウォール経由で接続を有効にするチェック ボックスをオンにします。

    ゲームが一覧に表示されない場合は、ゲームを例外の一覧に追加します。[プログラムの追加]、[参照] を順番にクリックします。Games for Windows ゲームの実行可能ファイルを探し、[開く] をクリックします。たとえば、既定で Vista 用ヘイロー 2 の実行可能ファイルは、次の場所にインストールされています。
    C: \Program Files\Microsoft Games\Halo 2\Halo2.exe
  4. [OK] を 3 回クリックします。
同じ現象が引き続き発生する場合は、次の「方法 3」の手順を実行します。

方法 3: Games for Windows - LIVE のアップデートを手動でインストールする

  1. 次のマイクロソフトの Web サイトにアクセスします。
    http://www.microsoft.com/japan/games/gamesforwindows/live.mspx (http://www.microsoft.com/japan/games/gamesforwindows/live.mspx)
  2. [Support] をクリックします。
  3. [Get Games for Windows ? LIVE Support & Updates here] をクリックします。
  4. [Download the Latest Update] をクリックします。
  5. [Run] をクリックし、アップデートをダウンロードしてすぐにインストールします。または、[Save] をクリックし、アップデートをダウンロードして後からインストールします。
  6. アップデートのインストールが完了したら、Games for Windows - LIVE に再度接続します。

この資料は以下の製品について記述したものです。
  • Games for Windows ?LIVE
  • マイクロソフト ヘイロー 2
  • マイクロソフト シャドウラン
キーワード:?
kbxbox360japanportal kberrmsg kbgamesforwindowslive kbpubtypekc kbtshoot KB937379
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳