The Winsock connection fails when the program calls the setsockopt function in Windows Vista

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Article ID: 937385 - View products that this article applies to.
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SYMPTOMS

A program opens a Winsock connection on a Windows Vista-based computer. However, the Winsock connection fails when the program calls the setsockopt function. This problem occurs if the program uses Transport Data Interface (TDI) filter drivers.

When this problem occurs, some network applications may not function correctly. For example, a user cannot use Remote Assistance to receive assistance from a remote computer. Specifically, the Remote Assistance connection is dropped shortly after the user accepts the Remote Assistance invitation. Then, the user receives the following error message:
Windows Remote Assistance is closing. An unknown error occurred so the session was disconnected.
Try restarting your session. If you continue to get this message, contact your administrator or technical support.
Additionally, the following event is logged in the Application log:

Source: Microsoft-Windows-RemoteAssistance
Date: <Time>
Event ID: 3
Task Category: None
Level: Critical
Keywords:
User: <User>
Computer: <Computer>
Description: Application will terminate, a critical error was detected in <File Path>\novinterdialog.cpp Line <Line Number> Function OnErrorProc

CAUSE

This problem occurs because Windows Vista uses a compatibility layer that is called TDX to support TDI filter drivers. TDX generates an error when the setsockopt function is called.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 933049. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
933049 A Winsock connection may fail when the program that opens the connection calls the Setsockopt function in Windows Vista

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable2,00116-May-200713:49Not applicable
X86_c747f75f3c6389fabecd6877a7a75b06_31bf3856ad364e35_6.0.6000.20599_none_5346227e4369fccd.manifestNot applicable70216-May-200713:49Not applicable
X86_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.0.6000.20599_none_e888d5f2f84d9cca.manifestNot applicable4,88316-May-200713:50Not applicable
Tdx.sys6.0.6000.2059970,14416-May-200701:24x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_95e17de1e02f0eab165aa112a98155cd_31bf3856ad364e35_6.0.6000.20599_none_9b973c647a645444.manifestNot applicable70616-May-200713:49Not applicable
Amd64_microsoft-windows-tdi-over-tcpip_31bf3856ad364e35_6.0.6000.20599_none_44a77176b0ab0e00.manifestNot applicable5,15016-May-200713:54Not applicable
Update.mumNot applicable2,01316-May-200713:49Not applicable
Tdx.sys6.0.6000.2059991,64816-May-200701:51x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

TDI filter drivers are network drivers and transport drivers that antivirus products or antispyware products frequently use. Operating systems that are earlier than Windows Vista mostly use the TDI filter drivers. Windows Vista uses a compatibility layer that is called TDX to support the TDI filter drivers. For more information about TDI drivers, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn2.microsoft.com/en-us/library/aa505007.aspx
For more information about the setsockopt function, visit the following MSDN Web site:
http://msdn.microsoft.com/en-us/library/ms740476.aspx
For more information about the Windows Filtering Platform, visit the following Microsoft Web site:
http://www.microsoft.com/whdc/device/network/WFP.mspx
For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 937385 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Ultimate
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbwinvistapostrtmfix kbexpertiseinter kbbug kbfix kbHotfixServer kbqfe KB937385

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