Po pokuse o otvorenie programu Internet Explorer 7 sa zobrazí dialógové okno Preberanie súboru – upozornenie zabezpečenia

Preklady článku Preklady článku
ID článku: 937409 - Zobraziť produkty, ktorých sa tento článok týka.
Dôležité upozornenie: Tento článok obsahuje postupy, ktoré vedú k oslabeniu zabezpečenia počítača alebo k vypnutiu funkcií zabezpečenia v počítači. Vykonaním týchto zmien môžete vyriešiť špecifické problémy. Pred vykonávaním týchto zmien sa však odporúča vyhodnotiť riziká spojené s implementáciou tohto riešenia v konkrétnom prostredí. Ak implementujete toto riešenie, vykonajte všetky zodpovedajúce dodatočné opatrenia na ochranu počítača.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Nainštalujete kumulatívnu aktualizáciu zabezpečenia (máj 2007) pre program Internet Explorer (MS07-027) a potom sa pokúsite otvoriť program Windows Internet Explorer 7. Môže sa otvoriť dialógové okno Preberanie súboru – upozornenie zabezpečenia a môže sa zobraziť nasledujúce hlásenie:
Chcete uložiť tento súbor?
V dialógovom okne Preberanie súboru – upozornenie zabezpečenia sa zobrazí aj názov súboru „navcancl“. Po zatvorení tohto dialógového okna nie je možné spustiť program Internet Explorer 7.

PRICINA

Tento problém sa môže vyskytnúť v počítači s operačným systémom Windows Vista v prípade, ak sú splnené nasledujúce podmienky:
  • Priečinok Temporary Internet Files bol premiestnený mimo používateľskej hierarchie priečinkov. Priečinok Temporary Internet Files bol napríklad premiestnený na iný zväzok.
  • Je povolené filtrovanie neoprávneného získavania údajov.
  • Je povolený chránený režim.
V takomto prípade má priečinok Temporary Internet Files nedostatočné povolenia v novom umiestnení. Preto sa filtrovanie neoprávneného získavania údajov nemôže spustiť. Keď sa vyskytne tento problém, program Internet Explorer 7 sa nemôže spustiť a otvorí sa dialógové okno Preberanie súboru – upozornenie zabezpečenia.

Tento problém sa môže taktiež vyskytnúť v počítači so systémom Microsoft Windows XP Service Pack 2 (SP2) alebo so systémom Microsoft Windows Server 2003 v prípade, ak je splnená niektorá z nasledujúcich podmienok:
  • Priečinok obsahujúci priečinok Temporary Internet Files bol odstránený.
  • Zmenili sa povolenia pre priečinok Temporary Internet Files.
V tomto prípade nie je možné zapisovať do priečinka.

RIEŠENIE

Ak chcete tento problém vyriešiť, použite jeden z nasledujúcich postupov.

Postup 1: Premiestnite priečinok Temporary Internet Files naspäť do pôvodného umiestnenia

Ak chcete vykonať postup 1 v počítači so systémom Windows Vista, postupujte takto:
  1. Kliknite na položku Štart
    Zbaliť tento obrázokRozbaliť tento obrázok
    tlačidlo Štart
    , zadajte hodnotu Možnosti siete Internet do poľa Vyhľadať a potom kliknite na položku Možnosti siete Internet v zozname Programy.
  2. Na karte Všeobecné kliknite na položku Nastavenie v časti História prehľadávania.
  3. Kliknite na tlačidlo Premiestniť priečinok.
  4. V časti Vyberte priečinok, do ktorého sa budú pridávať položky vyhľadajte nasledujúci priečinok:
    C:\Users\názov_používateľského_konta\AppData\Local\Microsoft\Windows
  5. Dvakrát kliknite na tlačidlo OK.
  6. Keď sa zobrazí nasledujúce hlásenie, kliknite na položku Áno:
    Systém Windows vás teraz odhlási, aby sa mohlo dokončiť premiestnenie dočasných internetových súborov. Chcete pokračovať?
  7. Znova sa prihláste do systému Windows Vista.
Ak chcete vykonať postup 1 v počítači so systémom Windows XP alebo v počítači so systémom Windows Server 2003, postupujte takto:
  1. Kliknite na položku Štart, potom na položku Spustiť, zadajte hodnotu inetcpl.cpl a potom kliknite na položku OK.
  2. Na karte Všeobecné kliknite na položku Nastavenie v časti História prehľadávania.
  3. Kliknite na tlačidlo Premiestniť priečinok.
  4. Na navigačnej table Vyberte priečinok, do ktorého sa budú pridávať položky vyhľadajte nasledujúci priečinok:
    C:\Documents and Settings\meno_používateľa\Local Settings
  5. Kliknite na položku OK, potom na položku Použiť a potom kliknite na položku OK.

Postup 2: Udelenie povolení pre priečinok Temporary Internet Files

Ak chcete vykonať postup 2 v počítači so systémom Windows Vista, postupujte takto:
  1. Kliknite na položku Štart
    Zbaliť tento obrázokRozbaliť tento obrázok
    tlačidlo Štart
    , zadajte hodnotu Možnosti siete Internet do poľa Vyhľadať a potom kliknite na položku Možnosti siete Internet v zozname Programy.
  2. Na karte Všeobecné kliknite na položku Nastavenie v časti História prehľadávania.
  3. Kliknite na položku Zobraziť súbory. Otvorí sa priečinok Temporary Internet Files.
  4. V poli Adresa programu Windows Prieskumník kliknite na názov priečinka, ktorý sa nachádza pred výrazom Temporary Internet Files.
  5. Kliknite na položku Usporiadať a potom na položku Vlastnosti.
  6. Na karte Zabezpečenie kliknite na položku Upraviť.
  7. V poli Názvy skupín alebo mená používateľov kliknite na meno príslušného používateľa. Ak sa meno príslušného používateľa v zozname nenájde, postupujte takto:
    1. Kliknite na tlačidlo Pridať.
    2. Do poľa Zadajte názvy objektov, ktoré chcete vybrať zadajte meno príslušného používateľa a potom kliknite na položku OK.
    3. V poli Názvy skupín alebo mená používateľov kliknite na meno príslušného používateľa.
  8. V poli Povolenie pre meno_používateľa kliknutím začiarknite políčko Úplný prístup v stĺpci Povoliť.
  9. Kliknite na tlačidlo Použiť a potom kliknite na tlačidlo OK.
  10. Zatvorte program Windows Prieskumník.
  11. Dvakrát kliknite na tlačidlo OK.
  12. Spustite program Internet Explorer 7.
Ak chcete vykonať postup 2 v počítači so systémom Windows XP alebo v počítači so systémom Windows Server 2003, postupujte takto:
  1. Kliknite na položku Štart, potom na položku Spustiť, zadajte hodnotu inetcpl.cpl a potom kliknite na položku OK.
  2. Na karte Všeobecné kliknite na položku Nastavenie v časti História prehľadávania.
  3. Kliknite na položku Zobraziť súbory.
  4. V programe Windows Prieskumník sa premiestnite do priečinka, ktorý obsahuje priečinok Temporary Internet Files.
  5. Na pravej table kliknite pravým tlačidlom myši na prázdnu oblasť a potom kliknite na položku Vlastnosti.
  6. Na karte Zabezpečenie kliknite na meno príslušného používateľa v poli Názvy skupín alebo mená používateľov. Ak sa meno príslušného používateľa v zozname nenájde, postupujte takto:
    1. Kliknite na tlačidlo Pridať.
    2. Do poľa Zadajte názvy objektov, ktoré chcete vybrať zadajte meno príslušného používateľa a potom kliknite na položku OK.
    3. V poli Názvy skupín alebo mená používateľov kliknite na meno príslušného používateľa.
  7. V poli Povolenie pre meno_používateľa kliknutím začiarknite políčko Úplný prístup v stĺpci Povoliť.
  8. Kliknite na tlačidlo Použiť a potom kliknite na tlačidlo OK.
  9. Zatvorte program Windows Prieskumník.
  10. Dvakrát kliknite na tlačidlo OK.
  11. Spustite program Internet Explorer 7.

STAV

Spoločnosť Microsoft potvrdila, že ide o problém, ktorý sa týka produktov spoločnosti Microsoft uvedených v časti „Vzťahuje sa na“.

DALSIE INFORMACIE

Upozornenie: Toto riešenie môže oslabiť zabezpečenie počítača alebo siete voči útokom zlomyseľných používateľov alebo nebezpečnému softvéru, ako sú napríklad vírusy. Toto riešenie sa neodporúča, no poskytujeme tieto informácie, s pomocou ktorých môžete riešenie implementovať podľa vlastného uváženia. Toto riešenie používate na vlastné riziko.

Tento problém môžete vyriešiť aj vypnutím filtrovania neoprávneného získavania údajov alebo vypnutím chráneného (zabezpečeného) režimu. Neodporúčame však, aby ste zakazovali tieto nástroje na zabezpečenie.

Vlastnosti

ID článku: 937409 - Posledná kontrola: 30. apríla 2010 - Revízia: 1.5
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Windows Internet Explorer 7, pri použití s produktom:
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Home Basic 64-bit edition
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Business
    • Windows Vista Business N 64-bit Edition
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Starter
    • Windows Vista Ultimate
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
Kľúčové slová: 
kbmsnreachportal kbtshoot kbprb KB937409

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com