When you try to send an e-mail message in which a user name or a recipient name contains quotation marks, the e-mail message is delivered to the Undeliverable folder in the Microsoft Dynamics CRM mailbox

Article translations Article translations
Article ID: 937530 - View products that this article applies to.
The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to send an e-mail message in which a user name or a recipient name contains quotation marks, the Microsoft Dynamics CRM-Exchange E-mail Router in Microsoft Dynamics CRM 3.0 cannot deliver the e-mail message. Instead, the e-mail message is delivered to the Undeliverable folder in the Microsoft Dynamics CRM mailbox. For example, this problem occurs if an e-mail message contains a user or a recipient such as the following:
Hite, Douglas "Doug"

CAUSE

This problem occurs because the Router cannot correctly parse a name that contains quotation marks. The Router cannot create the e-mail activity. Therefore, the Router delivers the message to the Undeliverable folder in the Microsoft Dynamics CRM mailbox.

RESOLUTION

This problem was corrected in Microsoft Dynamics CRM 3.0 Update Rollup 3.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935364Update Rollup 3 is available for Microsoft Dynamics CRM 3.0

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Microsoft Dynamics CRM server

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crmmsg.dll1.2.3297.12316,08829-Mar-200720:18x86
Crmnativeinteropproxy.dll3.0.5300.16853,399,18415-Oct-200718:39x86
Mscrmcustom.dll3.0.5300.1656181,09622-Aug-200703:47x86
Crmhotfix.cdfNot Applicable1,01415-Oct-200719:02Not Applicable
Mscrmcustom.dll3.0.5300.1656181,09622-Aug-200703:47x86
Updspapi.dll6.1.22.0371,93629-Mar-200705:18x86

Microsoft Dynamics CRM 3.0 client for Microsoft Office Outlook Compatibility Update

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Setup.xmlNot Applicable1,18915-Oct-200719:12Not Applicable
V3cclientpatch30.mspNot Applicable500,22415-Oct-200719:35Not Applicable
Crmnativeinteropproxy.dll3.0.5300.16853,399,18415-Oct-200718:39x86

Microsoft Dynamics CRM 3.0 client for Microsoft Office Outlook

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crmmsg.dll1.2.3297.12316,08829-Mar-200720:18x86
Crmnativeinteropproxy.dll3.0.5300.16853,399,18415-Oct-200718:41x86
Mscrmcustom.dll3.0.5300.1656181,09622-Aug-200703:47x86
Crmhotfix.cdfNot Applicable1,01415-Oct-200719:01Not Applicable
Mscrmcustom.dll3.0.5300.1656181,09622-Aug-200703:47x86
Updspapi.dll6.1.22.0371,93629-Mar-200705:18x86

Installation information

Install this hotfix on computers that are running the Microsoft Dynamics CRM 3.0 server and the Microsoft Dynamics CRM 3.0 client for Outlook.

Prerequisites

You must have the Microsoft Dynamics CRM 3.0 server and the Microsoft Dynamics CRM 3.0 client for Outlook installed to apply this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

Removal information

To remove this hotfix from a computer that is running Windows Server 2003, Windows XP, or Microsoft Windows 2000, use Add or Remove Programs in Control Panel. System administrators can use the Spuninst.exe tool to remove this hotfix from a computer that is running Windows Server 2003, Windows XP, or Windows 2000.

The Spuninst.exe tool is located in the %Windir%\$NTUninstallKB937530$\Spuninst folder.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
887283 Microsoft Business Solutions CRM software hotfix and update package naming standards

Properties

Article ID: 937530 - Last Review: April 3, 2008 - Revision: 2.3
APPLIES TO
  • Microsoft CRM 3.0
  • Microsoft CRM client for Microsoft Office Outlook, when used with:
    • Microsoft CRM 3.0
Keywords: 
kbautohotfix kbmbsemail kbhotfixserver kbqfe kbmbsmigrate KB937530

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com