Error messages when you try to synchronize a Windows Mobile device to Exchange Server 2003 on a Windows SBS 2003-based computer

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Article ID: 937635 - View products that this article applies to.
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Symptoms

You are running Microsoft Exchange Server 2003 on a Microsoft Windows Small Business Server (Windows SBS) 2003-based computer. However, when you try to synchronize a Microsoft Windows Mobile 5.0-based mobile device to Exchange Server 2003, the synchronization operation fails. Additionally, the following error messages are logged in the Application log on the Windows SBS-based computer:

Error message 1
Event Source: Server ActiveSync
Event ID: 3012
User: User_Account
Description: An error occurred while accessing the Active Directory for user [Internet Guest Account]. Information cannot be retrieved from Active Directory due to an unknown error. Verify that the Exchange ActiveSync Server can communicate with Active Directory, and that the user has a valid account.
Error message 2
Event Source: Server ActiveSync
Event ID: 3005
Description: Unexpected Exchange mailbox Server error: Server: [Internal Domain name] User: [Email address of the user] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly

Cause

This issue may occur if one or more following conditions are true:
  • The authentication method is incorrect for the virtual directories that are used by Microsoft ActiveSync.
  • The application name points to an incorrect entry in the Outlook Mobile Access virtual directory.
  • The application name points to an incorrect entry in the Microsoft-Server-ActiveSync virtual directory.
  • An incorrect application pool is associated with the virtual directories that are used by ActiveSync.

Resolution

To resolve this issue, make sure that the Exchange virtual directories settings are correct.

Note The virtual directories that are used by ActiveSync may still have incorrect settings even after you have recreated the virtual directories.

To make sure that the virtual directory settings are correct, follow these steps:
  1. Start the Internet Information Services (IIS) Microsoft Management Server (MMS) snap-in on the Windows SBS 2003-based computer.
  2. Expand Server_Name\Web Sites\Default Web Site.
  3. Right-click Exchange-OMA, and then follow these steps:
    1. Verify the following settings on the Virtual Directory tab:
      • The following check boxes are selected:
        • Script source access
        • Read
        • Write
        • Directory browsing
        • Log visits
        • Index this resource
      • Application name is unavailable, and Default Application is listed.
      • The Execute permissions setting is None.
      • The Application pool setting is unavailable, and ExchangeApplicationPool is listed.
    2. Verify the following settings on the Directory Security tab:
      • The Enable anonymous access check box is not selected.
      • The Integrated Windows authentication check box is selected.
      • The Basic authentication check box is selected.
      • The Require secure channel (SSL) check box is not selected.
    3. Close the Exchange-OMA Properties dialog box.
  4. Right-click OMA, and then follow these steps:
    1. Verify the following settings on the Virtual Directory tab:
      • The following check boxes are selected:
        • Read
        • Log visits
        • Index this resource
      • The Application name setting is /LM/W3SVC/1/root/OMA.
      • The Execute permissions setting is Scripts only.
      • The Application pool setting is ExchangeMobileBrowseApplicationPool.
    2. Verify the following settings on the Directory Security tab:
      • The Enable anonymous access check box is not selected.
      • The Integrated Windows authentication check box is not selected.
      • The Basic authentication check box is selected.
      • The Require secure channel (SSL) check box is not selected.
    3. Close the OMA Properties dialog box.
  5. Right-click Microsoft-Server-ActiveSync, and then follow these steps:
    1. Verify the following settings on the Virtual Directory tab:
      • The following check boxes are selected:
        • Log visits
        • Index this resource
      • The Application name setting is /LM/W3SVC/1/root/Microsoft-Server-ActiveSync.
      • The Execute permissions setting is Scripts and Executables.
      • The Application pool setting is ExchangeApplicationPool.
    2. Verify the following settings on the Directory Security tab:
      • The Enable anonymous access check box is not selected.
      • The Integrated Windows authentication check box is not selected.
      • The Basic authentication check box is selected.
      • The Require secure channel (SSL) check box is not selected.
  6. Run the iisreset /noforce computer_name command to restart IIS on the Windows SBS 2003-based computer.

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Properties

Article ID: 937635 - Last Review: September 22, 2013 - Revision: 4.0
Applies to
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft ActiveSync 4.5
  • Windows Mobile 6.5 Standard
Keywords: 
kbprb kbtshoot kbexpertiseadvanced KB937635

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