Message d'erreur lorsque vous utilisez le Gestionnaire de déploiement de Microsoft Dynamics CRM 3.0 pour modifier un compte d'utilisateur dans Active Directory: «une erreur s'est produite lors du changement de compte d'utilisateur»

Traductions disponibles Traductions disponibles
Numéro d'article: 937660 - Voir les produits auxquels s'applique cet article
Le correctif abordé dans cet article n'est pas disponible pour la version en chinois de Microsoft Dynamics CRM ou pour la version japonaise de Microsoft Dynamics CRM.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous utilisez le Gestionnaire de déploiement de Microsoft Dynamics CRM 3.0 pour modifier un compte d'utilisateur dans le service d'annuaire Active Directory, vous recevez message d'erreur suivantes :
Erreur lors du changement de compte d'utilisateur.
Remarque Le compte d'utilisateur dans Active Directory est lié à un utilisateur Microsoft Dynamics CRM.

Ce problème se produit si les conditions suivantes sont remplies :
  • Vous ne disposer aucuns des droits administrateur de domaine.
  • L'implémentation de Microsoft Dynamics CRM utilise la clé de Registre
    AutoGroupManagementOff
    . Cette clé de Registre empêche Microsoft Dynamics CRM d'effectuer des mises à jour dans Active Directory.

Cause

Ce problème se produit car le Gestionnaire de déploiement ne vérifie pas la clé de Registre
AutoGroupManagementOff
lorsque vous modifiez le compte d'utilisateur dans Active Directory.

Résolution

Ce problème a été corrigé dans Microsoft Dynamics CRM 3.0 Update Rollup 3.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
935364Le correctif cumulatif 3 est disponible pour Microsoft Dynamics CRM 3.0
Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contient ce correctif.

Si le correctif est disponible pour téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle de Microsoft et de support pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si n'importe quelle résolution des problèmes sont requis, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète de numéros de téléphone Microsoft Services de support technique ou à créer une demande de service distincte, site Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.

Informations sur les fichiers

La version anglaise de ce correctif dispose les attributs de fichier (ou version ultérieure fichier) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers figurent en temps universel (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour connaître la différence entre l'UTC et l'heure locale, utilisez l'onglet fuseau horaire de l'élément date et heure dans le Panneau de configuration.

Serveur Microsoft Dynamics CRM 3.0

Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Crmmsg.dll1.2.3297.12316,08829-Mar-200720 : 18x 86
Mscrmcustom.dll3.0.5300.1605179,56029-Mar-200720 : 18x 86
Sdtransform.dll3.0.5300.1639128,36021-07-200702 : 01x 86
Crmhotfix.CDFNon applicable99423-07-200700 : 19Non applicable
Mscrmcustom.dll3.0.5300.1605179,56029-Mar-200720 : 18x 86
Updspapi.dll6.1.22.0371,93629-Mar-200705 : 18x 86

Informations sur l'installation

Installer ce correctif sur des ordinateurs qui exécutent le serveur Microsoft Dynamics CRM 3.0 et le client Microsoft Dynamics CRM 3.0 pour Microsoft Office Outlook.

Après avoir appliqué le correctif, vérifiez que la valeur de Registre AutoGroupManagementOff sous la clé de Registre suivante est définie sur 1 :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

Conditions préalables

Vous devez disposer cumulatif 2 pour Microsoft Dynamics CRM 3.0 pour appliquer ce correctif. Pour plus d'informations sur le correctif n ° 2, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
927751Le correctif cumulatif 2 pour Microsoft Dynamics CRM 3.0 est disponible

La nécessité de redémarrer

Si vous êtes invité, redémarrez l'ordinateur après avoir installé le correctif.

Informations sur la suppression

Pour supprimer ce correctif sur un ordinateur qui exécute Windows Server 2003, Windows XP ou Microsoft Windows 2000, utilisez Ajout / Suppression de programmes dans le Panneau de configuration.Les administrateurs système peuvent utiliser l'outil Spuninst.exe pour supprimer ce correctif à partir d'un ordinateur qui exécute Windows Server 2003, Windows XP ou Windows 2000.

L'utilitaire Spuninst.exe se trouve dans le dossier %Windir%\$NTUninstallKB937660$\Spuninst.

Plus d'informations

Par défaut, la valeur de Registre AutoGroupManagementOff est définie à 0. Cela signifie que la fonctionnalité AutoGroupManagement est activée. Dans ce cas, lorsque vous remappez un utilisateur CRM à partir d'un compte Active Directory à l'autre, CRM va automatiquement supprimer l'ancien compte utilisateur Active Directory du groupe UserGroup de CRM et ajouter le nouveau compte d'utilisateur Active Directory à ce groupe. Cette action requiert des droits d'administrateur de domaine. Si vous ne disposez pas des droits d'administrateur, message d'erreur décrite ci-dessus s'affiche. Si la fonctionnalité AutoGroupManagement est désactivée et vous remappez à un utilisateur, les utilisateurs concernés ne sont pas automatiquement ajoutés ou supprimés du groupe UserGroup dans CRM. Au lieu de cela, le nom d'utilisateur dans la base de données config est modifié. Dans ce scénario, un administrateur de domaine doit ajouter et supprimer manuellement les utilisateurs affectés du groupe UserGroup.

Pour plus d'informations concernant la terminologie utilisée pour décrire les mises à jour logicielles, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la base de connaissances Microsoft :
824684Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
887283Normes d'attribution de noms packages de mise à jour et correctifs logiciels Microsoft Business Solutions CRM

Propriétés

Numéro d'article: 937660 - Dernière mise à jour: jeudi 3 avril 2008 - Version: 2.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft CRM 3.0
Mots-clés : 
kbmt kbautohotfix kberrmsg kbhotfixserver kbqfe kbmbsmigrate KB937660 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 937660
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com