Messaggio di errore quando si utilizza Gestione distribuzione di Microsoft Dynamics CRM 3.0 per modificare un account utente in Active Directory: "Errore durante la modifica di account utente"

Traduzione articoli Traduzione articoli
Identificativo articolo: 937660 - Visualizza i prodotti a cui si riferisce l?articolo.
L'hotfix descritto in questo articolo non è disponibile per la versione cinese di Microsoft Dynamics CRM o per la versione giapponese di Microsoft Dynamics CRM.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si utilizza Gestione distribuzione di Microsoft Dynamics CRM 3.0 per modificare un account utente nel servizio directory di Active Directory, viene visualizzato il seguente messaggio di errore:
Errore durante la modifica di account utente.
Nota L'account utente in Active Directory è collegato a un utente di Microsoft Dynamics CRM.

Questo problema si verifica se le seguenti condizioni sono vere:
  • Non sono i diritti di amministratore di dominio.
  • L'implementazione di Microsoft Dynamics CRM utilizza la chiave del Registro di sistema di
    AutoGroupManagementOff
    . Questa chiave del Registro di sistema impedisce l'esecuzione di aggiornamenti in Active Directory in Microsoft Dynamics CRM.

Cause

Questo problema si verifica perché Gestione distribuzione non controlla la chiave del Registro di sistema di
AutoGroupManagementOff
quando si modifica l'account utente in Active Directory.

Risoluzione

Questo problema è stato corretto in Microsoft Dynamics CRM 3.0 Update Rollup 3.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
935364L'aggiornamento cumulativo 3 è disponibile per Microsoft Dynamics CRM 3.0
È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.

Server Microsoft Dynamics CRM 3.0

Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Crmmsg.dll1.2.3297.12316,08829 Marzo 200720: 18x 86
Mscrmcustom.dll3.0.5300.1605179,56029 Marzo 200720: 18x 86
Sdtransform.dll3.0.5300.1639128,36021-07-200702: 01x 86
Crmhotfix.cdfNon applicabile99423-Lug-200700: 19Non applicabile
Mscrmcustom.dll3.0.5300.1605179,56029 Marzo 200720: 18x 86
Updspapi.dll6.1.22.0371,93629 Marzo 200705: 18x 86

Informazioni sull'installazione

Installare questo aggiornamento rapido (hotfix) nei computer che eseguono il server di Microsoft Dynamics CRM 3.0 e il client Microsoft Dynamics CRM 3.0 per Microsoft Office Outlook.

Dopo avere applicato l'hotfix, è necessario verificare che il valore di registro di sistema di AutoGroupManagementOff nella seguente chiave del Registro di sistema sia impostato su 1:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

Prerequisiti

È necessario aggiornamento cumulativo 2 per Microsoft Dynamics CRM 3.0 per applicare questo aggiornamento rapido (hotfix). Per ulteriori informazioni sull'aggiornamento cumulativo 2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
927751Aggiornamento cumulativo 2 per Microsoft Dynamics CRM 3.0 è disponibile

Necessità di riavvio

Se richiesto, riavviare il computer dopo avere installato l'hotfix.

Informazioni sulla rimozione

Per rimuovere questo aggiornamento rapido (hotfix) da un computer che esegue Windows Server 2003, Windows XP o Microsoft Windows 2000, utilizzare lo strumento Installazione applicazioni nel Pannello di controllo.Gli amministratori di sistema è in possono di utilizzare lo strumento Spuninst.exe per rimuovere questo aggiornamento rapido (hotfix) da un computer che esegue Windows Server 2003, Windows XP o Windows 2000.

Lo strumento di Spuninst.exe si trova nella cartella %Windir%\$NTUninstallKB937660$\Spuninst.

Informazioni

In base all'impostazione predefinita, il valore di registro di sistema di AutoGroupManagementOff è impostato su 0. In tal caso che la funzionalità AutoGroupManagement sia attivata. In questo caso, quando si modifica un utente di CRM da un account di Active Directory a un altro il mapping, CRM verranno automaticamente rimuovere il vecchio account utente Active Directory dal gruppo UserGroup in CRM e aggiungere il nuovo account utente Active Directory a questo gruppo. Questa azione richiede diritti di amministratore di dominio. Se non si dispone dei diritti di amministratore, verrà visualizzato il messaggio di errore descritto sopra. Se la funzionalità di AutoGroupManagement è disattivata e si modifica un utente il mapping, gli utenti interessati non viene automaticamente aggiunta o rimozione dal gruppo UserGroup in CRM. Al contrario, l'ID utente nel database di configurazione viene modificata. In questo scenario, un amministratore di dominio aggiungere e rimuovere manualmente gli utenti interessati dal gruppo UserGroup.

Per ulteriori informazioni sulla terminologia utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
887283Aggiornamenti e hotfix software Microsoft Business Solutions CRM standard di denominazione dei pacchetti

Proprietà

Identificativo articolo: 937660 - Ultima modifica: giovedì 3 aprile 2008 - Revisione: 2.3
Le informazioni in questo articolo si applicano a:
  • Microsoft CRM 3.0
Chiavi: 
kbmt kbautohotfix kberrmsg kbhotfixserver kbqfe kbmbsmigrate KB937660 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 937660
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com