"RPC exception 1726 occurred in session 10" error when you review the Application log on the computer that is running Microsoft Dynamics AX AOS services

This article provides a resolution for the errors that occur when you review the Application log on a computer that is running Microsoft Dynamics AX 4.0 Application Object Server (AOS) services.

Applies to:   Microsoft Dynamics AX
Original KB number:   937873

Symptoms

When you review the Application log on a computer that is running Microsoft Dynamics AX 4.0 Application Object Server (AOS) services, you may see error messages that resemble the following:

Error message 1

Event Type:Information
Event Source:Dynamics Server 17
Date:7/4/2007
Time:12:30:14 PM
Event Category:None
Description:
Object Server 01: RPC error: RPC exception 1726 occurred in session 10

Error message 2

Event Type:Information
Event Source:Dynamics Server 01
Event Category:None
Event ID:110
Date:7/4/2007
Time:12:30:33 AM
User:N/A
Computer: ComputerName
Description:
Object Server 01: No ping from 10. Terminating the session.

The first error message may be associated with the second error message. Until the AOS server ends session 10, each session that returns RPC error messages will stop responding. If too many sessions stop responding and return RPC error messages, the AOS server may shut down.

Cause

This problem may occur because users exit Microsoft Dynamics AX ungracefully. For example, users end the Microsoft Dynamics AX process by using Task Manager.

RPC 1726 is a general connection error message. However, the RPC 1726 error message may be associated with the No ping from 10. Terminating the session error message. In this case, the problem is typically caused by users exiting Microsoft Dynamics AX ungracefully.

Resolution

If you experience this problem on the Microsoft Dynamics AX client, do not exit the client by pressing Ctrl+Alt+Del. We recommend that you use Ctrl+Break and then wait for the system to become responsive again or contact the Microsoft Dynamics AX administrator or another user who has rights to the online users form. The administrator or the other user can select End Session to shut down the client session.

More information

If you experience this problem on the AOS server, it is important to determine which session is the cause and what the users are doing to cause the problem.

To do this, run the following script:

select * from sysuserlog where logouttime = 0 and sessionid = <X>

Note

Replace <X> with the session that is indicated in the RPC error message. From the results of the query, note the USERID and COMPUTERNAME columns. The column values indicate who is logging in and from where.

Typically, RPC exceptions are caused by ungracefully exiting the application. However, the exceptions may also indicate that a business process is hanging or taking a long time.

References

For more information, see How to find a user ID that is associated with a session ID in an error message in the Application log on the AOS server in Microsoft Dynamics AX: "RPC error: RPC exception 1726 occurred in session <SessionID>".