Después de instalar SMS 2003 SP3, el proceso Wmiprvse.exe puede generar CPU en los equipos cliente durante las operaciones de inventario de hardware

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Síntomas

Tenga en cuenta la situación siguiente:
  • Instalar Microsoft Systems Management Server 2003 Service Pack 3 (SP3).
  • El Asesor de activos de SMS 2003 SP3 realiza operaciones de inventario de hardware.
En este escenario, el proceso Wmiprvse.exe en equipos cliente de la organización puede generar la CPU. A veces, el uso de CPU que llegue al 100 por ciento.

Causa

Este problema puede producirse si se cumplen las condiciones siguientes:
  • Un archivo que aparece en una de las ubicaciones de inicio en el equipo cliente contiene varios idiomas. Por ejemplo, un archivo de programa que incluye idiomas mixtos se muestra en la siguiente ubicación de inicio en el equipo cliente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
  • La configuración regional actual del usuario en el equipo cliente no coincide con cualquiera de los idiomas que se utilizan en el archivo desde la ubicación de inicio (el archivo que se describe en la viñeta anterior).
  • La clase SMS_AutoStartSoftware está habilitada en el archivo SMS_DEF.MOF.

    Nota Para obtener más información acerca de cómo determinar si está habilitada esta clase, vea la sección "Solución".
La clase SMS_AutoStartSoftware no controla correctamente estas condiciones. En este escenario, la clase SMS_AutoStartSoftware entra en un bucle. Por tanto, la operación de inventario genera CPU en el equipo cliente.

Nota La clase SMS_AutoStartSoftware se incluye con SMS 2003 SP3.

Las siguientes tres clases también pueden ocasionar este problema cuando se deben procesar un archivo que incluye varios idiomas y cuando la configuración regional del usuario actual no coincide con cualquiera de los lenguajes en el archivo:
  • SMS_BrowserHelperObject
  • SMS_InstalledSoftware
  • SMS_SoftwareShortcut

Solución

El archivo siguiente está disponible para descargarlo del Centro de descarga de Microsoft:

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Download the 937882 package now.

Para obtener información adicional acerca de cómo descargar los archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus. con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a prevenir que se hagan cambios no autorizados.

Instrucciones de instalación

Esta revisión sólo debe instalarse en equipos cliente SMS afectados. Sitio de SMS servidores o servidores que alojan una función de SMS, como un punto de ubicación de servidor (SLP), un punto de acceso de cliente (CAP) o un punto de administración (MP), no requieren esta revisión.

Para simplificar la distribución de esta revisión, el programa de instalación de la revisión crea automáticamente un paquete y un programa que contiene el archivo SMS2003AC-SP3 KB937882 x86.msp. El archivo de SMS2003-SP3-KB937882-X 86-enu.exe sólo crea el paquete y el programa. Para poder instalar correctamente el paquete de revisiones en clientes avanzados de SMS, debe crear un anuncio y el destino todos los clientes SMS 2003 SP3 avanzadas para la distribución. Para ello, siga estos pasos:
  1. Haga doble clic en el archivo SMS2003-SP3-KB937882-X 86-ENU.exe y, a continuación, siga las instrucciones para crear el paquete y el programa.
  2. Haga clic en Inicio , haga clic en Todos los programas , haga clic en Systems Management Server y, a continuación, haga clic en SMS Administrator Console .
  3. En la consola de administrador de SMS, expanda Packages , haga clic con el botón secundario del mouse en KB937882 - Advanced Client Hotfix - C 1 1 , seleccione Todas las tareas y, a continuación, haga clic en Distribute Software .
  4. Siga las instrucciones en Distribute Software Wizard para anunciar e implementar el paquete de hotfix.

    Para obtener más información acerca de los métodos que puede utilizar para instalar este paquete de hotfix, vea el cuadro de diálogo titulado aplicar revisiones a clientes avanzados SMS en el Asistente para distribuir software.
Nota No es necesario realizar un sitio SMS restablecerá después de instalar este hotfix.

Si desea instalar manualmente el hotfix en un equipo de cliente SMS, puede instalar el archivo SMS2003AC-SP3 KB937882 x86.msp desde la línea de comandos en el equipo cliente SMS, como sigue:

msiexec.exe /P SMS2003AC-KB891073-X86.msp /L * v %temp% \ SMS2003AC-KB891073-X86.log /q REINSTALL = ALL REINSTALLMODE = mous

Nota El marcador de posición %temp% es la ubicación del archivo de registro de instalación y el marcador de posición SMS2003AC-KB891073-X86.log es el nombre del archivo de registro de instalación.

Esta revisión sólo se aplica a entornos que usan la versión en inglés estadounidense de SMS 2003 SP3. Esta revisión ya se incluye en SMS 2003 International Client Pack 1 (ICP1) y en SMS 2003 International Client Pack 2 (ICP2) en la versión internacional de SMS 2003 SP3.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

También puede experimentar este problema después de implementar la versión actualizada de la AssetAdvisor.dll archivo que se incluye en esta revisión. Por ejemplo, considere la situación siguiente:
  1. Implementar la versión actualizada del archivo AssetAdvisor.dll a equipos cliente mediante SMS 2003. Por lo tanto, estos equipos cliente ya no experimenta el problema que se describe en la sección "Síntomas".
  2. Unir un nuevo equipo cliente al dominio.
  3. El equipo cliente recibe la instalación de inserción del agente de cliente SMS.
En este escenario, el equipo de cliente puede iniciarse la operación de inventario de hardware antes de que el equipo cliente recibe el archivo AssetAdvisor.dll actualizado.

Nota Generalmente, inventario de hardware se inicia dentro aproximadamente 10 minutos de la instalación de cliente SMS. Sin embargo, podría tardar aproximadamente un día para el equipo cliente recibir el archivo AssetAdvisor.dll actualizado de SMS 2003. Por ejemplo, podría tardar aproximadamente un día para el proceso de actualización de la colección, la actualización de directiva de cliente y finalizar la operación de anuncio de ejecución.

Por lo tanto, si el equipo cliente contiene el software afectado, el equipo cliente puede experimentar el problema que se describe en la sección "Síntomas".

Más información

Información del archivo de registro

Cuando se produce este problema, la siguiente información de archivo de registro se genera durante la operación de colección de inventario de hardware:
<date and time> 1520 (0x05F0) Collection: Namespace = \\.\root\cimv2\sms; 
Query = SELECT __CLASS, __PATH, __RELPATH, BinFileVersion, BinProductVersion, 
Description, FileName, FilePropertiesHash, FilePropertiesHashEx, FileVersion, 
Location, Product, ProductVersion, Publisher, StartupType, StartupValue FROM 
SMS_AutoStartSoftware; Timeout = 600 secs. InventoryAgent
<date and time> 1520 (0x05F0) Unknown error encountered processing an instance 
of class SMS_AutoStartSoftware: 800706BE InventoryAgent

Successfully Completed Inventory for SMS_InstalledSoftware	AssetAdvisor	<date and time>	2636 (0x0A4C)
Start Inventory for SMS_AutoStartSoftware	AssetAdvisor	<date and time>	2716 (0x0A9C)
Trying to collect data from CAA_Autostartsoftware class	AssetAdvisor	<date and time>	2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_CURRENT_USER	AssetAdvisor	<date and time>	2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_LOCAL_MACHINE	AssetAdvisor	<date and time>	2716 (0x0A9C)
Start Inventory for SMS_SystemConsoleUser	AssetAdvisor	<date and time>	2820 (0x0B04)
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft


Cuando instala esta actualización, puede anotarse un mensaje de error similar al siguiente aparece en el archivo Execmgr.log:

Solicitud de estado de ejecución o el informe encontró para el programa instalar SMS Advanced Client SP3 Hotfix KB937882 paquete $ PackageID execmgr 8, 14/2007 1:36:23 P.M. 4024 (0x0FB8) servicio detiene mientras el programa instalar SMS Advanced Client SP3 Hotfix KB937882 se está ejecutando execmgr 8, 14/2007 1:36:23 P.M. 4024 (0x0FB8) Error en OpenProcess para proceso 2700, error 80070057 execmgr 8, 14/2007 1:31:27 P.M. 1292 (0x050C) no puede continuar el programa después de reiniciar servicio porque se cerró el proceso de supervisión. Suponga execmgr error 8, 14/2007 1:31:27 P.M. 1292 (0x050C)
Puede pasar por alto este mensaje de error sin que ello afecta a la seguridad. El proceso de archivo de Execmgr.log crea un nuevo proceso de revisión y supervisa el estado del proceso de revisión secundaria. Sin embargo, el proceso de revisión secundario debe detener el proceso primario para instalar los archivos incluidos en la actualización. Una vez completado el proceso de revisión secundario, el proceso del archivo Execmgr.log se inicia de nuevo. El proceso de archivo de Execmgr.log intenta reanudar el proceso primario original que inició el proceso de revisión. Sin embargo, este proceso primario ya ha finalizado. El proceso del archivo Execmgr.log devuelve el error porque no puede reanudar este proceso primario.

Propiedades

Id. de artículo: 937882 - Última revisión: lunes, 27 de agosto de 2007 - Versión: 6.1
La información de este artículo se refiere a:
  • Microsoft Systems Management Server 2003 Service Pack 3
Palabras clave: 
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Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 937882

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