SMS 2003 SP3 をインストールすると、Wmiprvse.exe プロセスのハードウェア インベントリ処理中にクライアント コンピューター上で CPU 使用率が高くされることがあります。

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文書番号: 937882
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目次

現象

次のシナリオを検討してください。
  • Microsoft システム管理サーバー 2003 Service Pack 3 (SP3) をインストールします。
  • SMS 2003 SP3 資産アドバイザーは、ハードウェア インベントリ操作を実行します。
このシナリオでは、Wmiprvse.exe プロセス、組織内のクライアント コンピューター高い CPU 使用率が発生します。場合によっては、CPU の使用率が 100% に急上昇可能性があります。

原因

この問題は、次の条件に該当する場合に発生します。
  • クライアント コンピューター上での起動場所のいずれかに表示されているファイルには複数の英語以外の言語が含まれます。たとえば、次の起動場所、クライアント コンピューター上で混合言語を含む、プログラム ファイルが一覧表示されます。
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
  • クライアント コンピューター上の現在のユーザー ロケール ファイルからの起動の場所 (以前の行頭文字に記載されているファイル) で使用されている言語のいずれか一致しません。
  • は、 SMS_AutoStartSoftware クラスは、Sms_def.mof ファイルで有効になります。

    メモ このクラスが有効になっているかどうかを確認する方法の詳細については、「回避策」のセクションを参照してください。
は、 SMS_AutoStartSoftware クラスでは、このような状況を正しく処理しません。このシナリオでは、 SMS_AutoStartSoftware クラスには、ループに入ります。したがって、インベントリ ・ オペレーションは、クライアント コンピューター上の高い CPU 使用率を生成します。

メモ は、 SMS_AutoStartSoftware クラスは SMS 2003 SP3 に含まれています。

次の 3 つのクラスは、複数の英語以外の言語を含むファイルを処理する場合と、現在のユーザー ロケールの言語のファイルのいずれかが一致しない場合この問題もがあります。
  • SMS_BrowserHelperObject
  • SMS_InstalledSoftware
  • SMS_SoftwareShortcut

解決方法

次のファイルは、Microsoft ダウンロード センターからダウンロードできます。

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ダウンロード
937882 パッケージします。

マイクロソフトのサポート ファイルをダウンロードする方法の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトは、このファイルのウイルスをスキャンしました。マイクロソフトは、ファイルが転記された日付に利用可能な最新のウイルス検出ソフトウェアを使用します。ファイルは、ファイルに不正な改変を防止するセキュリティが強化されたサーバーに格納されます。

インストールの手順

この修正プログラムは、影響を受ける SMS クライアント コンピューターにのみインストールする必要があります。SMS サイト サーバーまたはサーバー ロケーター ポイント (SLP) や、クライアント アクセス ポイント (CAP) を管理ポイント (MP) は、SMS の役割をホストしている、この修正プログラムを必要としないサーバー

この修正プログラムの配布を簡略化するには、修正プログラム インストーラーは、自動的にパッケージおよび SMS2003AC SP3 KB937882 x86.msp ファイルが含まれているプログラム作成します。SMS2003 SP3 KB937882 X しているファイルは、パッケージとプログラムを作成します。SMS アドバンスト クライアントで正しくこの修正プログラム パッケージをインストールする前に、SMS 2003 SP3 アドバンスト クライアントすべてに配布、広告とターゲットを作成する必要があります。これを行うには、次の手順を実行します。
  1. ダブルクリック、 SMS2003 SP3 KB937882 X しています。 ファイルし、パッケージとプログラムを作成するのには、指示に従って。
  2. クリックしてください。 開始をクリックして すべてのプログラムをクリックして Systems Management Server、し SMS 管理コンソール.
  3. SMS 管理コンソールを展開します。 パッケージを右クリックして KB937882 - 1 C 1 高度なクライアント修正プログラム-、ポイント すべてのタスク]、し ソフトウェアを配布します。.
  4. ソフトウェア配布アドバタイズおよび修正プログラム パッケージを展開するには、ウィザードの指示に従ってください。

    この修正プログラム パッケージをインストールすることができる方法の詳細については、ダイアログ ボックスを参照してください。 SMS アドバンスト クライアントに修正プログラムを適用します。 ソフトウェアの配布ウィザードします。
メモ この修正プログラムをインストールした後のリセット、SMS サイトを実行するためにはありません。

手動で、SMS クライアント コンピューターに修正プログラムをインストールする場合は、SMS2003AC SP3 KB937882 x86.msp ファイルから SMS クライアント コンピューターで、コマンド ・ ラインは以下のとおりインストールできます。

msiexec.exe/P SMS2003AC-KB891073-X86.msp/L * v %temp%\SMS2003AC ・ KB891073 ・ X86.log 再インストールの/q:a すべて REINSTALLMODE = mous =

メモ は、 %temp%プレース ホルダーは、インストール ログ ファイルの場所ですし、 SMS2003AC ・ KB891073 ・ X86.log プレース ホルダーは、インストール ログ ファイルの名前です。

この修正プログラムは米国英語版の SMS 2003 SP3 を使用する環境にのみ適用されます。この修正プログラムは既に SMS 2003 インターナショナル クライアント パック 1 (ICP1) と SMS 2003 インターナショナル クライアント パック 2 (ICP2) 国際バージョンの SMS 2003 SP3 に含まれています。

状況

マイクロソフトでは、この「対象」に記載されているマイクロソフト製品の問題として認識しています。

詳細

AssetAdvisor.dll の更新バージョンを配置した後もこの問題が発生可能性があります。この修正プログラムに含まれているファイルを指定します。たとえば、次のシナリオを検討してください。
  1. AssetAdvisor.dll ファイルの最新バージョンを導入します。SMS 2003 を使用してクライアント コンピューターにします。したがって、これらのクライアント コンピューターは、「現象」に記載されている問題が発生します。
  2. 新しいクライアント コンピューターをドメインに参加します。
  3. クライアント コンピューターは、SMS クライアント エージェントのプッシュ インストールを受け取ります。
クライアント コンピューターが、更新された AssetAdvisor.dll ファイルを受信する前にこのシナリオでは、ハードウェア インベントリがクライアント コンピューターを起動可能性があります。

メモ 一般的に、ハードウェア インベントリは約 10 分で、SMS クライアントのインストールを開始します。ただし、SMS 2003 から、更新された AssetAdvisor.dll ファイルを受信するクライアント コンピューターは、約 1 日かかります。たとえば、1 日約コレクション更新プロセスは、クライアント ポリシーの更新、および実行-広告操作が完了するかかります。

したがって、クライアント コンピューターに影響を受けるソフトウェアが含まれている場合は、クライアント コンピューター、「現象」に記載されている問題があります。

詳細

ログ ファイルの情報

この問題が発生すると、ハードウェア インベントリ コレクション操作中に、次のログ ファイル情報が生成されます。
<date and time> 1520 (0x05F0) Collection: Namespace = \\.\root\cimv2\sms; 
Query = SELECT __CLASS, __PATH, __RELPATH, BinFileVersion, BinProductVersion, 
Description, FileName, FilePropertiesHash, FilePropertiesHashEx, FileVersion, 
Location, Product, ProductVersion, Publisher, StartupType, StartupValue FROM 
SMS_AutoStartSoftware; Timeout = 600 secs. InventoryAgent
<date and time> 1520 (0x05F0) Unknown error encountered processing an instance 
of class SMS_AutoStartSoftware: 800706BE InventoryAgent

Successfully Completed Inventory for SMS_InstalledSoftware	AssetAdvisor	<date and time>	2636 (0x0A4C)
Start Inventory for SMS_AutoStartSoftware	AssetAdvisor	<date and time>	2716 (0x0A9C)
Trying to collect data from CAA_Autostartsoftware class	AssetAdvisor	<date and time>	2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_CURRENT_USER	AssetAdvisor	<date and time>	2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_LOCAL_MACHINE	AssetAdvisor	<date and time>	2716 (0x0A9C)
Start Inventory for SMS_SystemConsoleUser	AssetAdvisor	<date and time>	2820 (0x0B04)
詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
824684マイクロソフトのソフトウェア更新プログラムの説明に使用される一般的な用語の説明


この更新プログラムをインストールすると、一覧には、次のようなエラー メッセージ、Execmgr.log ファイルに記録される可能性があります。

要求プログラム インストール SMS アドバンスト クライアント SP3 修正プログラム KB937882 パッケージ $ パッケージ Id$ execmgr に対して見つかった実行またはレポートのステータスに 2007/8/14 午後 1時 36分: 23 4024 (0x0FB8) サービスを停止するプログラム インストール SMS アドバンスト クライアント SP3 修正プログラム KB937882 execmgr 中 2007/8/14 午後 1時 36分: 23 4024 (0x0FB8) OpenProcess 失敗プロセス 2700、エラー 80070057 execmgr 2007/8/14 1時 31分: 27 PM 1292 (0x050C) 監視サービスを再起動すると、プロセスが終了しているため、プログラムを続行できません。障害が発生した execmgr を前提としています 2007/8/14 1時 31分: 27 PM 1292 (0x050C)
このエラー メッセージは無視してかまいません。Execmgr.log ファイルの処理、パッチ、新しいプロセスを作成し、子プロセスが修正プログラムの状態を監視します。ただし、修正プログラムの子プロセスは、更新プログラムに含まれているファイルをインストールするのには、親プロセスを停止しなければなりません。修正プログラムの子プロセスが完了したら、もう Execmgr.log ファイルの処理を開始します。Execmgr.log ファイルの処理が修正プログラムのプロセスを開始した元の親プロセスを再開しようとします。ただし、この親プロセスが既に終了しました。この親プロセスを再開することができないため、Execmgr.log ファイルの処理は、エラーを返します。

プロパティ

文書番号: 937882 - 最終更新日: 2011年8月9日 - リビジョン: 8.0
キーワード:?
kbtshoot kbbug kbfix kbqfe kbprb kbpubtypekc atdownload kbmt KB937882 KbMtja
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英語版 KB:937882
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