หลังจากที่คุณติดตั้ง SMS 2003 SP3 กระบวนการ Wmiprvse.exe อาจสร้างการใช้งาน CPU สูงในคอมพิวเตอร์ไคลเอนต์ในระหว่างการดำเนินงานสินค้าคงคลังฮาร์ดแวร์

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 937882 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

พิจารณาสถานการณ์ต่อไปนี้::
  • คุณติดตั้ง Microsoft ระบบ Management Server 2003 Service Pack 3 (SP3)
  • โปรแกรมช่วยแนะที่ SMS 2003 SP3 สินทรัพย์นำทำการดำเนินงานสินค้าคงคลังฮาร์ดแวร์
ในสถานการณ์สมมตินี้ กระบวนการ Wmiprvse.exe บนไคลเอ็นต์คอมพิวเตอร์ในองค์กรอาจสร้างการใช้งาน CPU สูง ในบางครั้ง การใช้งาน CPU อาจ spike ถึง 100 เปอร์เซ็นต์

สาเหตุ

ปัญหานี้อาจเกิดขึ้นหากมีเงื่อนไขต่อไปนี้::
  • แฟ้มที่แสดงอยู่ในตำแหน่งที่ตั้งเริ่มต้นระบบคอมพิวเตอร์ไคลเอนต์อย่างใดอย่างหนึ่ง ประกอบด้วยหลายภาษาไม่ใช่ภาษาอังกฤษ แสดงตัวอย่างเช่น แฟ้มโปรแกรมที่มีภาษาที่ผสมกันอยู่ในตำแหน่งเริ่มต้นต่อไปนี้บนคอมพิวเตอร์ไคลเอนต์:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
  • ภาษาของผู้ใช้ปัจจุบันบนคอมพิวเตอร์ไคลเอนต์ไม่ตรงกับภาษาที่ใช้ในแฟ้มจากตำแหน่งที่ตั้งเริ่มต้นระบบ (แฟ้มที่ได้อธิบายไว้ในหมายหน้าหัวข้อก่อนหน้า) ใด ๆ
  • กระบวนการSMS_AutoStartSoftwareคลาถูกเปิดใช้งานในแฟ้ม Sms_def.mof

    หมายเหตุ:สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการตรวจสอบว่า มีการเปิดใช้คลาสนี้ ให้ดูที่ส่วน "วิธีแก้ปัญหา"
กระบวนการSMS_AutoStartSoftwareคลาสที่ไม่จัดการเงื่อนไขเหล่านี้อย่างถูกต้อง ในสถานการณ์สมมตินี้SMS_AutoStartSoftwareคลาสที่ป้อนการวนรอบ ดังนั้น การดำเนินการสินค้าคงคลังที่สร้างการใช้งาน CPU สูงในคอมพิวเตอร์ไคลเอนต์

หมายเหตุ:กระบวนการSMS_AutoStartSoftwareคลาสที่มีอยู่ใน SMS 2003 SP3

ระดับชั้นที่ 3 ต่อไปนี้อาจทำให้ยังเกิดปัญหานี้ เมื่อพวกเขาสามารถประมวลผลแฟ้มที่มีหลายภาษาไม่ใช่ภาษาอังกฤษ และ เมื่อระบบภาษาของผู้ใช้ปัจจุบันไม่ตรงกับภาษาในแฟ้มใด ๆ:
  • SMS_BrowserHelperObject
  • SMS_InstalledSoftware
  • SMS_SoftwareShortcut

การแก้ไข

แฟ้มต่อไปนี้สามารถดาวน์โหลดได้จากศูนย์ดาวน์โหลดของ Microsoft::

ยุบรูปภาพนี้ขยายรูปภาพนี้
ดาวน์โหลด
ดาวน์โหลดแพคเกจ 937882

หากต้องการทราบข้อมูลเพิ่มเติมเกี่ยวกับการดาวน์โหลดไฟล์การสนับสนุนของไมโครซอฟท์ โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base::
119591วิธีรับแฟ้มการสนับสนุนของไมโครซอฟท์จากบริการออนไลน์
Microsoft สแกนแฟ้มนี้เพื่อหาไวรัส Microsoft ใช้ซอฟต์แวร์ตรวจสอบไวรัสล่าสุด ณ วันที่มีการประกาศแฟ้มนั้นๆ แฟ้มดังกล่าวจะถูกจัดเก็บในเซิร์ฟเวอร์เพิ่มการรักษาความปลอดภัย ซึ่งช่วยป้องกันการเปลี่ยนแปลงแฟ้มโดยไม่ได้รับอนุญาต

คำแนะนำในการติดตั้ง

โปรแกรมแก้ไขด่วนนี้เท่านั้นต้องถูกติดตั้งบนคอมพิวเตอร์ไคลเอ็นต์ SMS ที่ได้รับผลกระทบ sms ไซต์เซิร์ฟเวอร์หรือเซิร์ฟเวอร์ที่กำลังจัดการโฮสต์สำหรับบทบาท SMS เช่นการเซิร์ฟเวอร์ Locator จุด (SLP), เป็นไคลเอนต์การเข้าถึงจุด (CAP), หรือจุดการจัดการ (MP) ไม่ต้องการแก้ไขด่วนนี้

เมื่อต้องการทำให้การกระจายของโปรแกรมแก้ไขด่วนนี้ โปรแกรมติดตั้งโปรแกรมแก้ไขด่วนจะสร้างแพคเกจและโปรแกรมที่ประกอบด้วยแฟ้ม SMS2003AC-SP3-KB937882-x86.msp แฟ้ม ENU.exe 86 SMS2003-SP3-KB937882-X แพคเกจและโปรแกรมที่สร้างเท่านั้น ก่อนที่คุณสำเร็จแล้วสามารถติดตั้งแพคเกจโปรแกรมแก้ไขด่วนบนไคลเอ็นต์ SMS ขั้นสูง คุณต้องสร้างโฆษณาและเป้าหมายการไคลทั้งหมด SMS 2003 SP3 ขั้นสูงเอนต์สำหรับการเผยแพร่ โดยให้ทำตามขั้นตอนต่อไปนี้::
  1. คลิกสองครั้ง86 SMS2003-SP3-KB937882-X-ENU.exeแฟ้ม และจากนั้น ทำตามคำแนะนำในการสร้างแพคเกจการและโปรแกรม
  2. คลิกเริ่มการทำงานคลิกโปรแกรมทั้งหมดคลิกSystems Management Serverแล้ว คลิกคอนโซลของผู้ดูแลระบบ sms.
  3. ในคอนโซลผู้ดูแลระบบ SMS ขยายแพคเกจคลิกขวาKB937882 - ขั้นสูงโปรแกรมแก้ไขด่วนของไคลเอ็นต์ - 1 C 1ชี้ไปที่งานทั้งหมดแล้ว คลิกกระจายซอฟต์แวร์.
  4. ทำตามคำแนะนำในตัวช่วยการกระจายซอฟต์แวร์สร้าง advertise และปรับใช้แพคเกจโปรแกรมแก้ไขด่วน

    สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการที่คุณสามารถใช้เพื่อติดตั้งแพคเกจโปรแกรมแก้ไขด่วนนี้ ให้ดูกล่องโต้ตอบที่ชื่อการใช้โปรแกรมแก้ไขด่วนที่ไคลเอ็นต์ SMS ขั้นสูงในการจัดสรรตัวช่วยสร้างการซอฟต์แวร์
หมายเหตุ:คุณไม่มีการดำเนินการไซต์ SMS มีการตั้งค่าใหม่หลังจากที่คุณติดตั้งโปรแกรมแก้ไขด่วนนี้

ถ้าคุณต้องการติดตั้งโปรแกรมแก้ไขด่วนบนคอมพิวเตอร์ไคลเอ็นต์ SMS ที่ด้วยตนเอง คุณสามารถติดตั้งแฟ้ม SMS2003AC-SP3-KB937882-x86.msp จากบรรทัดคำสั่งบนคอมพิวเตอร์ไคลเอ็นต์ SMS เป็นดังนี้:

msiexec.exe /P /L SMS2003AC KB891073 X86.msp * v% temp %\SMS2003AC KB891073 X86.log/q ติดตั้งซ้ำ = REINSTALLMODE ทั้งหมด = mous

หมายเหตุ:กระบวนการ% temp %ตัวยึดตำแหน่งที่ตั้งของแฟ้มบันทึกการติดตั้ง ที่อยู่และSMS2003AC KB891073 X86.logตัวยึดเป็นชื่อของแฟ้มบันทึกการติดตั้ง

การแก้ไขนี้สามารถใช้ได้เฉพาะกับสภาพแวดล้อมที่ใช้ในสหรัฐอเมริการุ่นภาษาอังกฤษ SMS 2003 SP3 การแก้ไขนี้รวมอยู่ ใน SMS 2003 สากลไคลเอ็นต์ Pack 1 (ICP1) และ SMS 2003 สากลไคลเอ็นต์ Pack 2 (ICP2) ใน SMS 2003 SP3 รุ่นสากลอยู่แล้ว

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ข้อมูลเพิ่มเติม

นอกจากนี้คุณอาจพบปัญหานี้หลังจากที่คุณปรับใช้รุ่นที่ปรับปรุงแล้วของไฟล์ AssetAdvisor.dll ที่รวมอยู่ในโปรแกรมแก้ไขด่วนนี้ ตัวอย่างเช่น พิจารณาสถานการณ์สมมติต่อไปนี้:
  1. You deploy the updated version of the AssetAdvisor.dll file to client computers by using SMS 2003. Therefore, these client computers no longer experience the problem that is described in the "Symptoms" section.
  2. You join a new client computer to the domain.
  3. The client computer receives the SMS client-agent push installation.
In this scenario, the client computer may start the hardware-inventory operation before the client computer receives the updated AssetAdvisor.dll file.

หมายเหตุ:Generally, hardware inventory starts within approximately 10 minutes of the SMS client installation. However, it could take approximately one day for the client computer to receive the updated AssetAdvisor.dll file from SMS 2003. For example, it could take approximately one day for the collection-update process, for the client policy update, and for the run-advertisement operation to finish.

Therefore, if the client computer contains the affected software, the client computer may experience the problem that is described in the "Symptoms" section.

ข้อมูลเพิ่มเติม

Log-file information

When this problem occurs, the following log-file information is generated during the hardware-inventory collection operation:
<date and time> 1520 (0x05F0) Collection: Namespace = \\.\root\cimv2\sms; 
Query = SELECT __CLASS, __PATH, __RELPATH, BinFileVersion, BinProductVersion, 
Description, FileName, FilePropertiesHash, FilePropertiesHashEx, FileVersion, 
Location, Product, ProductVersion, Publisher, StartupType, StartupValue FROM 
SMS_AutoStartSoftware; Timeout = 600 secs. InventoryAgent
<date and time> 1520 (0x05F0) Unknown error encountered processing an instance 
of class SMS_AutoStartSoftware: 800706BE InventoryAgent

Successfully Completed Inventory for SMS_InstalledSoftware	AssetAdvisor	<date and time>	2636 (0x0A4C)
Start Inventory for SMS_AutoStartSoftware	AssetAdvisor	<date and time>	2716 (0x0A9C)
Trying to collect data from CAA_Autostartsoftware class	AssetAdvisor	<date and time>	2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_CURRENT_USER	AssetAdvisor	<date and time>	2716 (0x0A9C)
Collecting AutostartSoftwares from HKEY_LOCAL_MACHINE	AssetAdvisor	<date and time>	2716 (0x0A9C)
Start Inventory for SMS_SystemConsoleUser	AssetAdvisor	<date and time>	2820 (0x0B04)
สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
824684คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายปรับปรุงซอฟต์แวร์ของ Microsoft


When you install this update, an error message that resembles the following listed may be logged in the Execmgr.log file:

Request in running or report status found for program Install SMS Advanced Client SP3 Hotfix KB937882 package $PackageID$ execmgr 8/14/2007 1:36:23 PM 4024 (0x0FB8) Service stopped while program Install SMS Advanced Client SP3 Hotfix KB937882 is running execmgr 8/14/2007 1:36:23 PM 4024 (0x0FB8) OpenProcess failed for process 2700, error 80070057 execmgr 8/14/2007 1:31:27 PM 1292 (0x050C) Cannot continue monitoring the program after service restart because the process exited. Assume failed execmgr 8/14/2007 1:31:27 PM 1292 (0x050C)
คุณสามารถละเว้นข้อความแสดงข้อผิดพลาดนี้ได้ กระบวนการแฟ้ม Execmgr.log สร้างกระบวนการโปรแกรมปรับปรุงใหม่ และตรวจสอบสถานะของกระบวนการแพทช์ลูก อย่างไรก็ตาม กระบวนการแพทช์ลูกต้องหยุดขั้นตอนหลักการการติดตั้งแฟ้มที่จะรวมในการปรับปรุง หลังจากกระบวนการแพทช์ลูกเสร็จสมบูรณ์ กระบวนการของไฟล์ Execmgr.log เริ่มทำงานอีกครั้ง กระบวนการแฟ้ม Execmgr.log พยายามที่จะดำเนินต่อกระบวนการหลักดั้งเดิมที่เริ่มต้นกระบวนการโปรแกรมปรับปรุง สิ้นสุดอย่างไรก็ตาม กระบวนการหลักนี้เรียบร้อยแล้วลง กระบวนการของไฟล์ Execmgr.log ส่งกลับข้อผิดพลาดเนื่องจากไม่สามารถกลับมาทำงานของกระบวนการหลักนี้

คุณสมบัติ

หมายเลขบทความ (Article ID): 937882 - รีวิวครั้งสุดท้าย: 11 กันยายน 2554 - Revision: 5.0
ใช้กับ
  • Microsoft Systems Management Server 2003 Service Pack 3
Keywords: 
atdownload kbbug kbfix kbqfe kbtshoot kbprb kbmt KB937882 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:937882

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com