Help and Support

Numéro d'article: 937940 - Dernière mise à jour: vendredi 8 juin 2007 - Version: 1.1

Le .NET Framework ne sont pas restaurée correctement lorsque vous sauvegardez et puis restaurez Windows Vista

Agrandir tout | Réduire tout

Symptômes

Lorsque vous sauvegardez et restaurez Windows Vista, Microsoft .NET Framework n'est pas restaurée correctement.

Cause

Ce problème se produit car Windows Vista ne prend pas en charge écrire l'ensemble des fichiers pour le .NET Framework dans le logiciel de sauvegarde.

Résolution

Pour résoudre ce problème, configurez le logiciel de sauvegarde pour inclure tous les fichiers et les dossiers qui existent dans les dossiers suivants :
  • %windir%\assembly
  • %windir%\Microsoft.Net

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

En sauvegardant correctement le .NET Framework, vous pouvez vous assurer que les applications qui sont conçues à l'aide de .NET Framework continuent à fonctionner correctement lorsque vous restaurez les fichiers.

Pour plus d'informations sur comment Windows Vista détermine les fichiers à enregistrer le logiciel de sauvegarde, reportez-vous au site de Web MSDN (Microsoft Developer Network) suivant :
http://msdn2.microsoft.com/en-us/library/aa819131.aspx (http://msdn2.microsoft.com/en-us/library/aa819131.aspx)
L'enregistreur de système dans Windows Vista fournit la liste des fichiers sur le logiciel de sauvegarde. L'enregistreur de système fait partie de l'API Volume Shadow Copy dans Windows Vista. Pour savoir comment utiliser l'API Volume Shadow Copy, reportez-vous au site Web MSDN suivant :
http://msdn2.microsoft.com/en-us/library/aa384645.aspx (http://msdn2.microsoft.com/en-us/library/aa384645.aspx)

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Vista Entreprise 64 bits
  • Windows Vista Édition Familiale Basique 64 bits
  • Windows Vista Édition Familiale Premium 64 bits
  • Windows Vista Édition Intégrale 64 bits
  • Windows Vista Professionnel
  • Windows Vista Professionnel 64 bits
  • Windows Vista Entreprise
  • Windows Vista Édition Familiale Basique
  • Windows Vista Édition Familiale Premium
  • Windows Vista Starter
  • Windows Vista Édition Intégrale
Mots-clés : 
kbmt kbhowto kbexpertiseinter kbprb kbinfo KB937940 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 937940  (http://support.microsoft.com/kb/937940/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles