Visio 2007 crashes, or the Visio.exe process is still running after you exit Visio 2007 on a Windows Vista-based computer

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Article ID: 937997 - View products that this article applies to.
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SYMPTOMS

When you exit Microsoft Office Visio 2007 on a Windows Vista-based computer, you experience one of the following symptoms:
  • Visio 2007 crashes.
  • Visio 2007 exits successfully. However, when you open Task Manager, the Visio.exe process is still running.
When you view the data in the error report, the report contains an error signature that resembles one of the following error signatures.
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Application nameApplication versionModule nameModule versionOffsetException code
Visio.exe12.0.4518.1014Vislib.dll12.0.4518.101400014f4cc0000005
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Application nameApplication versionModule nameModule versionOffsetException code
Visio.exe12.0.6211.1000Ntdll.dll6.0.6001.18000000761b7c015000f
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Application nameApplication versionModule nameModule versionOffsetException code
Visio.exe12.0.6300.5000Ntdll.dll6.0.6001.18000000761b7c015000f

CAUSE

This issue occurs because the Visio 2007 add-ins do not exit as expected when you exit Visio 2007.

RESOLUTION

If this issue occurs because of the Bluetooth send to Office add-in, you can resolve this issue by upgrading to Visio 2007 Service Pack 2.

Note Only early version of the Bluetooth send to Office add-in will cause this issue. The newer version will not.

With Visio 2007 Service Pack 2, the earlier version of the Bluetooth send to Office add-in will be disabled when you exit Visio 2007 Service Pack 2. Also, if you install a newer version of Bluetooth send to Office add-in, the Bluetooth send to Office add-in will be enabled when you start Visio 2007 Service Pack 2. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
953327 Description of Microsoft Office Visio 2007 Service Pack 2 and Microsoft Office Visio Language Pack 2007 Service Pack 2

WORKAROUND

To work around this problem, use one of the following methods.

Method 1: Disable all add-ins in Visio 2007 to avoid the problem

Note On a Windows Vista-based computer that is running under User Account Control (UAC), users may be prevented from removing Office add-ins. In this situation, the users must start Visio 2007 as an administrator.
  1. Start Visio 2007 as an administrator on the Windows Vista-based computer. To do this, follow these steps:
    1. Click Start
      Collapse this imageExpand this image
       Start
					 button
      , type Visio.exe in the Start Search box, right-click Visio.exe in the Programs list, and then click Run as administrator.

      Collapse this imageExpand this image
      User Access Control
					 permission
      If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  2. In Visio 2007, click Trust Center on the Tools menu.
  3. Click Add-ins.
  4. In the Manage list, click COM Add-ins, and then click Go.
  5. In the COM Add-Ins dialog box, click to clear the check boxes for all the add-ins in the Add-Ins available list.
  6. Click OK.

Method 2: Disable add-ins individually to determine which add-in causes the problem

If you determine the specific add-in that causes the problem, follow the steps in Method 1 to disable that add-in. You can then contact the manufacturer of your computer to determine whether an update to the add-in is available to resolve the issue.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 937997 - Last Review: April 28, 2009 - Revision: 4.0
APPLIES TO
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
Keywords: 
kbtshoot kbexpertisebeginner kbprb KB937997

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