Article ID: 938009 - Last Review: February 23, 2009 - Revision: 2.0

Client registration is unsuccessful when you switch System Center Configuration Manager 2007 from mixed mode to native mode or from native mode to mixed mode

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SYMPTOMS

When you switch Microsoft System Center Configuration Manager 2007 from mixed mode to native mode or from native mode to mixed mode, client registration is unsuccessful.

Additionally, the following error is logged in the ClientIDManagerStartup.log file on the client computer:
RegTask: Failed to send registration request message. Error 0x80040204
This file is located in the Windows\System32\Ccm\Logs folder.

CAUSE

This problem occurs if the MessageSizeThreshold value on the client is set to a value that is too low. For example, this problem may occur if the MessageSizeThreshold value is set to 5 or less.

Important We recommend that you do not change the MessageSizeThreshold value from its default value.

RESOLUTION

To resolve this problem, change MessageSizeThreshold to a larger value. For example, set the value to 10. To do this, follow these steps on each client computer that did not register with System Center Configuration Manager 2007:
  1. Start the Windows Management Instrumentation Tester tool (WBEMTest). To do this, type wbemtest at a command prompt, and then press ENTER.
  2. Connect to the following namespace:
    root\ccm\policy\machine\actualconfig
  3. Click Enum Classes, and then click Recursive.
  4. In the Query Result dialog box, double-click CCM_Messaging_Configuration.
  5. In the Object editor for CCM_Messaging_Configuration dialog box, click Instances.
  6. In the Query Result dialog box, double-click CCM_Messaging_Configuration.DummyKey=1.
  7. In the Object editor for CCM_Messaging_Configuration.DummyKey=1 dialog box, double-click MessageSizeThreshold.
  8. In the Property Editor dialog box, change the value to 10 in the Value box, and then click Save Property.
  9. In the Object Editor for CCM_Messaging_Configuration.dummyKey=1 dialog box, click Save Object.
  10. In the Object editor for CCM_Messaging_Configuration dialog box, click Save Object, and then close all the Query Result dialog boxes.
  11. Exit Windows Management Instrumentation Tester.
  12. On the client computer, restart the SMS Agent Host service (CcmExec.exe).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft System Center Configuration Manager 2007
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