文書番号: 938021 - 最終更新日: 2007年5月25日 - リビジョン: 1.1

Windows XP から Windows Vista にアップグレードすると IME の言語バーが 2 つ表示される または [タスク バー] に最小化できない

重要: この資料には、レジストリの編集に関する情報が含まれています。レジストリを編集する前に、問題が発生した場合に備えて、レジストリの復元方法を理解しておいてください。レジストリのバックアップ、復元、および編集方法の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986? (http://support.microsoft.com/kb/256986/JA/ ) Microsoft Windows レジストリの説明
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現象

Microsoft Windows XP から Microsoft Windows Vista にアップグレードすると、Windows Vista にて IME の言語バーの動作が以下のような状態になることがあります。
  • IME 言語バーが 2 つ表示される
  • 最小化ボタンが機能せず、IME 言語バーを [タスク バー] 内に表示できない

原因

Windows XP から引き継がれた ctfmon.exe が起動するためです。

回避策

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。

この問題を回避するには、Windows の起動時に ctfmon.exe が動作しないようにレジストリを変更します。この方法は、Windows Vista へのアップグレード前およびアップグレード後のどちらでも有効です。
  1. 管理者権限を持つユーザーでコンピュータにログオンします。
  2. レジストリ エディタを起動し、次のレジストリ キーを見つけます。

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
  3. ctfmon.exe のエントリを削除します。
  4. レジストリ エディタを終了し、コンピュータを再起動します。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

この資料は以下の製品について記述したものです。
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
キーワード:?
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