Message d'erreur lorsque vous essayez de passer en mode hors connexion dans le client Microsoft Dynamics CRM pour Outlook: « Échec de déplacer des données pour l'entité »

Traductions disponibles Traductions disponibles
Numéro d'article: 938065 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous exécutez le client d'ordinateur portable Microsoft Dynamics CRM pour la mise à jour de compatibilité Microsoft Office Outlook ou le client Microsoft Dynamics CRM pour Outlook avec Access en mode hors connexion, s'affiche la message d'erreur suivant lorsque vous tentez de passer en mode hors connexion :
Échoué données déplacer pour l'entité ' entity_name ' action salnsert, countRows = 1. Contactez votre administrateur système pour obtenir une assistance et essayez de point à nouveau en mode hors connexion.
En outre, vous recevez le message d'erreur suivant dans la trace de la plate-forme :
Insérer a échoué pour l'entité « incidents », batchRows = 0 avec l'exception System.Data.SqlClient.SqlException : le chargement en bloc a échoué.
La colonne est trop longue dans le fichier de données de ligne 1, colonne 18.
Vérifiez que le champ terminateur et terminateur de ligne spécifiés correctement.
Le fournisseur OLE DB « BULK » pour serveur lié "(null)" signalé une erreur. Le fournisseur n'a pas donner les informations au sujet l'erreur.
Impossible d'extraire une ligne de fournisseur OLE DB « BULK » pour serveur lié "(null)".
à System.Data.SqlClient.SqlConnection.OnError (exception SqlException, breakConnection Boolean)
à System.Data.SqlClient.SqlInternalConnection.OnError (exception SqlException, breakConnection Boolean)
à System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning (stateObj TdsParserStateObject)
à System.Data.SqlClient.TdsParser.Run (RunBehavior runBehavior SqlCommand cmdHandler dataStream SqlDataReader, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
à System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds (methodName de type String, Boolean asynchrone)
à System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery (résultat DbAsyncResult methodName de type String, sendToPipe Boolean)
à System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
à Microsoft.Crm.Application.Outlook.OfflineSync.Utility.ExecuteSql (chaîne strCommand spécifié, CrmDbConnection dbConnection) d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\Utility.cs:line 55
à Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.PopulateTempTable (tempTableName chaîne valeur de type String fileName CrmDbConnection dbConnection, nombre int32, formatFile de type String) d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 389
à Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsertTable (EntityMetadata entité, valeur de type String fileName, nombre int32, extension de type Boolean, attributs de type String) d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 672
à Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsert (EntityMetadata entité, valeur de type String fileName, nombre int32) d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 637
à Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.ExecuteInsert (nom de valeur de type String, Int32 nombre) d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 333
à Microsoft.Crm.Application.Outlook.OfflineSync.SyncData.DoBatchStep (ITransferDataProvider transferDataProvider, nom de valeur de type String, action SyncAction, batchRows int32) d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\Sync.cs:line 1087

Cause

Ce problème se produit si les conditions suivantes sont remplies :
  • Le formulaire principal d'une entité, vous avez ajouté un champ attribut personnalisé qui utilise le type NTEXT .
  • Le champ d'attribut personnalisé sur un enregistrement lié contient plus de 4 000 caractères.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes :
  • Si Microsoft SQL Server Express 2005 Service Pack 1 est installé sur l'ordinateur qui exécute le client portable Microsoft CRM 3.0 pour Outlook, installez le correctif 937545.

    Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
    937545 CORRECTIF : message d'erreur lorsque vous utilisez l'instruction BULK INSERT pour importer un fichier de données dans une table dans SQL Server 2005 avec Service Pack 1: « le fournisseur OLE DB » BULK » de serveur lié "(null)" signalé une erreur »
  • Si Microsoft SQL Server Express 2005 Service Pack 2 est installé sur l'ordinateur qui exécute le client portable Microsoft CRM 3.0 pour Outlook, installez le correctif 941450.
    941450 Package de cumulative mise à jour 4 pour SQL Server 2005 Service Pack 2

Plus d'informations

Procédure pour reproduire le problème

  1. Sur une entité, créer un attribut personnalisé qui utilise le type de NTEXT et qui peut contenir 5 000 caractères. Par exemple, créer un champ « new_LongField » sur l'entité de compte.
  2. Ajoutez le champ attribut personnalisé sur le formulaire principal.
  3. Publier les modifications.
  4. Pour un enregistrement, compléter ce champ attribut personnalisé pour contenir plus de 4000 caractères.
  5. Dans le client d'ordinateur portable Microsoft Dynamics CRM pour la mise à jour de compatibilité Outlook ou dans le client en mode hors connexion Microsoft Dynamics CRM pour Outlook, tentez de passer en mode hors connexion.

Références

Pour plus d'informations si vous utilisez le client d'ordinateur portable Microsoft Dynamics CRM 3.0 pour Outlook, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
918108 Message d'erreur lorsque vous essayez de passer en mode hors connexion sur un ordinateur client portable qui exécute Microsoft Dynamics CRM 3.0: « Échec de déplacer des données pour l'entité »

Propriétés

Numéro d'article: 938065 - Dernière mise à jour: vendredi 15 mai 2009 - Version: 4.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Dynamics CRM 4.0
  • Microsoft CRM 3.0
  • Microsoft CRM client for Microsoft Office Outlook sur le système suivant
    • Microsoft Dynamics CRM 4.0
    • Microsoft CRM 3.0
  • Microsoft Dynamics Live CRM Professional Edition
  • Microsoft Dynamics Live CRM Enterprise Edition
Mots-clés : 
kbmt kbmbscrmonlineoutlook kbfreshness2008 kbmbscrmonline kbmbscrm40 kbmbscustomization kberrmsg kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter KB938065 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 938065
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com