Alguns pressionamentos de teclas posteriores são interpretados como parte do atalho de teclado anterior na sessão de serviços de terminal de uma janela Área de trabalho remota em um computador com Windows Vista

Traduções deste artigo Traduções deste artigo
ID do artigo: 938080 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário.
  • Você digita um atalho de teclado em um computador baseado no Windows Vista.
  • Você está trabalhando em uma sessão de serviços de terminal que foi iniciada usando o Remote Desktop Connection 6.0 (RDC 6.0).
Nesse cenário, algumas chaves no atalho do teclado podem permanecer ativas. Portanto, na sessão de serviços de terminal da janela Área de trabalho remota, alguns pressionamentos de teclas posteriores são interpretados como parte do atalho de teclado anterior. Por exemplo, esse problema ocorre se as seguintes condições forem verdadeiras:
  • Você bloquear o computador local, pressionando o Windows logotipo + L atalho de teclado.
  • Você desbloquear o computador local.
  • A janela Área de trabalho remota está ativa.
Quando você pressiona qualquer tecla, vários atalhos de teclado do Windows ocorrem na sessão de serviços de terminal. Por exemplo, quando você pressiona E na sessão de serviços de terminal, o Windows Explorer é iniciado como se a tecla de logotipo do Windows ainda for mantida pressionada.

Observação Windows Explorer deve começar quando você pressionar o atalho de + teclado E de logotipo do Windows.

Causa

Esse problema ocorre devido a um erro em Remote Desktop Connection 6.0. Quando você pressiona um atalho de teclado no computador local, o Remote Desktop Connection 6.0 pode enviar somente a mensagem "chave suspensa" para a sessão remota. Desktop Connection 6.0 remoto pode não enviar a mensagem "chave-up" para determinadas teclas modificadoras como as teclas logotipo ALT, SHIFT e no Windows.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Vista. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
935791Como obter o service pack mais recente do Windows Vista

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes lançados anteriormente.

Informações do registro

Não é necessário fazer alterações no registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Vista, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Update.mumNão aplicável1,80605 De junho de 200714: 41Não aplicável
X86_af7377a27733d119afe9929fddc6f6a8_31bf3856ad364e35_6.0.6000.20612_none_af451b4837d6175a.manifestNão aplicável72205 De junho de 200714: 41Não aplicável
X86_microsoft-windows-t...s-clientactivexcore_31bf3856ad364e35_6.0.6000.20612_none_2e8894a3e1a596ce.manifestNão aplicável168,92005 De junho de 200714: 43Não aplicável
Aaclient.dll6.0.6000.20612116,73605 De junho de 200702: 58x 86
Aaclient.MOFNão aplicável1,09707-Janeiro de 200705: 26Não aplicável
Mstscax.dll6.0.6000.206121,866,24005 De junho de 200702: 59x 86
Mstscax.MOFNão aplicável1,96707-Janeiro de 200705: 26Não aplicável
Tsgqec.dll6.0.6000.2061236.35205 De junho de 200703: 00x 86
Windows Vista, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Amd64_2f717519b2475113a4a958128df893b8_31bf3856ad364e35_6.0.6000.20612_none_524aa2bfb5264ff0.manifestNão aplicável1,09205 De junho de 200714: 41Não aplicável
Amd64_microsoft-windows-t...s-clientactivexcore_31bf3856ad364e35_6.0.6000.20612_none_8aa730279a030804.manifestNão aplicável168,98205 De junho de 200714: 47Não aplicável
Update.mumNão aplicável2,05605 De junho de 200714: 41Não aplicável
Aaclient.dll6.0.6000.20612130.04805 De junho de 200704: 09x 64
Aaclient.MOFNão aplicável1,09707-Janeiro de 200705: 26Não aplicável
Mstscax.dll6.0.6000.206122,188,28805 De junho de 200704: 12x 64
Mstscax.MOFNão aplicável1,96707-Janeiro de 200705: 26Não aplicável
Tsgqec.dll6.0.6000.2061227,64805 De junho de 200704: 15x 64

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Vista Service Pack 1.

Mais Informações

Por padrão, o RDC 6.0 está incluído no Windows Vista. Você pode instalar o RDC 6.0 no Microsoft Windows XP e no Microsoft Windows Server 2003.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
Se você usar o RDC 6.0 em um computador baseado no Microsoft Windows XP ou em um computador com Microsoft Windows Server 2003, aplique o hotfix 936970. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
936970Mensagem de erro quando você tenta salvar um documento em um programa do Office de 2007 para uma unidade redirecionada no Windows Vista: "Ocorreu um erro de permissão de rede ou arquivo"
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
925876Ligação de desktop remota (cliente de serviços de terminal 6.0)
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
186607Noções básicas sobre o Remote Desktop Protocol (RDP)

Propriedades

ID do artigo: 938080 - Última revisão: quinta-feira, 15 de maio de 2008 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbautohotfix kbvistasp1fix kbfix kbexpertisebeginner kbpubtypekc kbqfe kbhotfixserver KB938080 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 938080

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com