Windows Vista-based client computers do not use the node type that you specify for name resolution on the DHCP server

Article translations Article translations
Article ID: 938248 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You use a Dynamic Host Configuration Protocol (DHCP) server to assign TCP/IP configurations to client computers. You set the WINS/NBT Node Type scope option to a specific node type. However, one or more Windows Vista-based client computers do not use the node type that you specify for name resolution.

For example, you set the WINS/NBT Node Type scope option to P-node (0x2) to configure client computers to use P-node name resolution. However, some Windows Vista-based client computers do not use P-node name resolution. Instead, if these computers cannot resolve the host name by using a NetBIOS name server, they broadcast requests. This behavior causes unexpected traffic in the network environment.

Note In the P-node configuration, client computers should not broadcast requests even if the computers cannot resolve the host name by using a NetBIOS name server.

CAUSE

This problem occurs if the DHCP Client service on a Windows Vista-based client computer does not have permission to write the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netbt\Parameters
This registry subkey controls the client node type. If a computer cannot write this registry subkey, the computer uses a default configuration that is based on the following principles:
  • If no NetBIOS name server is configured for the client computer, the computer uses B-node.
  • If one or more NetBIOS name servers are configured for the client computer, the computer uses H-node.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.After you apply this hotfix, the DHCP Client service has permission to write the registry subkey.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you can obtain new TCP/IP configurations from the DHCP server by restarting the computer. Or, you can type the following commands to obtain the new configurations. Press ENTER after each command.
ipconfig /release
ipconfig /renew

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable2,66601-Jun-200711:40Not applicable
X86_17f8a129334d9db5cad88c4701803fdc_31bf3856ad364e35_6.0.6000.20610_none_a4bdbe9021f33ae0.manifestNot applicable69301-Jun-200711:40Not applicable
X86_1dbb82a81e605554f9037311063c5ba5_31bf3856ad364e35_6.0.6000.20610_none_ab9ec0ad53822b7e.manifestNot applicable70601-Jun-200711:40Not applicable
X86_microsoft-windows-netbt_31bf3856ad364e35_6.0.6000.20610_none_5efd54b513435508.manifestNot applicable21,25401-Jun-200711:42Not applicable
X86_microsoft-windows-tcpip-nettcpip-pro_31bf3856ad364e35_6.0.6000.20610_none_a6f5464fec263b41.manifestNot applicable2,90901-Jun-200711:42Not applicable
Netbt.sys6.0.6000.20610184,32001-Jun-200701:39x86
Netbtugc.exe6.0.6000.2061021,50401-Jun-200701:39x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_1aed3f767f1db3e30f22b22b0f69930e_31bf3856ad364e35_6.0.6000.20610_none_c20bc1a8fd1b8144.manifestNot applicable71001-Jun-200711:40Not applicable
Amd64_3f4e6bd32d8bd43455a0712a9944474c_31bf3856ad364e35_6.0.6000.20610_none_1345d4008f5924bc.manifestNot applicable69701-Jun-200711:40Not applicable
Amd64_eb65e3bca8c6579c9e2b19271303978b_31bf3856ad364e35_6.0.6000.20610_none_81f739cecbc003ed.manifestNot applicable69701-Jun-200711:40Not applicable
Amd64_microsoft-windows-netbt_31bf3856ad364e35_6.0.6000.20610_none_bb1bf038cba0c63e.manifestNot applicable21,28001-Jun-200711:46Not applicable
Amd64_microsoft-windows-tcpip-nettcpip-pro_31bf3856ad364e35_6.0.6000.20610_none_0313e1d3a483ac77.manifestNot applicable2,91501-Jun-200711:46Not applicable
Package_1_for_kb938248~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,78601-Jun-200711:40Not applicable
Package_2_for_kb938248~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable2,68101-Jun-200711:40Not applicable
Update.mumNot applicable1,90901-Jun-200711:40Not applicable
Wow64_microsoft-windows-netbt_31bf3856ad364e35_6.0.6000.20610_none_c5709a8b00018839.manifestNot applicable8,16401-Jun-200711:46Not applicable
Netbt.sys6.0.6000.20610233,47201-Jun-200702:05x64
Netbtugc.exe6.0.6000.2061024,06401-Jun-200702:05x64
Netbtugc.exe6.0.6000.2061021,50401-Jun-200701:39x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

WORKAROUND

To work around this problem, manually set the node type in the client computer's registry. To do this, follow these steps:
  1. Click Start, type regedit in the Start Search box, and then press ENTER.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netbt\Parameters
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type NodeType, and then press ENTER.
  5. Right-click NodeType, and then click Modify.
  6. In the Value data box, type the desired value, and then click OK.

    Note To use P-node name resolution, set this value to 2.
  7. Exit Registry Editor.

MORE INFORMATION

For more information about name resolution in NetBIOS over TCP/IP, click the following article number to view the article in the Microsoft Knowledge Base:
119493 NetBIOS over TCP/IP name resolution and WINS
For more information about DHCP, visit the following Microsoft TechNet Web site:
http://technet.microsoft.com/en-us/library/bb727003.aspx
For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 938248 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbwinvistapostrtmfix kbexpertiseinter kbbug kbfix kbHotfixServer kbqfe KB938248

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com