Error message when you log on to Microsoft Office Communicator: "Cannot Synchronize Address Book"

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Article ID: 938286 - View products that this article applies to.
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SYMPTOMS

When you log on to Microsoft Office Communicator, you receive the following error message:


Cannot Synchronize Address Book


When you click the message to display the details, you receive the following error message:


Cannot synchronize with the corporate address book. The cause of the problem is unknown. Please contact your system administrator with this information.


Additionally, the following error message is logged in the Office Communicator log:


URLDownloadToFile terminated, Url=https://ocs.domain.com/Abs/Ext/F-0918.lsabs, hr=0x800c0008


If you use Windows Internet Explorer to try to manually download any of the address book files, you receive an HTTP 500 error message. The Internet Information Services (IIS) log displays the same error.

CAUSE

This issue occurs because IIS does not specify the Network Directory Security credentials to connect to the Address Book Files folder.

RESOLUTION

Note This issue occurs on the client-side. However, you have to configure the settings on the server that is running Microsoft Office Communications Server to resolve the issue. If you are not familiar with Office Communications Server, contact the server administrator.

To resolve this issue, you must have the Administrator permission on the server that is running Microsoft Office Communications Server.

Windows Server 2003-based server

Method 1: If the Address Book Files folder is on the computer that is running Communications Server

  1. Click Start, click Run, type inetmgr, and then click OK.
  2. Expand ServerName, expand Web Sites, expand Default Web sites, and then expand Abs.
  3. Right-click Ext, and then click Properties.
  4. In the Ext Properties dialog box, click to select the A directory located on this computer check box on the Virtual Directory tab, click Browse to select the Address Book Files folder, and then click OK.
  5. Repeat steps 3 and 4 for Int in the Abs node.

Method 2: If the Address Book Files folder is not on the computer that is running Communications Server

  1. Click Start, click Run, type inetmgr, and then click OK.
  2. Expand ServerName, expand Web Sites, expand Default Web sites, and then expand Abs.
  3. Right-click Ext, and then click Properties.
  4. In the Ext Properties dialog box, click Connect As on the Virtual Directory tab.
  5. In the Network Directory Security Credentials dialog box, specify the credentials, and then click OK.
  6. Repeat steps 3 to 5 for Int in the Abs node.

Windows Server 2008-based server


Method 1: If the Address Book Files folder is on the computer that is running Communications Server

  1. Click Start, click Run, type inetmgr, and then click OK.
  2. Expand ServerName, expand Sites, expand Default Web sites, and then expand Abs.
  3. Expand Ext and click on Files, in the Actions pane click on Basic Settings
  4. Using the Physical path setting browse to the Address Book Files folder.
  5. Click OK twice and close the IIS 7.0 Management console
  6. Repeat steps 3 through 5 for Int in the Abs node.

Method 2: If the Address Book Files folder is not on the computer that is running Communications Server


  1. Click Start, click Run, type inetmgr, and then click OK.
  2. Expand ServerName, expand Sites, expand Default Web sites, and then expand Abs.
  3. Expand Ext and click on Files, in the Actions pane click on Basic Settings
  4. You should see the UNC path to the Address Book share
  5. Click on the Connect As Button, choose Application user (pass-through authentication)
  6. Click OK twice and close the IIS 7.0 Management console
  7. Repeat steps 3 through 6 forInt in the Abs node.

Note By default IIS 6.0 and IIS 7.0 use pass through authentication for the Identity of the LSGroupExpAppPool which is the Domain\RTCComponentService account. By default the remote Address Book Share has the domain’s Authenticated Users account add
ed to its ACL.

MORE INFORMATION

The issue that is described in the SYMPTOMS section of this article will affect all internal and remote users that are signed into the Office Communicator client. The issue is centric to IIS application pool "LSGroupExpAppPool" that hosts some of the Office Communications Server web services. The LSGroupExpAppPool Identity will provide the correct credentials to the server that is hosting the share that contains the address book files. When this authentication process fails, address book downloads will be globally affected.

The "Cannot Synchronize Address Book" notification can pertain to several different physical and logical connectivity issues that the Office Communicator client can have. If the Office Communicator provides additional error information that is relevant to the "Cannot Synchronize Address Book" notification but does not match what is listed in the SYMPTOMS section of this KB article then the steps listed in the RESOLUTION section of this article may not solve this issue.

Remote Office Communicator connectivity can be the cause of Address Book synchronization problems that will also provide the "Cannot Synchronize Address Book" notification. Review the information that is listed below to make sure that the remote connectivity to the Communication Server web components is configured correctly

Microsoft Office Communications Server 2007 R2 Microsoft Office Communications Server 2007 R2

REFERENCES

For more information about this issue, visit the following Microsoft Website:
939530 The Lync 2010 client or the Office Communicator client does not download the corporate address book and displays a notification: "Cannot Synchronize Address Book"

Properties

Article ID: 938286 - Last Review: April 24, 2012 - Revision: 9.0
APPLIES TO
  • Microsoft Office Communications Server 2007 Enterprise Edition
  • Microsoft Office Communications Server 2007 Standard Edition
  • Microsoft Office Communicator 2007
  • Microsoft Office Communications Server 2007 R2 Standard Edition
  • Microsoft Office Communications Server 2007 R2 Enterprise Edition
Keywords: 
kbexpertiseinter kbtshoot kberrmsg kbprb kbcip KB938286

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