Foutbericht wanneer u zich aanmeldt bij een website waarvoor Kerberos-verificatie met Internet Explorer 7: "Toegang is geweigerd vanwege ongeldige referenties"

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 938305 - Bekijk de producten waarop dit artikel van toepassing is.
BelangrijkDit artikel bevat informatie over het wijzigen van het register. Controleer of de back-up van het register voordat u het wijzigt. Zorg ervoor dat u hoe u het register kunt herstellen weet als er een probleem optreedt. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over back-up, terugzetten en het register wijzigen:
256986Beschrijving van het Microsoft Windows-register
Alles uitklappen | Alles samenvouwen

Symptomen

U gebruikt Windows Internet Explorer 7. U probeert aan te melden op een website verificatie voor Kerberos versie 5-protocol vereist. Echter u driemaal gevraagd uw gebruikersreferenties Hoewel voert u de juiste gegevens telkens wanneer u hierom. Wanneer u de website voor de derde keer aanmelden, wordt het volgende foutbericht weergegeven:
HTTP-fout 401.1-: Toegang is geweigerd vanwege ongeldige referenties. Internet informatieservices (IIS)

Oorzaak

Dit probleem treedt op als de website een CNAME-bronrecord in DNS (Domain Name System) gebruikt met de server Kerberos-verificatie initieert. Wanneer u Internet Explorer 7 toegang tot de website, gebruikt Internet Explorer 7 de hostnaam van de server in plaats van de CNAME-bronrecord te maken met de server. Echter is alleen de belangrijkste naam SPN (Service) voor de CNAME-bronrecord geregistreerd op de account die de server voor de verificatie gebruikt. Het verificatieproces werkt daarom niet.

Oplossing

WaarschuwingEr kunnen ernstige problemen optreden als u het register foutief wijzigt met de Register-Editor of met een andere methode. Deze problemen mogelijk het besturingssysteem opnieuw te installeren. Microsoft kan niet garanderen dat deze problemen kunnen worden opgelost. Wijzig het register voor uw eigen risico.

Installeer de hotfix die wordt vermeld in de Microsoft Knowledge Base-artikel 911149 voor dit probleem. Schakel vervolgens de hotfix 911149 op de computer. U doet dit als volgt:
  1. Klik opStart, klik opUitvoeren, typRegedit, en klik vervolgens opOK.
  2. Zoek en klik op de volgende registersubsleutel:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main
  3. Op deBewerkenin het menuNieuwe, en klik vervolgens opSleutel.
  4. TypeFeatureControl, en druk op ENTER.
  5. Klik op deFeatureControlde registervermelding die u in stap 4 hebt gemaakt.
  6. Op deBewerkenin het menuNieuwe, en klik vervolgens opSleutel.
  7. TypeFEATURE_USE_CNAME_FOR_SPN_KB911149, en druk op ENTER.
  8. Klik op deFEATURE_USE_CNAME_FOR_SPN_KB911149de registervermelding die u in stap 7 hebt gemaakt.
  9. Op deBewerkenin het menuNieuwe, en klik vervolgens opDWORD-waarde.
  10. TypeIexplore.exe, en druk op ENTER.
  11. Klik met de rechtermuisknop op de registervermelding Iexplore.exe en klik vervolgens opWijzigen.
  12. In deWaardein het vak1, en klik vervolgens opOK.

    OpmerkingHerstellen de waarde van de registervermelding Iexplore.exe 0x0 terugkeren naar het vorige gedrag voor achterwaartse compatibiliteit.
  13. Sluit Register-Editor.

Meer informatie

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
911149Foutbericht in Internet Explorer wanneer u toegang tot een website waarvoor Kerberos-verificatie op een computer met Windows XP: ' HTTP-fout 401 - niet: toegang is geweigerd vanwege ongeldige referenties "
Opmerking Dit is een artikel voor snelle publicatie dat rechtstreeks is gemaakt vanuit de ondersteuningsorganisatie van Microsoft. De informatie in dit artikel wordt in de huidige vorm aangeboden in reactie op nieuw geconstateerde problemen. Aangezien artikelen van dit type zeer snel moeten worden gepubliceerd, kan de inhoud typografische fouten bevatten en kan de inhoud zonder voorafgaande kennisgeving worden gewijzigd. Raadpleeg de Gebruiksrechtovereenkomst voor overige aandachtspunten.

Eigenschappen

Artikel ID: 938305 - Laatste beoordeling: vrijdag 18 maart 2011 - Wijziging: 2.0
De informatie in dit artikel is van toepassing op:
  • Windows Internet Explorer 7
Trefwoorden: 
kbtshoot kbexpertiseadvanced kbprb kbmt KB938305 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:938305

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com