Komunikat o błędzie podczas próby zalogowania do witryny sieci Web, który wymaga uwierzytelniania Kerberos za pomocą programu Internet Explorer 7: "Odmowa dostępu z powodu nieprawidłowych poświadczeń"

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 938305 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ważne Ten artykuł zawiera informacje na temat sposobu modyfikacji rejestru. Upewnij się, że wykonanie kopii zapasowej rejestru przed przystąpieniem do modyfikacji. Upewnij się, że wiesz, jak przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji dotyczących sposobu wykonywania kopii, przywracania i modyfikowania rejestru kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
256986 Opis rejestru systemu Microsoft Windows
Rozwiń wszystko | Zwiń wszystko

Symptomy

Korzystanie z programu Windows Internet Explorer 7. Spróbuj zalogować się do witryny sieci Web, która wymaga uwierzytelniania protokołu Kerberos w wersji 5. Jednak wyświetlony monit trzy razy poświadczeń użytkownika, nawet jeśli Wprowadź poprawne informacje o każdym razem, gdy zostanie wyświetlony monit o tym. Podczas próby logowania w witrynie sieci Web po raz trzeci może zostać wyświetlony następujący komunikat o błędzie:
Błąd HTTP 401.1 — Brak autoryzacji: Odmowa dostępu z powodu nieprawidłowych poświadczeń. Internet Information Services (IIS)

Przyczyna

Ten problem występuje, jeśli w witrynie sieci Web używa rekord zasobu CNAME w systemie nazw domen (DNS) skontaktować się z serwerem, który inicjuje uwierzytelniania Kerberos. Jeśli dostęp do witryny sieci Web za pomocą programu Internet Explorer 7 program Internet Explorer 7 nazwę hosta serwera zamiast używa rekord zasobu CNAME się z serwerem. Jednak tylko głównej nazwy usługi (SPN) dla rekordu zasobu CNAME jest zarejestrowany na konto, którego serwer używa do uwierzytelniania. Dlatego też proces uwierzytelniania nie działa.

Rozwiązanie

Ostrzeżenie Niepoprawne zmodyfikowanie rejestru przy użyciu Edytora rejestru lub inną metodą może spowodować poważne problemy. Te problemy mogą wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie gwarantuje, że można rozwiązać te problemy. Modyfikowanie rejestru na własne ryzyko.

Aby rozwiązać ten problem, należy zainstalować poprawkę, opisaną w artykule 911149 bazy wiedzy Microsoft Knowledge Base. Następnie należy włączyć poprawkę 911149 na komputerze. Aby to zrobić, wykonaj następujące kroki:
  1. Kliknij przycisk Start, kliknij przycisk Uruchom, wpisz regedit, a następnie kliknij przycisk OK.
  2. Zlokalizuj i kliknij następujący podklucz rejestru:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main
  3. Na Edycja menu, wskaż Nowy, a następnie kliknij przycisk Klucz.
  4. Typ FeatureControl, a następnie naciśnij klawisz ENTER.
  5. Kliknij przycisk FeatureControl wpis rejestru, który został utworzony w kroku 4.
  6. Na Edycja menu, wskaż Nowy, a następnie kliknij przycisk Klucz.
  7. Typ FEATURE_USE_CNAME_FOR_SPN_KB911149, a następnie naciśnij klawisz ENTER.
  8. Kliknij przycisk FEATURE_USE_CNAME_FOR_SPN_KB911149 wpis rejestru, który został utworzony w kroku 7.
  9. Na Edycja menu, wskaż Nowy, a następnie kliknij przycisk Wartość DWORD.
  10. Typ Iexplore.exe, a następnie naciśnij klawisz ENTER.
  11. Kliknij prawym przyciskiem myszy wpis rejestru Iexplore.exe, a następnie kliknij przycisk Modyfikowanie.
  12. W Wartość pole typu 1, a następnie kliknij przycisk OK.

    Uwaga Aby powrócić do poprzedniego zachowania zgodności z poprzednimi wersjami, należy ustawić wartość wpisu rejestru Iexplore.exe na 0x0.
  13. Zamknij Edytor rejestru.

Więcej informacji

Aby uzyskać więcej informacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
911149Komunikat o błędzie w programie Internet Explorer podczas próby dostępu do witryny sieci Web, który wymaga uwierzytelniania Kerberos na komputerze z systemem Windows XP: "Błąd HTTP 401 - nieautoryzowany: odmowa dostępu z powodu nieprawidłowych poświadczeń"
Uwaga: Niniejszy artykuł, przeznaczony do „SZYBKIEJ PUBLIKACJI”, został utworzony bezpośrednio przez organizację pomocy technicznej firmy Microsoft. Zawarte w nim informacje są udostępniane „w stanie takim, w jakim są” w odpowiedzi na pojawiające się problemy. W wyniku przyspieszonego trybu udostępniania materiały mogą zawierać błędy typograficzne i mogą zostać poprawione w dowolnym momencie bez uprzedzenia. Więcej informacji można znaleźć w Warunkach użytkowania.

Właściwości

Numer ID artykułu: 938305 - Ostatnia weryfikacja: 25 czerwca 2011 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Windows Internet Explorer 7
Słowa kluczowe: 
kbtshoot kbexpertiseadvanced kbprb kbmt KB938305 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:938305

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com