Mensagem de erro quando tenta iniciar sessão para um Web site que requer a autenticação Kerberos utilizando o Internet Explorer 7: "Acesso negado devido a credenciais inválidas"

Traduções de Artigos Traduções de Artigos
Artigo: 938305 - Ver produtos para os quais este artigo se aplica.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Sintomas

Está a utilizar o Windows Internet Explorer 7 . Tentar iniciar sessão num Web site que requer autenticação de protocolo Kerberos versão 5. No entanto, é solicitado três vezes as credenciais de utilizador, mesmo que introduza as informações correctas sempre que lhe for pedido para efectuar este procedimento. Quando tenta iniciar sessão no Web site pela terceira vez, recebe a seguinte mensagem de erro:
Erro de HTTP 401.1 - não autorizado: Acesso negado devido a credenciais inválidas. Serviços de informação Internet (IIS)

Causa

Este problema ocorre se o Web site utilizar um registo de recursos CNAME no sistema de nomes de domínio (DNS) para contactar o servidor que inicia a autenticação Kerberos. Quando utiliza o Internet Explorer 7 para aceder ao Web site, o Internet Explorer 7 utiliza o nome de anfitrião do servidor em vez do registo de recurso CNAME contactar o servidor. No entanto, apenas o principal nome serviço (SPN) para o registo de recurso CNAME está registado na conta que o servidor utiliza para a autenticação. Por conseguinte, o processo de autenticação não funciona.

Resolução

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Para resolver este problema, instale a correcção mencionada no artigo da base de dados de conhecimento da Microsoft 911149. Em seguida, Active a correcção 911149 no computador. Para o fazer, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main
  3. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  4. Escreva FeatureControl e, em seguida, prima ENTER.
  5. Clique na entrada registo FeatureControl que criou no passo 4.
  6. No menu Editar , aponte para Novo e, em seguida, clique em chave .
  7. Escreva FEATURE_USE_CNAME_FOR_SPN_KB911149 e, em seguida, prima ENTER.
  8. Clique na entrada registo FEATURE_USE_CNAME_FOR_SPN_KB911149 que criou no passo 7.
  9. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  10. Escreva iexplore.exe e, em seguida, prima ENTER.
  11. Clique com o botão direito do rato na entrada de registo Iexplore.exe e, em seguida, clique em Modificar .
  12. Na caixa valor , escreva 1 e, em seguida, clique em OK .

    Nota Para reverter para o comportamento anterior para compatibilidade com versões anteriores, reponha o valor da entrada de registo Iexplore.exe para 0 x 0.
  13. Saia do Editor de registo.

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
911149Mensagem de erro no Internet Explorer quando tenta aceder a um Web site que requer autenticação de Kerberos num computador com o Windows XP: "Erro HTTP 401 - não autorizado: acesso negado devido a credenciais inválidas"

Propriedades

Artigo: 938305 - Última revisão: 27 de outubro de 2007 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Windows Internet Explorer 7
Palavras-chave: 
kbmt kbtshoot kbexpertiseadvanced kbprb KB938305 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 938305

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com