Error message when you insert an image in a non-English Works Word Processor program: "Works cannot access one or more required files"

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Article ID: 938489 - View products that this article applies to.
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Symptoms

When you try to insert an image or try to open a template that contains images in a non-English Microsoft Works Word Processor program, you may receive the following error message:
Works cannot access one or more required files. The files may have been renamed, deleted or moved. Try reinstalling Works and starting the program again.

Cause

This behavior may occur if one of the following programs is installed:
  • 2007 Microsoft Office system
  • 2007 Microsoft Office Trial
  • Microsoft Works 6.0 Converter for Works and Word Users
You receive the error message for each image that you try to insert, or for each image that appears in the template.

This behavior occurs because two files that are needed are missing from the local language folder. For example, the Wkgl90.dll and Wkimgl90.dll files may be missing from the 1031 folder when you install the German version of Works. However, the Wkgl90.dll and Wkimgl90.dll files are in the 1033 folder as expected. The 1033 folder is the English language folder.

Resolution

To resolve this behavior, follow these steps:
  1. Determine the locale identifier for the version of Works that you are using.

    For more information about locale identifiers, click the following article number to view the article in the Microsoft Knowledge Base:
    221435 List of supported locale identifiers in Word
  2. Open the English locale folder in Works.

    To open the English locale folder in Works on a Windows Vista-based computer, click Start
    Collapse this imageExpand this image
    the Start button
    , type Local disk\Program Files\Microsoft Works\1033 in the Start Search box, and then press ENTER. In this example, Local disk is the drive letter where Works is installed.

    To open the English locale folder in Works on Microsoft Windows XP and earlier versions, click Start, click Run, type Local disk\Program Files\Microsoft Works\1033, and then click OK. In this example, Local disk is the drive letter where Works is installed.
  3. Locate and then right-click the Wkgl90.dll file. Click Copy.
  4. Open the locale folder for the version of Works that you are using.
    To do this in Windows Vista, click Start
    Collapse this imageExpand this image
    the Start button
    , type Local disk\Program Files\Microsoft Works\locale in the Start Search box where locale is the locale ID, and then press ENTER.

    To open the locale folder for the version of Works that you are using in Windows XP and earlier versions, click Start, click Run, type Local disk\Program Files\Microsoft Works\locale, and then click OK. In this example, locale is the locale ID.
  5. Paste the Wkgl90.dll file in the folder that you opened in step 4.

    To do this in Windows Vista, click Paste on the Organize menu.

    To do this in Windows XP and earlier versions, click Paste on the Edit menu.
  6. To copy the Wkimgl90.dll file, repeat steps 2 through 5.

    Note You must substitute the Wkimgl90.dll file for the Wkgl90.dll file in step 3 and in step 5.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 938489 - Last Review: October 24, 2013 - Revision: 1.0
Applies to
  • Microsoft Works 8
Keywords: 
kbnosurvey kbarchive kbtshoot kberrmsg kbexpertisebeginner kbprb KB938489

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