Article ID: 938586 - Last Review: February 4, 2008 - Revision: 1.4

Some applications do not work correctly when you use a DNS server that supports dynamic updates

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SYMPTOMS

You have a Domain Name System (DNS) server that supports dynamic updates. This DNS server also lets multiple pointer (PTR) resource records be added to reverse DNS zones for the same IP address. However, some applications require each IP address to have a unique PTR resource record. Therefore, these applications cannot work correctly.

CAUSE

This problem occurs because the DNS server does not update the PTR resource record when a new record for the same IP address is added by a client or by a Dynamic Host Configuration Protocol (DHCP) server.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.Note After you apply this hotfix, the PTR record registration process changes. A new PTR record replaces the previous record for the same IP address.

Prerequisites

Windows XP Service Pack 2 (SP2) must be installed before you apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Dnsapi.dll5.1.2600.3185147,45625-Jul-200713:52x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

When a network client receives an IP address and related configuration information from a DHCP server, one of the following events occurs:
  • The client registers a host (A) resource record on the DNS server.
  • The client lets the DHCP server register a host (A) resource record, a PTR resource record, or both types of resource records in the DNS database. The DHCP server keeps track of the pointer PTR resource record for the client.
For more information about a similar problem on a Windows Server 2003-based computer, click the following article number to view the article in the Microsoft Knowledge Base:
929768  (http://support.microsoft.com/kb/929768/ ) Some applications do not work correctly when you use a DNS server that supports dynamic updates
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbpubtypekc kbqfe kbhotfixserver KB938586
 

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