The Entity Health monitor for an Operations Manager 2007 management server displays "Critical" together with a Health Service threshold setting

Article ID: 938626 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you open the Health Explorer window in the Microsoft System Center Operations Manager 2007 Operations Console to query an affected management server, the Entity Health monitor for the management server displays Critical together with one or both of the following threshold settings:
  • Health Service Handle Count Threshold
  • Health Service Private Bytes Threshold

CAUSE

This problem occurs because the default threshold values for the Health Service Handle Count Threshold monitor and the Health Service Private Bytes Threshold monitor may be set too low. We recommend that you configure an override setting for these health monitors when they apply to the Management Server Computer Group.

RESOLUTION

To resolve this problem, install the hotfix that is described in the following Microsoft Knowledge Base article:
939799 The System Center Operations Manager 2007 agent is unable to restart the health service after its monitored thresholds are exceeded

WORKAROUND

To work around this problem, apply an override that applies to management servers to the Health Service Handle Count Threshold monitor and to the Health Service Private Bytes Threshold monitor. To do this, follow these steps:
  1. Click Start, point to All Programs, click System Center Operations Manager 2007, and then click Operations Console.
  2. In the Operations Console, click Authoring.
  3. In the Authoring pane, expand Management Pack Objects, and then click Monitors.
  4. On the Operations Console toolbar, click View, and then click Scope.
  5. In the Scope Management Pack Objects by target(s) dialog box, click Clear All.
  6. In the Look for box, type Health Service.
  7. Click to select the Health Service check box, and then click OK.
  8. In the Monitors pane, expand Health Service, expand Entity Health, expand Performance, expand Health Service Performance, right-click Health Service Handle Count Threshold, point to Overrides, point to Override the Monitor, and then click For a group.
  9. In the Select Object dialog box, click to select the group named Management Server Computer Group, and then click OK
  10. In the Override properties dialog box, check to select the Agent Performance Monitor Type - Threshold check box.
  11. In the Override Setting field, change the value from 2000 to 10000, and then click OK.
  12. Right-click Health Service Private Bytes Threshold, point to Overrides, point to Override the Monitor, and then click For a group
  13. In the Select Object dialog box, click to select the group named Management Server Computer Group, and then click OK
  14. In the Override properties dialog box, check to select the Agent Performance Monitor Type - Threshold check box.
  15. In the Override Setting field, change the value from 104857600 to 1610612736, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 938626 - Last Review: January 8, 2008 - Revision: 2.0
APPLIES TO
  • Microsoft System Center Operations Manager 2007
Keywords: 
kbtshoot kbexpertiseinter kbprb KB938626

Give Feedback