ID do artigo: 938627 - Última revisão: quarta-feira, 31 de outubro de 2007 - Revisão: 1.1

Quando você tenta instalar o relatório do Microsoft System Center Operations Manager 2007, a instalação está sem êxito

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Sintomas

Quando você tenta instalar o recurso de relatório do Microsoft System Center Operations Manager 2007, a instalação está sem êxito. Quando esse problema ocorre, log de eventos do Operations Manager pode conter a seguinte mensagem de erro:
Data: data
Fonte: Serviço do SDK do OpsMgr
Tempo: hora
Categoria: nenhum
Tipo: erro
IDENTIFICAÇÃO de evento: 26319
Usuário: N/d
Computername do computador:
Descrição: Uma exceção lançada durante o processamento GetUserRolesForOperationAndUser para uuid:UUID de id de sessão. Mensagem de exceção: Acesso negado. (Exceção de HRESULT: 0 x 80070005 (E_ACCESSDENIED)) Exceção completa: System.UnauthorizedAccessException: acesso negado. (Exceção fro HRESULT: 0 x 80070005 (E_ACCESSDENIED))
Mensagem de exceção: Acesso negado. (Exceção de HRESULT: 0 x 80070005 (E_ACCESSDENIED)) Exceção completa: System.UnauthorizedAccessException: acesso negado. (Exceção de HRESULT: 0 x 80070005 (E_ACCESSDENIED)) em Microsoft.Interop.Security.AzRoles.IAzApplication2.InitializeClientContextFr omStringSid (SidString String, Int32 lOptions, objeto varReserved) em Microsoft.EnterpriseManagement.Mom.sdk.Authorization.AzManHelper.GetScopedRo leAssignmentsForUser (IList ` 1 roleNames, String userName) em Microsoft.EnterpriseManagement.Mom.sdk.Authorization.AuthManager.GetUserRole sForOperationAndUser (operationId GUID, String userName) em Microsoft.EnterpriseManagement.Mom.ServiceDataLayer.SdkDataAccess.GetUserRol esForOperationAndUser (operationId GUID, String userName) em Microsoft.EnterpriseManagement.Mom.ServiceDataLayer.SdkDataAccessTieringWrap per.GetUserRolesForOperationAndUser (operationId GUID, String userName) em Microsoft.EnterpriseManagement.Mom.ServiceDataLayer.SdkDataAccessExceptionTr acingWrapper.GetUserRolesForOperationAndUser (operationId GUID, String userName)

Causa

Esse problema ocorre quando a conta de serviço SDK não tem acesso de leitura ao atributo tokenGroupsGlobalAndUniversal . Gerenciador de autorização do SDK do serviço requer esse acesso para determinar os grupos de segurança para o qual um usuário pertence.

Esse problema ocorre se uma das seguintes condições for verdadeira:
  • Você instala o recurso de relatórios do Operations Manager 2007 em um ambiente de domínio Windows Server 2003 e é ativada a opção permissões compatíveis somente com os sistemas operacionais Windows 2000 ou Windows Server 2003 .
  • Você instala o recurso de relatórios do Operations Manager 2007 em um ambiente de domínio Windows 2000 e a opção permissões compatíveis somente com servidores Windows 2000 está ativada.

Resolução

Para resolver esse problema, adicione a conta de serviço SDK ao grupo Windows acesso de autorização. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , aponte para Ferramentas administrativas e, em seguida, clique em Active Directory Users and Computers .
  2. No Active Directory Users and Computers, clique em Builtin e, em seguida, clique duas vezes em Grupo de acesso de autorização do Windows .
  3. Clique na guia membros e adicione a conta de serviço SDK à lista de membros.

Mais Informações

Por padrão, se a opção permissões compatíveis com servidores 2000 pré-Windows é ativada quando o domínio é criado, cada membro do domínio é adicionado ao grupo de acesso compatível anterior ao Windows 2000. Nessa situação, o grupo Acesso compatível anterior ao Windows 2000 tem acesso de leitura ao atributo tokenGroupsGlobalAndUniversal . Portanto, nenhuma ação é necessária a menos que o nome do grupo Acesso compatível anterior ao Windows 2000 manualmente é alterado.

Para obter mais informações sobre esse problema, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
331951  (http://support.microsoft.com/kb/331951/ ) Alguns aplicativos e APIs exigir acesso a informações de autorização em objetos de conta

A informação contida neste artigo aplica-se a:
  • Microsoft System Center Operations Manager 2007
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 938627  (http://support.microsoft.com/kb/938627/en-us/ )