Help and Support
 

powered byLive Search
Hotfix Download Available

A meeting update message or a meeting cancellation message from an Exchange 2003 user is not delivered to an Exchange 2007 user

Article ID:938650
Last Review:October 25, 2007
Revision:2.3
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry
On This Page

SYMPTOMS

Consider the following scenario. A Microsoft Exchange Server 2003 organization and a Microsoft Exchange Server 2007 organization exchange communications by using SMTP. An Exchange 2003 user organizes a meeting and then sends a meeting request to an Exchange 2007 user. Additionally, the Exchange 2007 user accepts the meeting request. Then, the meeting organizer uses Microsoft Office Outlook to send a meeting update message or a meeting cancellation message to the Exchange 2007 user.

In this scenario, the meeting update message or the meeting cancellation message is not delivered to the Exchange 2007 user. Instead, the meeting update message or the meeting cancellation message goes into the SMTP retry queue. If an administrator tries to open the message in the Exchange System Manager console, the administrator may receive the following error message:
Unable to open for delivery
Additionally, if the diagnostics logging of the MSExchangeTransport component is set to maximum, the following warning is logged:

Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Exchange Store Driver
Event ID: 327
Description:
The following call : EcGetMime to the store failed. Error code : -2147467259. MDB : <xxxxxxxx>. FID :<xxxx> . MID : <xxxx>. File : .

Back to the top

CAUSE

When an Exchange 2007 user accepts a meeting request from an Exchange 2003 user, the X-MICROSOFT-CDO-ATTENDEE-CRITICAL-CHANGE attribute is missed. In the Outlook client, if the X-MICROSOFT-CDO-ATTENDEE- CRITICAL-CHANGE attribute is missing, the PR_RECIPIENT_TRACKSTATUS_TIME property is set to "1/1/1601 00:00:00 AM." When the Exchange 2003 user tries to send an update of the meeting request or a cancellation of the meeting request, the value of the PR_RECIPIENT_TRACKSTATUS_TIME property cannot be successfully converted from the MAPI format to the MIME format by using the VariantTimeToSystemTime function.

Back to the top

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install the hotfix, you must create the FixRecipientTrackStatusTime register entry to enable the hotfix. To do this, follow these steps:
1.Click Start, click Run, type Regedit, and then click OK.
2.Locate the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent\MimeHandlers\{85D2DDB8-6225-11D2-BDF1-00C04FD655B5}
3.On the Edit menu, point to New, and then click DWORD Value.
4.In the details pane, type FixRecipientTrackStatusTime for the new value, and then press ENTER.
5.Right-click FixRecipientTrackStatusTime, and then click Modify.
6.In the Edit DWORD Value dialog box, click Decimal under Base.
7.In the Value data box, type 1, and then click OK.
8.Exit Registry Editor.

Back to the top

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Microsoft Exchange Server 2003 Service Pack 2 (SP2) must be installed before you apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 (http://support.microsoft.com/kb/836993/) How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services are automatically restarted when you apply this hotfix:
The Microsoft Exchange System Attendant service
The Internet Information Services (IIS) Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Cdo.dll6.5.7653.5720,89621-Jun-200716:28
Cdoex.dll6.5.7653.53,948,54421-Jun-200722:22
Davex.dll6.5.7653.51,131,52021-Jun-200722:19
Excdo.dll6.5.7653.53,634,68821-Jun-200722:22
Exoledb.dll6.5.7653.52,619,90421-Jun-200707:20
Lsmexhc.dll6.5.7653.5125,44021-Jun-200716:30
Madfb.dll6.5.7653.5525,31221-Jun-200722:22
Massync.dll6.5.7653.5757,24821-Jun-200717:01
Microsoft.exchange.oma.userinterface.dll6.5.7653.5397,31221-Jun-200716:52
Rtdsmcal.dll6.5.7653.534,30421-Jun-200716:50

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top


APPLIES TO
Microsoft Exchange Server 2003 Enterprise Edition
Microsoft Exchange Server 2003 Standard Edition

Back to the top

Keywords: 
kbautohotfix kbexchcoexistmigration kbexchtransport kbexpertiseinter kbqfe kbhotfixserver KB938650

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.