Help and Support

The Microsoft Exchange Information Store service uses almost 100 percent of CPU resources on an Exchange 2007 server, and Outlook clients display the "Outlook retrieving data" dialog box

Article ID:938698
Last Review:August 30, 2007
Revision:1.2

SYMPTOMS

On a server that is running Microsoft Exchange Server 2007, the Microsoft Exchange Information Store service uses almost 100 percent of CPU resources. When this occurs, Microsoft Office Outlook clients cannot connect to the Exchange 2007 server. Then, the Outlook clients display the Outlook retrieving data dialog box.

Back to the top

CAUSE

This problem occurs because long-running transactions cause the Microsoft Exchange Information Store service to use almost 100 percent of CPU resources. In this case, the large message generates the running transactions that cause this problem.

Back to the top

RESOLUTION

To resolve this problem, install Update Rollup 4 for Exchange Server 2007. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
940006 (http://support.microsoft.com/kb/940006/) Description of Update Rollup 4 for Exchange Server 2007

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

When this problem occurs, the following call stack is generated:
0:065> kbnL
# RetAddr : Args to Child : Call Site
00 00000000`5421cccc : 00000000`32985200 00000000`60770200 00000000`00000000 00000000`32985200 : ese!ErrBFIPrepareFlushPage+0x110
01 00000000`5421f375 : 00000000`0ea8fa40 00000000`11af0900 00000000`00000000 00000000`11af0900 : ese!ErrBFIFlushPage+0xec
02 00000000`5421f9eb : 00006077`02000000 00000000`0ea8fa30 00000000`fffffeff 00000000`0ea8fa40 : ese!ErrBFIOB0MaintEntry+0x1a5
03 00000000`5422038a : 00000000`00000003 00000000`00000010 00000000`00000000 00000000`00000000 : ese!ErrBFIOB0MaintScan+0x53b
04 00000000`54220dd2 : 00000000`ffffffff 00000000`019f5200 00000000`00000708 00000000`11af0900 : ese!ErrBFIMaintCheckpointDepthIFlushPagesByIFMP+0x71a
05 00000000`5422110b : 00000000`0ea8fbb8 00000000`00841b65 00000000`019eeb48 00000000`54390ac0 : ese!BFIMaintCheckpointDepthIFlushPages+0x242
06 00000000`54390b35 : 00000000`00000000 00000000`ffffffff 00000000`54390ac0 00000000`019eeb00 : ese!BFIMaintCheckpointDepthITask+0x5b
07 00000000`77eeaf13 : 00000000`11ab4490 00000000`00000000 00000000`00000000 00000000`00000000 : ese!COSTimerQueueEntry::Completion_+0x75
08 00000000`77eec727 : 00000000`359fe260 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlpWaitOrTimerCallout+0x18c
09 00000000`77eea78a : 00000000`0ea8fdb0 00000000`00000000 00000000`00000000 00000000`77eec6e0 : ntdll!RtlpAsyncTimerCallbackCompletion+0x46
0a 00000000`77eea99f : 00000000`359fafbf 00000000`77eec1e5 00000000`00000000 00000000`00000000 : ntdll!RtlpWorkerCallout+0x183
0b 00000000`77eeac75 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlpExecuteWorkerRequest+0x63
0c 00000000`77d6b6da : 00000000`77d6b6a0 00000000`00000000 00000000`00000000 00000000`77ef0600 : ntdll!RtlpWorkerThread+0x71
0d 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadStart+0x3a

Back to the top


APPLIES TO
Microsoft Exchange Server 2007 Enterprise Edition
Microsoft Exchange Server 2007 Standard Edition

Back to the top

Keywords: 
kbexpertiseinter kbqfe KB938698

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.