You may be unable to save a file in a Microsoft Office program on a Windows Vista-based computer

Article translations Article translations
Article ID: 938716 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to save a file in a Microsoft Office program on a Windows Vista-based computer, the save operation may fail. Additionally, a new 0-byte destination file may be generated.

This issue may occur if the following conditions are true:
  • The client-side caching (CSC) feature is enabled.
  • A program is monitoring the files or folders on the computer.

CAUSE

When an Office program tries to save a file, the Office program renames a temporary file to generate the destination file. In this situation, the CSC component sends a change notification to the temporary file. This behavior causes the monitoring program to open a handle on the temporary file. This open handle prevents the Office program from completing the save operation. Therefore, the save operation fails, and a 0-byte file is generated.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable1,76916-Jun-200711:19Not Applicable
X86_17c2cd2d00ac2c3d69c3e1e6feee3feb_31bf3856ad364e35_6.0.6000.20621_none_53472d4f190611f7.manifestNot Applicable70516-Jun-200711:19Not Applicable
X86_microsoft-windows-offlinefiles-core_31bf3856ad364e35_6.0.6000.20621_none_9cd7059877edad01.manifestNot Applicable15,17916-Jun-200711:21Not Applicable
Csc.sys6.0.6000.20621320,00016-Jun-200700:55x86
Cscmig.dll6.0.6000.20621105,98416-Jun-200702:06x86
Microsoft-windows-offlinefiles-core-ppdlic.xrm-msNot Applicable3,02116-Jun-200701:58Not Applicable
Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_e934062dd1ae4c4d3349cd231f709fa6_31bf3856ad364e35_6.0.6000.20621_none_7c4fac84be86e6c6.manifestNot Applicable70916-Jun-200711:19Not Applicable
Amd64_microsoft-windows-offlinefiles-core_31bf3856ad364e35_6.0.6000.20621_none_f8f5a11c304b1e37.manifestNot Applicable15,20716-Jun-200711:33Not Applicable
Update.mumNot Applicable1,77916-Jun-200711:19Not Applicable
Csc.sys6.0.6000.20621418,30416-Jun-200701:09x64
Cscmig.dll6.0.6000.20621134,14416-Jun-200703:19x64
Microsoft-windows-offlinefiles-core-ppdlic.xrm-msNot Applicable3,02116-Jun-200703:09Not Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 938716 - Last Review: November 27, 2007 - Revision: 1.1
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbexpertisebeginner kbfix kbqfe kbhotfixserver KB938716

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com