เมื่อคุณพยายามที่จะตรวจสอบสำเนาของ Windows XP คุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้: "0x80080201 ไม่สามารถตรวจพบหมายเลขผลิตภัณฑ์ (PID)"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 938720 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามที่จะตรวจสอบสำเนาของ Microsoft Windows XP คุณได้รับข้อความแสดงข้อความแสดงข้อผิดพลาดที่ Windows ของแท้ Advantage (WGA) ต่อไปนี้:
0x80080201 ไม่สามารถตรวจหารหัสประจำผลิตภัณฑ์ (PID)

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจาก Windows XP อยู่ในสถานะที่ป้องกันไม่ให้เข้าถึงหมายเลข (PID) ของผลิตภัณฑ์ WGA สถานะนี้อาจเกิดขึ้นสำหรับการเนื่องจากสาเหตุต่อไปนี้:
  • แฟ้ม %windir%\System32\Wpa.dbl จะสูญหาย หรือเสียหาย
  • การตั้งค่าการรักษาความปลอดภัยหรือการตั้งค่าแอตทริบิวต์ของแฟ้ม %windir%\System32\Wpa.dbl ไม่ถูกต้อง
  • เครื่องมือบางอย่างที่สามารถดาวน์โหลดได้มีย้าย หรือปรับเปลี่ยนรหัสผลิตภัณฑ์
  • ค่ารหัสผลิตภัณฑ์ในรีจิสทรีจะสูญหาย หรือเสียหาย
  • อย่างน้อยหนึ่งแฟ้มต่อไปนี้อาจเป็นรุ่นที่ไม่ถูกต้อง หรือเหล่านั้นอาจจะไม่ลงทะเบียน:
    • Licdll.dll
    • Licwmi.dll
    • Legitcheckcontrol.dll

การแก้ไข

เมื่อต้องการแก้ปัญหานี้ ให้ทำตามขั้นตอนต่อไปนี้

ขั้นตอนที่ 1: ตรวจสอบว่า การตรวจสอบการตรวจสอบมีความล้มเหลว

  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:/a oobe/msoobeแล้ว คลิกตกลง.

    หมายเหตุ:ไม่มีช่องว่างระหว่างmsoobeและ/a.
  2. กระบวนการเปิดใช้งาน Windowsกล่องโต้ตอบปรากฏขึ้น ทำตามคำแนะนำที่ปรากฏบนหน้าจอเพื่อเรียกใช้ Windows XP ถ้าคุณยังคงได้รับข้อความแสดงข้อผิดพลาด ไปที่ขั้นตอนที่ 2

ขั้นตอนที่ 2: ดาวน์โหลด และการลงทะเบียนแฟ้ม Legitcheckcontrol.dll รุ่นล่าสุดแล้ว

  1. เมื่อต้องการดาวน์โหลดแฟ้ม LegitCheckControl.cab แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://download.microsoft.com/download/9/b/d/9bdc68ef-6a9f-4505-8fb8-d0d2d160e512/LegitCheckControl.cab
  2. แยกแฟ้ม LegitCheckControl.cab กับไดเรกทอรีชั่วคราวบนคอมพิวเตอร์ของคุณ
  3. การคัดลอกแฟ้ม Legitcheckcontrol.dll ในไดเรกตอรีชั่วคราวไป%windir%\System32ไดเรกทอรี
  4. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:cmdแล้ว คลิกตกลง.
  5. การลงทะเบียนแฟ้ม LegitcheckControl.dll รุ่นใหม่ ด้วยการพิมพ์คำสั่งต่อไปนี้ที่พร้อมท์รับคำสั่ง:
    regsvr32 %windir%\system32\legitcheckcontrol.dll
  6. เริ่มต้นระบบคอมพิวเตอร์ใหม่
  7. หลังจากที่มีการเริ่มคอมพิวเตอร์ใหม่ ทำขั้นตอนที่ 1 อีกครั้งเพื่อตรวจสอบว่า ปัญหายังคงอยู่ ถ้าคุณยังคงได้รับข้อความข้อผิดพลาด ไปที่ขั้นตอนที่ 3

ขั้นตอนที่ 3: การลงทะเบียนแฟ้ม Licwmi.dll

  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:cmdแล้ว คลิกตกลง.
  2. ที่พรอมต์คำสั่ง ให้พิมพ์คำสั่งต่อไปนี้ แล้วกด ENTER::
    regsvr32 /u %windir%\system32\licwmi.dll
  3. ทำขั้นตอนที่ 1 อีกครั้ง ถ้าคุณยังคงได้รับข้อความข้อผิดพลาด ไปที่ขั้นตอนที่ 4

ขั้นตอนที่ 4: การลงทะเบียนแฟ้ม Licdll.dll

  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:cmdแล้ว คลิกตกลง.
  2. ที่หน้าจอพร้อมรับคำสั่ง ให้พิมพ์คำสั่งต่อไปนี้ กด ENTER หลังจากแต่ละคำสั่ง
    regsvr32 /u %windir%\system32\licdll.dll
    หยุดสุทธิ winmgmt
  3. หลังจากที่หยุดบริการ Winmgmt พิมพ์คำสั่งต่อไปนี้ที่พร้อมท์รับคำสั่ง และกด enter:
    เริ่มต้นสุทธิ winmgmt
  4. ทำขั้นตอนที่ 1 อีกครั้ง ถ้าคุณยังคงได้รับข้อความข้อผิดพลาด ไปที่ขั้นตอนที่ 5

ขั้นตอนที่ 5: ตรวจสอบค่าสำหรับ ProductID ในรีจิสทรี

  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:regeditแล้ว คลิกตกลง.
  2. ค้นหา และคลิ กขวาที่ค่ารีจิสทรีต่อไปนี้:
    NT\CurrentVersion\ProductID HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
  3. ตรวจสอบว่า ค่ารีจิสทรีปรากฏในรูปแบบต่อไปนี้:
    <12345-ver-1234567-89012></12345-ver-1234567-89012>
  4. ถ้าค่าปรากฏขึ้นอย่างถูกต้อง การรีสตาร์ทเครื่องคอมพิวเตอร์ และจากนั้น ทำตามขั้นตอนที่ 1 อีกครั้ง
  5. ถ้าคุณยังคงได้รับข้อความข้อผิดพลาด ไปที่ขั้นตอนที่ 6

ขั้นตอนที่ 6: ตรวจสอบให้แน่ใจว่า แอตทริบิวต์แฟ้ม Wpa.dbl จะไม่ตั้งค่าเป็นแบบอ่านอย่างเดียว

  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:attrib - r %windir%\system32\wpa.dblแล้ว คลิกตกลง.
  2. ทำขั้นตอนที่ 1 อีกครั้ง ถ้าคุณยังคงได้รับข้อความข้อผิดพลาด ไปที่ขั้นตอนที่ 7

ขั้นตอนที่ 7: ตรวจสอบการตั้งค่าความปลอดภัยสำหรับแฟ้ม Wpa.dbl

  1. ใน Windows Explorer ค้นหาแฟ้ม %windir%\System32\Wpa.dbl
  2. คลิกขวาWpa.dblแล้ว คลิกคุณสมบัติ.
  3. ในการการรักษาความปลอดภัยแท็บ คลิกเพื่อเลือกกลุ่ม SYSTEM ตรวจสอบว่า การอนุญาตให้กล่องกาเครื่องหมายสำหรับควบคุมทั้งหมดถูกเลือก ถ้าควบคุมทั้งหมดจะไม่ได้เลือกสำหรับกลุ่ม SYSTEM เลือกนั้น และคลิกตกลง.
  4. ทำขั้นตอนที่ 1 อีกครั้ง ถ้าคุณยังคงได้รับข้อความข้อผิดพลาด ไปที่ขั้นตอนที่ 8
หมายเหตุ:ใน Windows XP Edition หน้าแรกการรักษาความปลอดภัยแท็บปรากฏขึ้น เฉพาะ เมื่อคอมพิวเตอร์ที่กำลังทำงานในเซฟโหมด นอกจากนี้ยัง ใน Windows XP Professional,การรักษาความปลอดภัยแท็บปรากฏขึ้น เมื่อเท่านั้นใช้การแชร์แฟ้มอย่างง่ายร่วม (แนะนำ)กล่องกาเครื่องหมายที่อยู่ในนั้นตัวเลือกโฟลเดอร์ไม่มีเลือกกล่องโต้ตอบ

ขั้นตอนที่ 8: เรียกใช้เครื่องมือ Microsoft ของแท้ Advantage การวินิจฉัย (MGADIAG)

  1. เมื่อต้องการรันเครื่องมือ แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://go.microsoft.com/fwlink/?linkid=52012
  2. ในการแฟ้มการดาวน์โหลด - คำเตือนเกี่ยวกับการรักษาความปลอดภัยกล่องโต้ตอบ คลิกเรียกใช้.
  3. ในการInternet Explorer - คำเตือนเกี่ยวกับการรักษาความปลอดภัยกล่องโต้ตอบ คลิกเรียกใช้.
  4. ในการเครื่องมือการวินิจฉัย Advantage ของแท้ของ Microsoftกล่องโต้ตอบ คลิกดำเนินการต่อ.
  5. เมื่อเครื่องมือ MGADIAG เสร็จสิ้น คลิกCopy.
  6. แวะไปที่ศูนย์ข้อมูลแบบออนไลน์ของ Windows XP ของแท้ Advantage ปัญหาการตรวจสอบที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://forums.microsoft.com/Genuine/ShowForum.aspx?ForumID=442 &amp; SiteID = 25
    คุณสามารถสร้างเธรดใหม่นี้เว็บไซต์ที่มีข้อมูลที่คุณคัดลอกจากเครื่องมือ MGADIAG

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับ WGA แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://www.microsoft.com/genuine/downloads/whyValidate.aspx
หากต้องการทราบข้อมูลเพิ่มเติม โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base::
892130คำอธิบายของ Windows ของแท้ Advantage (WGA)
916247windows ของแท้ Advantage ไม่ตรวจสอบสำเนาของ Windows XP
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการเปิดใช้งาน Windows XP คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
307890วิธีการเปิดใช้งาน Windows XP

คุณสมบัติ

หมายเลขบทความ (Article ID): 938720 - รีวิวครั้งสุดท้าย: 16 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Genuine Advantage
Keywords: 
kbtshoot kbprb kbmt KB938720 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:938720

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com