Visio 2003 서비스 팩 3 또는 Visio 2007 서비스 팩 2를 설치한 후 CAD 파일을 사용할 수 없도록 설정하는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 938803 - 이 문서가 적용되는 제품 보기.
중요 이 문서에서는 레지스트리 수정 방법을 설명합니다. 레지스트리를 수정하기 전에 레지스트리를 백업해야 하며, 문제가 발생하는 경우 복원하는 방법을 알고 있어야 합니다. 레지스트리 백업, 복원 및 수정 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322756 Windows XP 및 Windows Server 2003에서 레지스트리를 백업, 편집 및 복원하는 방법
모두 확대 | 모두 축소

소개

이 문서에서는 Microsoft Office Visio 2003 서비스 팩 3(SP3) 또는 Microsoft Office Visio 2007 서비스 팩 2(SP2)를 설치한 후 CAD .dwg 파일을 사용할 수 없도록 설정하는 방법에 대해 설명합니다.

추가 정보

경고 레지스트리 편집기를 사용하거나 다른 방법을 사용하여 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있으며, 이러한 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 이러한 문제에 대해 해결을 보증하지 않습니다. 레지스트리의 수정에 따른 모든 책임은 사용자에게 있습니다.

Visio 2003 SP3 또는 Microsoft Office Visio 2007 SP2를 설치한 후 Visio 2003 또는 Visio 2007에서 .dwg 파일을 사용할 수 없도록 설정할 수 있습니다. Visio 파일의 보안을 강화하기 위해 Visio 2003 또는 Visio 2007에서 .dwg 파일을 사용할 수 없도록 설정할 수 있습니다.

.dwg 파일을 사용할 수 없도록 설정하면 다음과 같은 문제가 발생합니다.
  • 열기 대화 상자의 파일 형식 상자에 AutoCAD 드로잉 (*.dwg; *.dxf)이 나타나지 않습니다.
  • 삽입 메뉴에서 CAD 드로잉이 사용할 수 없도록 설정되어 있습니다.
  • CAD 개체가 포함된 Visio 파일을 열면 CAD 개체가 빈 컨테이너로 나타납니다. CAD 개체의 ActiveX 컨트롤이 사용할 수 없도록 설정되어 있습니다.
  • 다른 이름으로 저장 대화 상자의 파일 형식 상자에 AutoCAD 드로잉 (*.dwg; *.dxf)이 나타나지 않습니다.
  • 도구 메뉴에서 추가 기능을 가리키면 CAD 드로잉 변환이 사용할 수 없도록 설정되어 있습니다.
  • 도구 메뉴에서 추가 기능을 가리키면 CAD 라이브러리 변환이 사용할 수 없도록 설정되어 있습니다.
.dwg 파일을 사용할 수 없도록 설정하려면 다음과 같이 하십시오.
  1. Visio를 종료합니다.
  2. 레지스트리 편집기를 시작합니다. 이렇게 하려면 다음 방법 중 하나를 사용하십시오.
    • Windows Vista에서는 시작
      그림 축소그림 확대
      시작 단추
      을 누르고 검색 시작 상자에 regedit를 입력한 다음 Enter 키를 누릅니다.

      그림 축소그림 확대
      사용자 계정 컨트롤 허용
      관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 계속을 누릅니다.
    • Windows XP에서는 시작, 실행을 차례로 누르고 열기 상자에 regedit를 입력한 다음 확인을 누릅니다.
  3. 다음 레지스트리 키를 찾아 누릅니다.
    • Visio 2003:
      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Visio\Application
    • Visio 2007:
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Visio\Application
  4. 3단계에서 지정한 키를 누른 후 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 누릅니다.
  5. DisableDWG를 입력한 다음 Enter 키를 누릅니다.
  6. DisableDWG를 마우스 오른쪽 단추로 누른 다음 수정을 누릅니다.
  7. 값 데이터 상자에 1을 입력한 다음 확인을 누릅니다.
  8. 파일 메뉴에서 끝내기를 눌러 레지스트리 편집기를 끝냅니다.
이 문서에 나와 있는 다른 공급업체 제품은 Microsoft와 무관한 회사에서 제조한 것입니다. Microsoft는 이들 제품의 성능이나 신뢰성에 관하여 명시적이든 묵시적이든 어떠한 보증도 하지 않습니다.

속성

기술 자료: 938803 - 마지막 검토: 2009년 5월 8일 금요일 - 수정: 2.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Office Visio 2003 Service Pack 3?을(를) 다음과 함께 사용했을 때
    • Microsoft Office Visio Professional 2003
    • Microsoft Office Visio Standard 2003
  • 2007 Microsoft Office Suite Service Pack 2?을(를) 다음과 함께 사용했을 때
    • Microsoft Office Visio Professional 2007
    • Microsoft Office Visio Standard 2007
키워드:?
kbregistry kbupdateissue kbexpertiseinter kbhowto KB938803

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com