Informace o určitých typech souborů blokovaných po instalaci aktualizace Office 2003 Service Pack 3

Překlady článku Překlady článku
ID článku: 938810 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek obsahuje informace o určitých typech souborů, které jsou po instalaci aktualizace Microsoft Office 2003 Service Pack 3 (SP3) blokovány.

ÚVOD

Tento článek obsahuje podrobné informace o typech souborů, které jsou po instalaci aktualizace Office 2003 SP3 blokovány, a o opětovném povolení těchto souborů.

Další informace

Blokované typy souborů

Po instalaci aktualizace Office 2003 SP3 jsou blokovány následující typy souborů aplikací Microsoft Office Excel 2003, Microsoft Office PowerPoint 2003 a Microsoft Office Word 2003. Tyto typy souborů jsou ve výchozím nastavení blokovány, protože kód pro analýzu používaný v aplikacích Office 2003 při otevírání a ukládání těchto typů souborů je méně zabezpečený. Z tohoto důvodu pro vás může otevírání a ukládání těchto typů souborů představovat určité riziko.

Následující tabulka obsahuje názvy hodnot registru a jim odpovídající typy souborů, jejichž otevření je ve výchozím nastavení blokováno.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název hodnoty registruBlokované typy souborů
CDRSoubory aplikace Corel Draw (CDR)
LotusandQuattroFilesWK1, WK4, WJ3, WK1 FMT, WKS, WK3, WK3 FM3, WJ2, WQ1, FM3, WJ1
LegacyBinaryFilesGrafy aplikace Microsoft Excel 4.0 (XLC)
LegacyDatabaseAndDatasourceFilesSoubory DBF 2 (dBASE II) (DBF)
FilesBeforePowerPoint97Tato zásada zabrání otevření souborů starších než PowerPoint 97, které mají typy souborů jako PPT, POT, PPS nebo PPA. Verze Microsoft PowerPoint 97 se to ještě netýká.
FilesBeforeVersionOtevření všech souborů aplikace Word s nižším číslem verze než Word 6.0 pro systém Windows je blokováno. To zahrnuje následující verze souborů:
  • Word 1.x for Windows
  • Word 4.x for Macintosh
  • Word 1.2 for Windows Japan
  • Word 1.2 for Windows Korea
  • Word 5.x for Macintosh
  • Word 1.2 for Windows Taiwan
  • Word 2.x for Windows
  • Word 2.x for Windows BiDi
  • Word 2.x for Windows Japan
  • Word 2.x for Windows Korea
  • Word 2.x for Windows Taiwan
Výchozí číslo verze lze zvýšit či snížit. Posunutím dolů zobrazíte další verze v seznamu.
Následující tabulka obsahuje názvy hodnot registru a jim odpovídající typy souborů, jejichž uložení je ve výchozím nastavení blokováno.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Názvy hodnot registruBlokované typy souborů
FilesBeforePowerPoint97Tato zásada zabrání uložení souborů starších než PowerPoint 97, které mají typy souborů jako PPT, POT, PPS nebo PPA. Verze Microsoft PowerPoint 97 se to ještě netýká.
LotusandQuattroFilesWK1, WK4, WJ3, WK1 FMT, WKS, WK3, WK3 FM3, WJ2, WQ1, FM3, WJ1
LegacyBinaryFilesGrafy aplikace Microsoft Excel 4.0 (XLC)
LegacyDatabaseAndDatasourceFilesSoubory DBF 2 (dBASE II) (DBF)

Povolení blokovaných typů souborů

Důležité: Tento postup může zvýšit bezpečnostní riziko pro počítač. Tento postup může také oslabit zabezpečení počítače nebo sítě vůči útoku uživatelů se zlými úmysly nebo škodlivému softwaru, například virům. Doporučujeme použít postup uvedený v tomto článku, který umožňuje, aby programy pracovaly zamýšleným způsobem, nebo použít specifické možnosti programů. Před provedením změn však doporučujeme vyhodnotit nebezpečí spojená s nasazením daného postupu v konkrétním prostředí. Pokud se rozhodnete tento postup použít, učiňte veškerá vhodná dodatečná opatření k ochraně systému. Doporučujeme tento postup použít pouze tehdy, pokud je to opravdu nutné.

Chcete-li povolit blokované typy souborů, použijte některou z následujících metod.

Metoda 1: Automatické opětovné povolení všech typů souborů pomocí aktualizace ke stažení

Společnost Microsoft vytvořila sadu aktualizací, která umožňuje znovu povolit blokované typy souborů. Chcete-li tyto aktualizace nainstalovat, postupujte takto:

Další informace o tom, jak stahovat soubory podpory společnosti Microsoft, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
119591 Jak získat soubory podpory společnosti Microsoft ze serverů služeb online
Tento soubor byl zkontrolován na výskyt virů. Společnost Microsoft použila ke kontrole tohoto souboru nejnovější antivirový software, který byl v době jeho publikování k dispozici. Soubor je uložený na zabezpečených serverech neumožňujících neoprávněné změny souborů.
  1. Stáhněte příslušné soubory z webu služby Stažení softwaru. Klepněte na jeden či více následujících odkazů:
  2. Poklepejte na soubor uložený v kroku 1.
  3. Klepnutím na tlačítko Ano potvrďte instalaci tohoto souboru.
  4. Pokud běží některá aplikace sady Office, je třeba tuto aplikaci restartovat.
Po instalaci této aktualizace bude aktualizováno nastavení registru, které umožní otevírat a ukládat všechny typy souborů podporované sadou Microsoft Office 2003. Tyto typy souborů zahrnují typy souborů blokované ve výchozím nastavení po aktualizaci Office 2003 SP3. Kód pro analýzu používaný při otevírání a ukládání těchto typů souborů je méně zabezpečený. Instalaci těchto aktualizací doporučujeme pouze tehdy, pokud s těmito typy souborů pracujete pravidelně.

Společnost Microsoft také vytvořila sadu aktualizací, která obnoví nastavení registru do stavu po instalaci aktualizace Office 2003 SP3. Chcete-li tyto aktualizace nainstalovat, postupujte takto:
  1. Stáhněte příslušné soubory z webu služby Stažení softwaru. Klepněte na jeden či více následujících odkazů:
  2. Poklepejte na soubor uložený v kroku 1.
  3. Klepnutím na tlačítko Ano potvrďte instalaci tohoto souboru.
  4. Pokud běží některá aplikace sady Office, je třeba tuto aplikaci restartovat.
Poznámka: Po instalaci této aktualizace budou nastavení registru aktualizována do stavu po instalaci aktualizace Office 2003 SP3. Navíc nebude nadále možné otevírat a ukládat typy souborů, které jsou ve výchozím nastavení v aktualizaci Office 2003 SP3 blokovány.

Metoda 2: Nastavení klíčů registru pomocí šablon pro správu

Klíče registru můžete nastavit pomocí šablon pro správu obsažených v aktualizaci „Šablona pro správu sady Office 2003 Service Pack 3 (ADM), soubory OPA a aktualizovaný vysvětlující text“.

Tuto aktualizaci naleznete na následujícím webu společnosti Microsoft:
http://www.microsoft.com/downloads/details.aspx?familyid=BA8BC720-EDC2-479B-B115-5ABB70B3F490

Metoda 3: Ruční nastavení hodnoty registru

Chcete-li pro některé aplikace povolit tyto typy souborů, můžete ručně nastavit hodnoty registru. Použijte následující postupy (podle používané aplikace).

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zazálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Zálohování, úpravy a obnovení registru v systémech Windows XP a Windows Server 2003


Poznámka: Tyto typy souborů byste měli odblokovat jen dočasně. Po otevření nebo uložení příslušných souborů tyto typy opět zablokujte.
Aplikace Excel
Chcete-li v aplikaci Excel 2003 povolit otevírání souborů v dřívějších typech souborů aplikace Excel, postupujte takto:
  1. Ukončete aplikaci Excel 2003.
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security
  4. Po výběru příslušného podklíče uvedeného v kroku 3 přejděte v nabídce Upravit na podnabídku Nový a klepněte na příkaz Klíč.
  5. Zadejte název FileOpenBlock a pak stiskněte klávesu ENTER.
  6. Vyberte podklíč FileOpenBlock, v nabídce Úpravy přejděte na podnabídku Nový a potom klepněte na příkaz Hodnota DWORD.
  7. Zadejte název LotusandQuattroFiles a pak stiskněte klávesu ENTER.
  8. Klepněte pravým tlačítkem myši na položku LotusandQuattroFiles a potom klepněte na příkaz Změnit.
  9. Do pole Údaj hodnoty zadejte hodnotu 0 a klepněte na tlačítko OK.
  10. Kroky 6 až 9 opakujte pro položky registru LegacyBinaryFiles a LegacyDatabaseAndDatasourceFiles.
  11. Ukončete program Editor registru klepnutím na příkaz Konec v nabídce Soubor.
Chcete-li v aplikaci Excel 2003 povolit ukládání souborů v dřívějších typech souborů aplikace Excel, postupujte takto:
  1. Ukončete aplikaci Excel 2003.
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Excel\Security
  4. Po výběru příslušného podklíče uvedeného v kroku 3 přejděte v nabídce Upravit na podnabídku Nový a klepněte na příkaz Klíč.
  5. Zadejte název FileSaveBlock a pak stiskněte klávesu ENTER.
  6. Vyberte podklíč FileSaveBlock, v nabídce Úpravy přejděte na podnabídku Nový a potom klepněte na příkaz Hodnota DWORD.
  7. Zadejte název LotusandQuattroFiles a pak stiskněte klávesu ENTER.
  8. Klepněte pravým tlačítkem myši na položku LotusandQuattroFiles a potom klepněte na příkaz Změnit.
  9. Do pole Údaj hodnoty zadejte hodnotu 0 a klepněte na tlačítko OK.
  10. Kroky 6 až 9 opakujte pro položky registru LegacyBinaryFiles a LegacyDatabaseAndDatasourceFiles.
  11. Ukončete program Editor registru klepnutím na příkaz Konec v nabídce Soubor.
Aplikace PowerPoint
Chcete-li v aplikaci PowerPoint 2003 povolit otevírání souborů v dřívějších typech souborů aplikace PowerPoint, postupujte takto:
  1. Ukončete aplikaci PowerPoint 2003.
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\PowerPoint\Security
  4. Po výběru příslušného podklíče uvedeného v kroku 3 přejděte v nabídce Upravit na podnabídku Nový a klepněte na příkaz Klíč.
  5. Zadejte název FileOpenBlock a pak stiskněte klávesu ENTER.
  6. Vyberte podklíč FileOpenBlock, v nabídce Úpravy přejděte na podnabídku Nový a potom klepněte na příkaz Hodnota DWORD.
  7. Zadejte název FilesBeforePowerPoint97 a pak stiskněte klávesu ENTER.
  8. Klepněte pravým tlačítkem myši na položku FilesBeforePowerPoint97 a potom klepněte na příkaz Změnit.
  9. Do pole Údaj hodnoty zadejte hodnotu 0 a klepněte na tlačítko OK.
  10. Ukončete program Editor registru klepnutím na příkaz Konec v nabídce Soubor.
Chcete-li v aplikaci PowerPoint 2003 povolit ukládání souborů v dřívějších typech souborů aplikace PowerPoint, postupujte takto:
  1. Ukončete aplikaci PowerPoint 2003.
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\PowerPoint\Security
  4. Po výběru příslušného podklíče uvedeného v kroku 3 přejděte v nabídce Upravit na podnabídku Nový a klepněte na příkaz Klíč.
  5. Zadejte název FileSaveBlock a pak stiskněte klávesu ENTER.
  6. Vyberte podklíč FileSaveBlock, v nabídce Úpravy přejděte na podnabídku Nový a potom klepněte na příkaz Hodnota DWORD.
  7. Zadejte název FilesBeforePowerPoint97 a pak stiskněte klávesu ENTER.
  8. Klepněte pravým tlačítkem myši na položku FilesBeforePowerPoint97 a potom klepněte na příkaz Změnit.
  9. Do pole Údaj hodnoty zadejte hodnotu 0 a klepněte na tlačítko OK.
  10. Ukončete program Editor registru klepnutím na příkaz Konec v nabídce Soubor.
Aplikace Word
Chcete-li v aplikaci Word 2003 povolit otevírání souborů v dřívějších typech souborů aplikace Word, postupujte takto:
  1. Ukončete aplikaci Word 2003.
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Security
  4. Po výběru příslušného podklíče uvedeného v kroku 3 přejděte v nabídce Upravit na podnabídku Nový a klepněte na příkaz Klíč.
  5. Zadejte název FileOpenBlock a pak stiskněte klávesu ENTER.
  6. Vyberte podklíč FileOpenBlock, v nabídce Úpravy přejděte na podnabídku Nový a potom klepněte na příkaz Hodnota DWORD.
  7. Zadejte název FilesBeforeVersion a pak stiskněte klávesu ENTER.
  8. Klepněte pravým tlačítkem myši na položku FilesBeforeVersion a potom klepněte na příkaz Změnit.
  9. Do pole Údaj hodnoty zadejte hodnotu odpovídající některé z hodnot uvedených v a klepněte na tlačítko OK.

    Například výchozí hodnota této položky je nastavená na hodnotu Word 6.0 for Windows nebo na hodnotu 101. To znamená, že je blokováno otevření všech souborů aplikace Word s nižším číslem verze než aplikace Word 6.0 pro systém Windows (nikoli samotná verze 6.0). Výchozí číslo verze lze zvyšovat a snižovat. Verze uvedené v tabulce verzí souborů aplikace Word jsou seřazené vzestupně.

    Poznámka: Pokud nastavíte hodnotu této položky na hodnotu 0, bude možné otevřít všechny soubory dřívějších verzí. Namísto nastavení této položky na hodnotu 0 doporučujeme nastavit její hodnotu na některou z hodnot uvedených v tabulce verzí souborů aplikace Word, neboť kód pro analýzu používaný při otevírání dřívějších typů souborů je méně zabezpečený.
  10. Ukončete program Editor registru klepnutím na příkaz Konec v nabídce Soubor.
Tabulka verzí souborů aplikace Word
Zmenšit tuto tabulkuRozšířit tuto tabulku
VerzeHodnota registru
Word 1.x for Windows33
Word 4.x for Macintosh33
Word 1.2 for Windows Japan34
Word 1.2 for Windows Korea35
Word 5.x for Macintosh35
Word 1.2 for Windows Taiwan36
Word 2.x for Windows45
Word 2.x for Windows BiDi46
Word 2.x for Windows Japan46
Word 2.x for Windows Korea47
Word 2.x for Windows Taiwan48
Word 6.0 pro systém Windows101 (Toto je výchozí nastavení)
Word 6.0 for Macintosh104
Word 95 RTM (prodejní verze)104
Word 95 Beta105
Word 97 pro systém Windows193
Word 98 for Macintosh193
Word 2001 for Macintosh195
Word X for Macintosh195
Word 9 pro systém Windows217
Word 10 pro systém Windows257
Word 11 pro systém Windows268
Word 2004 for Macintosh268
Word 11 uložená aplikací Word 12274
Vypnout blokování všech souborů0
Aplikace Corel Draw
Chcete-li povolit otevírání souborů CDR, postupujte takto:
  1. Ukončete všechny aplikace sady Office 2003.
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Graphics Filters\Import
  4. Po výběru příslušného podklíče uvedeného v kroku 3 přejděte v nabídce Upravit na podnabídku Nový a klepněte na příkaz Klíč.
  5. Zadejte příkaz CDR a potom stiskněte klávesu ENTER.
  6. Vyberte podklíč CDR, v nabídce Úpravy přejděte na podnabídku Nový a potom klepněte na příkaz Hodnota DWORD.
  7. Zadejte název Enabled a pak stiskněte klávesu ENTER.
  8. Klepněte pravým tlačítkem myši na položku Enabled a klepněte na příkaz Změnit.
  9. Do pole Údaj hodnoty zadejte hodnotu 1 a klepněte na tlačítko OK.
  10. Ukončete program Editor registru klepnutím na příkaz Konec v nabídce Soubor.

Další informace

Další informace o blokovaných typech souborů naleznete v následujících článcích znalostní báze Microsoft Knowledge Base:
922847 Při pokusu o otevření typu souboru blokovaného nastavením zásad registru v aplikaci PowerPoint 2007 nebo PowerPoint 2003 se zobrazí chybová zpráva
922848 Při pokusu o otevření typu souboru blokovaného nastavením zásad registru v aplikaci Excel 2007 nebo Excel 2003 se zobrazí chybová zpráva
922849 Při pokusu o otevření či uložení typu souboru blokovaného nastavením zásad registru v aplikaci Word 2007 nebo Word 2003 se zobrazí chybová zpráva (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
922850 Při pokusu o otevření či uložení typu souboru blokovaného nastavením zásad registru v jedné z aplikací systému 2007 Office nebo sady Office 2003 se zobrazí chybová zpráva
Produkty jiných výrobců popisované v tomto článku vyrábějí společnosti, které jsou nezávislé na společnosti Microsoft. Společnost Microsoft neposkytuje žádnou záruku (implicitně předpokládanou ani jinou) týkající se výkonu a spolehlivosti těchto produktů.

Vlastnosti

ID článku: 938810 - Poslední aktualizace: 14. dubna 2008 - Revize: 5.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office 2003 Service Pack 3
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
Klíčová slova: 
kbtshoot kberrmsg kbexpertisebeginner kbprb KB938810

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com