文章编号: 938818 - 查看本文应用于的产品
展开全部 | 关闭全部

自动诊断和修复问题



注意 如果您想亲自解决该问题,请转到“我自己修复此问题”部分。
该信息是否有用?请向我们发送您的反馈

MATS 程序包修复的类似问题

2415237 无法在 Windows Vista 的 Windows 照片库中预览图片
930102 Windows XP 或 Windows Vista 的 Windows 照片库中的图像过渡问题


有关 MATS 程序包修复的其他问题的详细信息,请转到“MATS 程序包修复的其他问题”部分。

症状

在运行 Windows Vista 的计算机上的 Windows 照片库中启动幻灯片时,并未显示该幻灯片中的图片。

原因

在启动幻灯片时,Windows Vista 使用“图形”的 Windows 体验指数评级来确定是使用 DirectX 独占模式,还是使用 GDI+ 模式绘制图像。如果使用 DirectX 独占模式绘制图像,则始终使用逐行扫描模式。但是,显示器在当前分辨率下可能不支持逐行扫描模式或非交错扫描模式。在这种情况下,您将遇到“症状”部分中描述的问题。

注意 某些显示器仅在特定分辨率下支持隔行扫描模式。例如:许多等离子或液晶电视都使用 480i 或 1080i 模式。在上述示例中,字母“i”表示“隔行扫描”。

我自己修复此问题

重要说明 此部分、方法或任务包含有关如何修改注册表的步骤。但是,注册表修改不当可能会出现严重问题。因此,请一定严格按照下列步骤操作。为了获得进一步保护,请在修改注册表之前对其进行备份。这样就可以在出现问题时还原注册表。有关如何备份和还原注册表的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
322756 如何在 Windows 中备份和还原注册表


若要解决此问题,请使用下列方法之一:

方法 1
使用在选定分辨率下支持逐行扫描模式的显示器。

方法 2
编辑注册表,强制 Windows Vista 使用 GDI+ 模式。为此,请按照下列步骤操作:
  1. 单击“开始”,单击“运行”,键入 regedit,然后单击“确定”

    注意:如果系统提示您输入管理员密码或进行确认,请键入密码或单击“继续”
  2. 找到并单击下面的注册表子项:
    HKEY_CURRENT_USER\Software\Microsoft\Windows Photo Gallery\Slideshow
  3. 在“编辑”菜单上,指向“新建”,然后单击“DWORD 值”。
  4. 键入 WinSATSCore,然后按 Enter。
  5. 右键单击“WinSATSCore”,单击“修改”,在“数值数据”框中键入 0,然后单击“确定”
  6. 退出注册表编辑器。
该信息是否有用?请向我们发送您的反馈

MATS 程序包如何修复此问题

单击此处了解 MATS 程序包如何修复此问题

MATS 程序包修复的其他问题

930097 当 Windows Vista 中的一页无法容纳 Windows 照片库显示的 TIFF 图像时,计算机会变慢
2415238 在 Windows Vista 的 Windows 照片库中,图像打印预览中存在颜色问题
2009298 从 Windows Vista 升级到 Windows 7 之后,无法在 Windows Live 照片库中下载相册
944221 Windows Live 照片库冻结或无法启动
939395 Windows Vista 的 Windows 照片库中的图像及其背景变黄
2425702 显示图片的屏幕保护程序在 Windows 中停止工作

属性

文章编号: 938818 - 最后修改: 2012年2月29日 - 修订: 4.0
这篇文章中的信息适用于:
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Starter
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
关键字:?
kbexpertiseinter kbtshoot kbprb kbexpertisebeginner kbsurveynew kbmatsfixme KB938818
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com