Certain kinds of video content do not play after you apply a windowless skin such as the Revert skin to Windows Media Player

Article translations Article translations
Article ID: 938920 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

You apply a windowless skin such as the Revert skin to Microsoft Windows Media Player 11, to Windows Media Player 10, or to Windows Media Player 9. However, after you apply the skin, certain kinds of video content do not play.

CAUSE

This issue occurs if the video is encoded by using a YUV-based pixel format. In this scenario, Windows Media Player incorrectly processes the video content.

This issue does not occur if the video is encoded by using a RGB-based pixel format.

WORKAROUND

To work around this issue if you are running Windows Media Player on a Microsoft Windows XP-based computer, either turn off video acceleration or turn off the video mixing renderer. To do this, follow these steps:
  1. Start Windows Media Player.
  2. On the Tools menu, click Options, and then click the Performance tab.
  3. Do one of the following:
    • Turn off video acceleration. To do this, move the Video acceleration slider to the None setting.
    • Turn off the video mixing renderer. To do this, follow these steps:
      1. Click Advanced.
      2. Under Video Acceleration, click to clear the Use video mixing renderer check box.
      3. Click OK.
  4. Click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about pixel formats, click the following article number to view the article in the Microsoft Knowledge Base:
294880 General information about pixel formats

Properties

Article ID: 938920 - Last Review: November 26, 2007 - Revision: 1.2
APPLIES TO
  • Microsoft Windows Media Player 11
  • Microsoft Windows Media Player 10
  • Microsoft Windows Media Player 9 Series
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Starter
Keywords: 
kbtshoot kbbug kbprb kbpending kbexpertiseinter KB938920

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com