ID do artigo: 938927 - Última revisão: terça-feira, 19 de fevereiro de 2008 - Revisão: 2.2

Você perde as listas de canal de alguns canais e as gravações agendadas não podem ser executadas ao configurar o Windows Media Center para usar um sintonizador de TV digital no Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante Este artigo contém informações sobre como modificar o Registro. Certifique-se de fazer backup do Registro antes de modificá-lo. Certifique-se de que saiba como restaurá-lo caso ocorra algum problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do Registro do Microsoft Windows

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao configurar o Windows Media Center para usar um sintonizador de TV digital no Windows Vista, você pode perder as listas de canal do Guia de programas eletrônicos (EPG) de alguns canais. Você também pode perder as listas de canal do EPG dos subcanais desses canais. Além disso, as gravações agendadas não podem ser executadas.

Causa

Esse problema pode ocorrer se o transmissor da televisão alterar as informações sobre os canais. Nessa situação, o recurso Verificação oportunista atualiza as informações do canal de acordo com os novos detalhes do canal. Por exemplo, o recurso Verificação oportunista atualiza as informações do canal quando o transmissor atualiza os títulos dos canais. Isso pode fazer com que as informações do EPG dos canais afetados sejam perdidas.

Resolução

Para resolver esse problema, aplique o seguinte hotfix. Em seguida, modifique o Registro para desabilitar o recurso Verificação oportunista. Para obter informações sobre como fazer isso, consulte a seção "Informações sobre o Registro".

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Por isso, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request (http://go.microsoft.com/?linkid=6294451)
Observação Se outros problemas ocorrerem ou se uma solução de problema for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Pré-requisitos

Não há pré-requisitos.

Requisitos de reinicialização

É necessário reiniciar o serviço Receptor do Media Center após a aplicação desse hotfix. Para fazer isso, reinicie o computador. Ou, você pode usar o Console de gerenciamento Microsoft (MMC) para reiniciar o serviço. Para obter informações sobre como fazer isso, consulte a seção "Mais informações".

Informações de substituição do hotfix

Este hotfix não substitui nenhum outro.

Informações do Registro

Aviso O uso incorreto do Editor do Registro, ou outro método, pode causar sérios problemas. Estes problemas talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor de Registro possam ser solucionados. A modificação do Registro é de sua responsabilidade.

Após a aplicação desse hotfix, desabilite o recurso Verificação oportunista. Para fazer isto, execute as seguintes etapas:
  1. Clique em Iniciar, digite regedit na caixa Iniciar pesquisa e pressione ENTER.
  2. Localize e clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Media Center\Service\GLID
  3. No menu Editar, aponte para Novo e clique em Valor DWORD.
  4. Digite DisableActualStreamOpportunisticScanning para nomear a nova entrada e pressione ENTER.
  5. Clique com o botão direito do mouse em DisableActualStreamOpportunisticScanning e clique em Modificar.
  6. Na caixa Dados do valor, digite 1 e clique em OK.
  7. Feche o Editor do Registro.
Observação Se as listas de canal do EPG dos canais já foram perdidas, exclua os canais e verifique novamente os canais após a aplicação do hotfix.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Versões de 32 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Update.mumNão aplicável1.76314-Jun-200713:04Não aplicável
X86_430b406b905bf3a840a13cd31fa40ca3_31bf3856ad364e35_6.0.6000.20619_none_224b88a2661fd044.manifestNão aplicável70014-Jun-200713:04Não aplicável
X86_microsoft-windows-ehome-ehglid_31bf3856ad364e35_6.0.6000.20619_none_2ddd696686192028.manifestNão aplicável40.00914-Jun-200713:05Não aplicável
Ehglid.dll6.0.6000.20619372.73614-Jun-200702:16x86
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Amd64_0fb9918e42dc235c33a9815bd9e239f2_31bf3856ad364e35_6.0.6000.20619_none_e2173f4512059463.manifestNão aplicável70414-Jun-200713:04Não aplicável
Amd64_microsoft-windows-ehome-ehglid_31bf3856ad364e35_6.0.6000.20619_none_89fc04ea3e76915e.manifestNão aplicável40.02914-Jun-200713:12Não aplicável
Update.mumNão aplicável1.77314-Jun-200713:04Não aplicável
Ehglid.dll6.0.6000.20619465.92014-Jun-200703:21x64

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para reabilitar o recurso Verificação oportunista, defina o valor da entrada do Registro DisableActualStreamOpportunisticScanning como 0. Ou, exclua a entrada do Registro.

Para reiniciar o serviço Receptor do Media Center, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar, digite services.msc e clique em OK.
  2. Clique com o botão direito do mouse em Serviço Receptor do Media Center e clique em Reiniciar.
Para obter mais informações sobre a terminologia padrão usada para descrever atualizações de software da Microsoft, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palavras-chave: 
kbvistasp1fix kbexpertisebeginner kbfix kbpubtypekc kbqfe kbhotfixserver KB938927