Error message when you start a Windows XP Embedded-based computer that is running on AC power or that has a fully charged battery: "Critical Battery" or "Low Battery"

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Article ID: 938961 - View products that this article applies to.
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SYMPTOMS

When you start a portable computer that is running Microsoft Windows XP Embedded with Service Pack 2 (SP2), you may receive an error message that resembles one of the following.

Error message 1

Critical Battery

You should change your battery or switch to outlet power immediately to keep from losing your work.

Error message 2

Low Battery

You should change your battery or switch to outlet power immediately to keep from losing your work.
You receive the message even though the battery is fully charged or the system is running on AC power.

CAUSE

This problem may occur on a system that uses a high-speed flash disk to speed up the startup process. This problem occurs because the Windows XP composite battery driver (Compbatt.sys) does not correctly recognize the battery status. This problem occurs when the system starts faster than the composite battery driver expects.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Compbatt.sys5.1.2600.315810,24015-Jun-200710:34x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 938961 - Last Review: November 27, 2007 - Revision: 2.2
APPLIES TO
  • Microsoft Windows XP Embedded Service Pack 2
Keywords: 
kbautohotfix kbbug kbfix kberrmsg kbexpertiseadvanced kbqfe kbhotfixserver KB938961

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