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Article ID: 938988 - Last Review: August 15, 2007 - Revision: 2.1

You may be unable to delete a log file on a client computer in System Center Operations Manager 2007

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SYMPTOMS

In Microsoft System Center Operations Manager 2007, you may be unable to delete a log file on a client computer when you use the Generic Text Log data source to monitor the computer. Therefore, users or applications may receive error messages.

CAUSE

This problem occurs when the Operations Manager agent is monitoring the log file. The data source that parses the log file keeps an open reference to the file. This open reference prevents the file from being deleted.

WORKAROUND

To work around this problem, stop the health service on the computer that you are monitoring. When you stop the health service, monitoring stops. You can restart the health service after you delete the file.

To stop the health service, follow these steps on the computer that you are monitoring:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In the details pane, right-click OpsMgr Health Service, and then click Stop.
After you delete the file, follow these steps to restart the health service:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In the details pane, right-click OpsMgr Health Service, and then click Start.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft System Center Operations Manager 2007
  • Microsoft System Center Essentials 2007
Keywords: 
kbprb kbtshoot kbexpertiseadvanced KB938988

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