Help and Support
 

powered byLive Search

You cannot deploy an agent by using the Discovery and Installation Wizard in System Center Operations Manager 2007

Article ID:938993
Last Review:July 25, 2007
Revision:1.0

SYMPTOMS

You cannot deploy an agent by using the Discovery and Installation Wizard in Microsoft System Center Operations Manager 2007. When this problem occurs, the following entry is logged in the Agent_NameAgentInstall.log file:
CanRegisterMU: get_Services() failed. Error Code: 0x80070422
Note By default, the log file is located in the "C:\Program Files\System Center Operations Manager 2007\AgentManagement\AgentLogs\" folder.

Back to the top

CAUSE

This problem may occur if the Automatic Updates service is disabled on the computer where you try to deploy the agent.

Back to the top

RESOLUTION

To resolve this problem, enable the Automatic Updates service on the destination computer. You can disable the service after you deploy the agent. To enable the Automatic Updates service, follow these steps:
1. Click Start, click Run, type services.msc, and then click OK.
2.Right-click Automatic Updates in the list of services, and then click Properties.
3. On the General tab, click Manual in the Startup type box.
4. Under Service status, click Start, and then click OK.
To disable the Automatic Updates service, follow these steps:
1. Click Start, click Run, type services.msc, and then click OK.
2.Right-click Automatic Updates in the list of services, and then click Properties.
3.On the General tab, click Disabled in the Startup type box, and then click OK.
Or, manually install the agent. For information about how to do this, view the "How to Deploy the Operations Manager 2007 Agent Using MOMAgent.msi from the Command Line" topic in the Operations Manager 2007 Help file.

Back to the top


APPLIES TO
Microsoft System Center Essentials 2007
Microsoft System Center Operations Manager 2007

Back to the top

Keywords: 
kbprb kbtshoot kbexpertiseadvanced KB938993

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.