You receive a "STOP 0x000000D1" error after you create a network bridge on a computer that is running Windows XP

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Article ID: 939010 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You install two network adapters on a computer that is running Microsoft Windows XP.
  • You create a network bridge that uses both of the network adapters.
  • You install network driver interface specification (NDIS) intermediate drivers on the computer.
In this scenario, you may receive a Stop error message that resembles the following:
STOP 0x000000D1 (parameter1, parameter2, parameter3, parameter4)
DRIVER_IRQL_NOT_LESS_OR_EQUAL

CAUSE

This problem occurs because of a problem in the Bridge.sys driver. The Bridge.sys driver stores its forwarding information in the ProtocolReserved member of the NDIS_PACKET structure. If ProtocolReserved was last used by another process at the time that the Bridge.sys driver accesses ProtocolReserved, this Stop error may occur.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed.
322389 How to obtain the latest Windows XP service pack

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Bridge.sys5.1.2600.315871,55215-Jun-200710:19x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the NDIS_PACKET structure, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms797623.aspx
For more information about NDIS intermediate drivers, visit the following Microsoft Web sites:
http://msdn2.microsoft.com/en-us/library/aa938138.aspx

http://msdn2.microsoft.com/en-us/library/aa938140.aspx

Properties

Article ID: 939010 - Last Review: August 29, 2007 - Revision: 2.1
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertisebeginner kbhotfixserver kbqfe KB939010

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