Help and Support

An update to prevent a Background Intelligent Transfer Service (BITS) crash on a Windows Vista-based computer

Article ID:939159
Last Review:August 28, 2007
Revision:2.2
Note If you are experiencing the symptoms that are described this article, see the following Microsoft Knowledge Base article to resolve these symptoms:
940520 (http://support.microsoft.com/kb/940520/) The host process for Windows Services stops working after you download Microsoft updates on a computer that is running Windows Vista
The update that is described in this article prevents the symptoms that are described in this article. However, you cannot use this update to recover from symptoms that you are experiencing.
On This Page

SYMPTOMS

When updates are being downloaded from Windows Update on a Windows Vista-based computer, you may experience the following symptoms:
A dialog box appears that indicates that the host process for Windows Services has stopped working.
After you restart the computer, you receive the following error message in a Windows Update dialog box:
Some Updates were not installed
Failed: xx updates
Error(s) Found:
Code 800706BA
An event that resembles the following is logged in the Application log:

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: date
Time: time
Computer: computer name
User: N/A
Description: Faulting application svchost.exe_BITS, version 6.0.6000.16386, time stamp 0x4549adc4, faulting module qmgr.dll, version 7.0.6000.16386, time stamp 0x4549bd9f, exception code 0xc0000005

Back to the top

CAUSE

This problem occurs because the Background Intelligent Transfer Service (BITS) state files are corrupted. This problem stops the host process for Windows Services. This behavior prevents you from using BITS to transfer files.

Back to the top

RESOLUTION

An update is available to prevent a BITS crash on a Windows Vista-based computer.

Back to the top

Update information

The following files are available for download from the Microsoft Download Center:

Windows Vista, 32-bit versions

DownloadDownload the 939159 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=D8F9D963-5D01-411F-BBA2-B57FE0D4204C&displaylang=en)

Windows Vista, 64-bit versions

DownloadDownload the 939159 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=2ED66BB5-8496-4B45-8725-D58629950E69&displaylang=en)

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you install this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Update-bf.mumNot applicable1,74626-Jul-200718:43Not applicable
X86_95f9025e940221ff71b90bbcb12b5997_31bf3856ad364e35_6.0.6000.20647_none_41ed808d1593c68c.manifestNot applicable69926-Jul-200718:43Not applicable
X86_f1479b2110873990b2b9a281e8db3e25_31bf3856ad364e35_6.0.6000.16531_none_d1c8c5ebd7c90b15.manifestNot applicable69926-Jul-200718:43Not applicable
X86_microsoft-windows-bits-client_31bf3856ad364e35_6.0.6000.16531_none_218b14e6fc62ea9e.manifestNot applicable122,08126-Jul-200718:43Not applicable
X86_microsoft-windows-bits-client_31bf3856ad364e35_6.0.6000.20647_none_220fe38215833e63.manifestNot applicable122,08126-Jul-200718:43Not applicable
Qmgr.dll7.0.6000.16531750,08025-Jul-200703:21x86
Qmgr.mofNot applicable2,30207-Jan-200705:31Not applicable
Qmgr.dll7.0.6000.20647750,08025-Jul-200703:14x86
Qmgr.mofNot applicable2,30207-Jan-200705:31Not applicable
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Amd64_268de7d1b3950bd78d4ec43e395c8e0d_31bf3856ad364e35_6.0.6000.20647_none_2fcba980449d77e2.manifestNot applicable70326-Jul-200718:43Not applicable
Amd64_cba080dad87678f379b404d4c9060151_31bf3856ad364e35_6.0.6000.16531_none_7643f907f44a851e.manifestNot applicable70326-Jul-200718:43Not applicable
Amd64_microsoft-windows-bits-client_31bf3856ad364e35_6.0.6000.16531_none_7da9b06ab4c05bd4.manifestNot applicable122,13726-Jul-200718:47Not applicable
Amd64_microsoft-windows-bits-client_31bf3856ad364e35_6.0.6000.20647_none_7e2e7f05cde0af99.manifestNot applicable122,13726-Jul-200718:47Not applicable
Update-bf.mumNot applicable1,75626-Jul-200718:43Not applicable
Qmgr.dll7.0.6000.165311,039,87225-Jul-200704:29x64
Qmgr.mofNot applicable2,30207-Jan-200705:39Not applicable
Qmgr.dll7.0.6000.206471,039,36025-Jul-200704:16x64
Qmgr.mofNot applicable2,30207-Jan-200705:32Not applicable

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

Back to the top


APPLIES TO
Windows Vista Business
Windows Vista Enterprise
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Starter
Windows Vista Ultimate
Windows Vista Business 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition

Back to the top

Keywords: 
kbvistasp1fix atdownload kbexpertiseinter kbpubtypekc kbqfe KB939159

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.