Het verwijderen van bepaalde beveiligingsupdates voor .NET Framework 1.1 of voor .NET Framework 1.0 betekent dat de bestandsversie van het laatste servicepack wordt hersteld

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 939160 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Symptomen

Neem bijvoorbeeld het volgende scenario. U hebt een computer waarop Microsoft .NET Framework 1.1 of Microsoft .NET Framework 1.0 is geïnstalleerd. Vervolgens verwijdert u een van de beveiligingsupdates die worden beschreven in de volgende Microsoft Knowledge-artikelen:
  • 928366 Beschrijving van de beveiligingsupdate voor NET Framework 1.1 voor Windows XP en Windows 2000 10.07.07
  • 929729 Beschrijving van de beveiligingsupdate voor .NET Framework 1,1 voor Windows Vista 10.07.07
  • 928367 Beschrijving van de beveiligingsupdate voor .NET Framework 1.0 voor Windows Vista, Windows Server 2003, Windows XP en Windows 2000 10.07.07
In dit scenario wordt de bestandsversie van .NET Framework hersteld die is geïnstalleerd met het laatste servicepack. Bovendien kunt u alleen een eerder geïnstalleerde update of een nieuwere update opnieuw installeren. U kunt een oudere update niet installeren.

Oorzaak

Dit probleem treedt op omdat updates voor .NET Framework 1.1 en voor .NET Framework 1.0 in eerste instantie zijn ontworpen voor gebruik met Windows Installer 2.0. Updates voor .NET Framework 1.1 en voor .NET Framework 1.0. zijn niet compatibel met Windows Installer 3.0.

Opmerking Windows Installer 3.0 wordt niet ondersteund op oudere platforms zoals Microsoft Windows Millennium Edition, Microsoft Windows 98 en Microsoft Windows 95.

Windows Installer 2.0 heeft een beperking. Het programma heeft geen ingebouwde ondersteuning voor het verwijderen van een update. Om deze beperking weg te nemen, is er een aangepaste verwijderfunctie ingebouwd in de updates voor .NET Framework 1.1 en de updates voor .NET Framework 1.0.

Deze functie werkt als volgt. Naast het payload-bestand (MSP) bevat de update een zogenaamde ?anti-patch?. Als de juiste verwijderopdracht wordt doorgegeven aan het uitvoerbare wrapper-programma van de update, installeert de wrapper de anti-patch. De anti-patch is eigenlijk een tweede update. De tweede update bevat de laatst bekende juiste versie van de bestanden in het payload-bestand (MSP). Deze versie is de laatste basisversie. Deze versie is meestal afkomstig uit het meest recente servicepack (indien beschikbaar). Het verwijderen van een update voor .NET Framework 1.1 of voor .NET Framework 1.0 betekent dus dat niet altijd de bestandsversie wordt hersteld die is geïnstalleerd door de eerdere versie. Het is ook mogelijk dat de bestandsversie van .NET Framework wordt hersteld die is geïnstalleerd met het laatste servicepack.

Neem bijvoorbeeld het volgende scenario. U hebt twee updates voor .NET Framework 1.0 Service Pack 3. De eerste update is update KB886906. Deze update heeft bestandsversie 1.0.3705.6021. De tweede update is update KB928367. Deze update heeft bestandsversie 1.0.3705.6060.

In de volgende tabel kunt u zien wat er in dit scenario gebeurt wanneer u de updates installeert en vervolgens verwijdert.
Deze tabel samenvouwenDeze tabel uitklappen
StapActieHuidige bestandsversieNieuwe bestandsversie
1U installeert .NET Framework 1.0 Service Pack 3Niet van toepassing1.0.3705.6018
2U installeert update KB886906. Dit is de eerste (oudere) update.1.0.3705.60181.0.3705.6021
3U installeert update KB928367. Dit is de tweede (nieuwere) update.1.0.3705.60211.0.3705.6060
4U verwijdert update KB928367. Dit is de tweede (nieuwere) update.1.0.3705.60601.0.3705.6018
Dit scenario laat zien dat na het verwijderen van de tweede update de bestandsversie van .NET Framework 1.0 niet de versie van de eerste update is, zoals was te verwachten. De versie van .NET Framework 1.0 die wordt hersteld is de basisversie. (De basisversie is de bestandsversie van .NET Framework 1.0 Service Pack 3.)

Oplossing

Microsoft heeft een speciaal hulpprogramma gepubliceerd om dit probleem te verhelpen. Gebruik Uninstall Cleanup Tool als u een van de beveiligingsupdates verwijdert die worden genoemd in de sectie ?Symptomen?.

Als u dit hulpprogramma wilt downloaden, gaat u naar het Microsoft Downloadcentrum: 
http://www.microsoft.com/downloads/nl-nl/details.aspx?familyid=7a4efc33-0343-4ee4-b0c4-97bd16967a09&displaylang=nl
Nadat u het hulpprogramma hebt uitgevoerd, is de laatst bekende juiste configuratie van de computer hersteld. Vervolgens kunt u de eerdere beveiligingsupdate opnieuw installeren.

In de volgende tabel kunt u zien wat er gebeurt wanneer u de updates installeert en vervolgens verwijdert. In de tabel wordt ook aangegeven hoe Uninstall Cleanup Tool dit probleem oplost.
Deze tabel samenvouwenDeze tabel uitklappen
StapActieHuidige bestandsversieNieuwe bestandsversie
1U installeert .NET Framework 1.0 Service Pack 3Niet van toepassing1.0.3705.6018
2U installeert update KB886906. Dit is de eerste (oudere) update. 1.0.3705.60181.0.3705.6021
3U installeert update KB928367. Dit is de tweede (nieuwere) update.1.0.3705.60211.0.3705.6060
4U verwijdert update KB928367. Dit is de tweede (nieuwere) update.1.0.3705.60601.0.3705.6018
5U downloadt Uninstall Cleanup Tool en voert het programma uit.1.0.3705.60601.0.3705.6018
6U installeert update KB886906 opnieuw. Dit is de eerste (oudere) update.1.0.3705.60181.0.3705.6021
In de volgende tabel wordt de update beschreven die u opnieuw moet installeren als u een van de beveiligingsupdates verwijdert die worden genoemd in de sectie ?Symptomen?.
Deze tabel samenvouwenDeze tabel uitklappen
Versie van .NET FrameworkVerwijderde updateNieuw te installeren update
.NET Framework 1.1 Service Pack 1
928366 Beschrijving van de beveiligingsupdate voor NET Framework 1.1 voor Windows XP en Windows 2000 10.07.07
886903 Beveiligingsprobleem met valideren van ASP.NET-pad in Microsoft .NET Framework 1.1 Service Pack 1
.NET Framework 1.1 Service Pack 1
929729 Beschrijving van de beveiligingsupdate voor .NET Framework 1,1 voor Windows Vista 10.07.07
886903 Beveiligingsprobleem met valideren van ASP.NET-pad in Microsoft .NET Framework 1.1 Service Pack 1
.NET Framework 1.0 Service Pack 3
928367 Beschrijving van de beveiligingsupdate voor .NET Framework 1.0 voor Windows Vista, Windows Server 2003, Windows XP en Windows 2000 10.07.07
886906 Beveiligingsprobleem met valideren van ASP.NET-pad in Microsoft .NET Framework 1,0 Service Pack 3
Het hier beschreven hulpprogramma Uninstall Cleanup Tool moet u uitvoeren nadat u een van de nieuwe updates hebt verwijderd en voordat u de eerdere update installeert. U moet deze procedure dus elke keer uitvoeren nadat u de beveiligingsupdate hebt verwijderd. Dus telkens als u de beveiligingsupdate verwijdert, voert u het hier beschreven hulpprogramma Uninstall Cleanup Tool uit en installeert u vervolgens de eerdere update.

Opmerking Wanneer u het hulpprogramma uitvoert, wordt het programma niet op de computer geïnstalleerd. Het programma wordt na voltooiing uit het geheugen verwijderd.

Meer informatie

Voor meer informatie over problemen die optreden wanneer u na het installeren van verschillende updates een bepaalde update verwijdert, klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
938244 Het verwijderen van een update voor .NET Framework 1.0 of voor .NET Framework 1.1 betekent dat de bestandsversie van het laatste servicepack wordt hersteld
Opmerking Dit is een artikel voor snelle publicatie dat rechtstreeks is gemaakt vanuit de ondersteuningsorganisatie van Microsoft. De informatie in dit artikel wordt in de huidige vorm aangeboden in reactie op nieuw geconstateerde problemen. Aangezien artikelen van dit type zeer snel moeten worden gepubliceerd, kan de inhoud typografische fouten bevatten en kan de inhoud zonder voorafgaande kennisgeving worden gewijzigd. Raadpleeg de Gebruiksrechtovereenkomst voor overige aandachtspunten.

Eigenschappen

Artikel ID: 939160 - Laatste beoordeling: vrijdag 14 oktober 2011 - Wijziging: 1.0
De informatie in dit artikel is van toepassing op:
  • Microsoft .NET Framework 1.1 Service Pack 1 op de volgende platformen
    • Windows Vista Home Premium
    • Windows Vista Ultimate
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Starter
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows® 2000 Server
    • Microsoft Windows 2000 Advanced Server
  • Microsoft .NET Framework 1.0 Service Pack 3 op de volgende platformen
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Ultimate
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Starter
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows® 2000 Server
    • Microsoft Windows 2000 Advanced Server
Trefwoorden: 
kbupdateissue kbuninstall kbinstallation kbupdate kbhowto kbtshoot kbexpertisebeginner kbprb KB939160

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com