ID do artigo: 939209 - Última revisão: quarta-feira, 18 de junho de 2008 - Revisão: 1.2

CORREÇÃO: Ao usar um aplicativo para reproduzir o conteúdo de vídeo protegido por DRM no Windows XP, o aplicativo pode falhar

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Você está executando o conteúdo de vídeo protegido por DRM (gerenciamento de direitos digitais) no Windows XP.
  • O conteúdo foi protegido usando o SDK (Software Development Kit) do Microsoft Windows Media Rights Manager.
  • Você possui o DXVA (DirectX video acceleration) ativado.
  • O aplicativo usado para reproduzir o conteúdo usa o DirectX para reprodução de vídeo.
Nesta situação, pode ocorrer uma falha no aplicativo.

Observação Este problema não ocorre se usar um dos seguintes aplicativos para reproduzir o conteúdo protegido por DRM.
  • Microsoft Windows Media Player
  • Um aplicativo que foi desenvolvido usando o SDK do Windows Media Format

Causa

Este problema ocorre devido à forma com que o filtro QASF do Windows Media DirectShow manipula o conteúdo entrelaçado e protegido.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix estiver disponível para download, existirá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não é exibida, envie uma solicitação ao Serviço de Atendimento ao Cliente da Microsoft para obter o hotfix.

Observação Caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso seu idioma não seja exibido, um hotfix não está disponível para esse idioma.

Informações sobre o download

Os seguintes arquivos estão disponíveis para download no Centro de Download da Microsoft:

Windows XP, versões com base em x86 (todos os idiomas)

Recolher esta imagemExpandir esta imagem
Download
Baixe o pacote WindowsMedia11-KB939209-x86-INTL.exe agora. (http://download.microsoft.com/download/9/2/3/92369494-33bc-4193-b39a-2c456df2878c/windowsmedia11-kb939209-x86-intl.exe)

Windows XP, versões com base em x64 (todos os idiomas)

Recolher esta imagemExpandir esta imagem
Download
Baixe o pacote WindowsMedia11-KB939209-x64-INTL.exe agora. (http://download.microsoft.com/download/9/2/3/92369494-33bc-4193-b39a-2c456df2878c/windowsmedia11-kb939209-x64-intl.exe)

Observação Este hotfix não possui uma versão com base em x64 para o Windows XP. O pacote WindowsMedia11-KB939209-x64-INTL.exe aplica a versão de 32 bits deste hotfix na versão do Windows XP com base em x64.

Para obter mais informações sobre como baixar os arquivos de suporte da Microsoft, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
119591  (http://support.microsoft.com/kb/119591/[PT]/ ) Como obter os arquivos de suporte da Microsoft nos serviços online
A Microsoft examinou este arquivo em busca de vírus. A Microsoft usou o mais recente software de detecção de vírus disponível na data em que o arquivo foi publicado. O arquivo está armazenado em servidores de segurança avançada que ajudam a evitar qualquer alteração não autorizada no arquivo.

A versão global do hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Qasf.dll11.0.5721.5233211.45620-jun-200723:54x86

Situação

A Microsoft confirmou que este é um bug que ocorre nos produtos Microsoft que estão listados na seção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Palavras-chave: 
kbautohotfix kbbug kbhotfixserver kbqfe kbfix KB939209