Сообщение об ошибке при попытке изменить или удалить сопоставление альтернативного доступа в службах Windows SharePoint Services 3.0: «конфликт обновления, и это действие необходимо выполнена повторная попытка»

Переводы статьи Переводы статьи
Код статьи: 939308 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

Выполнить восстановление системы в Microsoft Windows SharePoint Services 3.0 в котором восстанавливается база данных конфигурации. Затем попробуйте изменить или удалить сопоставления альтернативного доступа.

При этом появляется сообщение об ошибке, похожее на следующее сообщение об ошибке:
Конфликт обновления, и это действие необходимо выполнена повторная попытка. Объект SPAlternateUrlCollection имя = предок WEBAPPLICATION = SPFarm имя = SharePoint_Config обновляется путем Имя_домена\UserName1, на компьютере процесс w3wp Имя_сервера. Дополнительные сведения о конфликте в журнале трассировки.
При просмотре файлов журнала единого входа службы (ULS) отображается запись следующего вида:
Дата Время Службы 0x1988 Windows SharePoint W3wp.exe (0x1620) топологии средний 8xqz, обновление SPPersistedObject SPAlternateUrlCollection имя = WEBAPPLICATION родительского = имя SPFarm = SharePoint_Config. Версия: убедитесь, что 16449: 0, хеш-код: 30474330, код: 609b3309-241a-4193-8289-1bba6a70be50, стек: во Microsoft.SharePoint.Administration.SPPersistedObject.Update() в Microsoft.SharePoint.Administration.SPAlternateUrlCollection.Update() в Microsoft.SharePoint.ApplicationPages.IncomingUrlPage.BtnSave_Click (объекта отправителя, EventArgs e) в System.Web.UI.WebControls.Button.OnClick (EventArgs e) в System.Web.UI.WebControls.Button.RaisePostBackEvent (строка eventArgument) в System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent (строка eventArgument) в System.Web.UI.Page.RaisePostBackEvent (IPostBackEventHandler sourceControl, eventArgument строка) в System.Web.UI.Page.RaisePostBackEvent (NameValueCollection postData) в System.Web.UI.Page.ProcessRequestMain (логическое includeStagesBeforeAsyncPoint, логическое includeStagesAfterAsyncPoint) в System.Web.UI.Page.ProcessRequest (логическое includeStagesBeforeAsyncPoint, логическое includeStagesAfterAsyncPoint) в System.Web.UI.Page.ProcessRequest() в System.Web.UI.Page.ProcessRequestWithNoAssert (контекст HttpContext) в System.Web.UI.Page.ProcessRequest (контекст HttpContext) в ASP._admin_editincomingurl_aspx.ProcessRequest (контекст HttpContext) в System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() в System.Web.HttpApplication.ExecuteStep (IExecutionStep шаг, логическое значение & completedSynchronously) в System.Web.HttpApplication.ResumeSteps (ошибка) в System.Web.HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest (контекст HttpContext, AsyncCallback cb, объект extraData) в System.Web.HttpRuntime.ProcessRequestInternal (HttpWorkerRequest wr) в System.Web.HttpRuntime.ProcessRequestNoDemand (HttpWorkerRequest wr) в System.Web.Hosting.ISAPIRuntime.ProcessRequest (IntPtr ecb, Int32 iWRType) 06-06-2007 w3wp.exe 14:36:31.51 (0x1620) 0x1988 топологии служб Windows SharePoint высокой UpdatedConcurrencyException 75bd: SPAlternateUrlCollection имя объекта = предок WEBAPPLICATION = SPFarm имя = SharePoint_Config был обновлен другим пользователем. Определите, если эти изменения будут конфликтовать, устранить любые различия и заново второе изменение. Эта ошибка также может означать программная ошибка, вызванная получением двух копий одного объекта в одном потоке. Обновление сведений о предыдущих: пользователь: Имя_домена\UserName1 Процесс: w3wp компьютера:Имя_сервера Время:Дата Время Текущее обновление информации: пользователь: Имя_домена\UserName2 Процесс: w3wp компьютера:Имя_сервераДата Время Службы 0x1988 Windows SharePoint W3wp.exe (0x1620) топологии высокой ConcurrencyException 8xqy: старые версии: 16449 новая версия: 0

Причина

Эта проблема возникает, если содержимое кэш-памяти на серверах переднего плана новее, чем содержимое базы данных конфигурации. После выполнения восстановления системы может потребоваться вручную очистить кэш файловой системы на локальном сервере.

Решение

Для решения этой проблемы, очистите кэш на всех серверах в ферме серверов, на котором выполняется служба Windows SharePoint Services таймера. Чтобы сделать это, выполните следующие действия.
  1. Остановите службу таймера. Чтобы сделать это, выполните следующие действия.
    1. Нажмите кнопку Начало, выберите пункт Администрирование, а затем нажмите кнопку Службы.
    2. Щелкните правой кнопкой мыши Windows SharePoint Services таймера, а затем нажмите кнопку Остановить.
    3. Закройте консоль службы.
  2. На компьютере под управлением Microsoft Office SharePoint Server 2007, на котором размещается веб-узел центра администрирования нажмите кнопку Начало, нажмите кнопку Запустить, тип Проводник, а затем нажмите клавишу ВВОД.
  3. В проводнике Windows найдите и дважды щелкните следующую папку:
    Диск: \Documents and Settings\All Users\Application Data\Microsoft\SharePoint\Config\ИДЕНТИФИКАТОР GUID
    Заметки
    • В Диск Местозаполнитель указывает букву диска, на котором установлена система Windows. По умолчанию Windows установлена на диске C.
    • В ИДЕНТИФИКАТОР GUID Местозаполнитель папка GUID.
    • Папка данных приложений могут быть скрыты. Чтобы просмотреть скрытые папки, выполните следующие действия.
      1. На Сервис меню, нажмите кнопку Свойства папки.
      2. Нажмите кнопку Представление Вкладка.
      3. В Дополнительные параметры Выберите Показывать скрытые файлы и папки Из списка Скрытые файлы и папки, а затем нажмите кнопку ОК.
    • В Windows Server 2008 — это кэш конфигурации находится в:
      Диск: \ProgramData\Microsoft\SharePoint\Config\ИДЕНТИФИКАТОР GUID
  4. Создайте резервную копию файла Cache.ini.
  5. Удалите все файлы конфигурации XML в папке GUID. Сделать это таким образом, чтобы убедиться, что идентификатор GUID папки заменяется новым XML-файлов конфигурации при перестроении кэша.

    Примечание При очистке кэша конфигурации в папке GUID убедитесь, что не удаляйте папку и файл Cache.ini, который находится в папке GUID.
  6. Дважды щелкните файл Cache.ini.
  7. На Редактирование меню, нажмите кнопку Выбрать все.
  8. На Редактирование меню, нажмите кнопку Удалить.
  9. Тип 1, а затем нажмите кнопку Сохранить В меню Файл меню.
  10. На Файл меню, нажмите кнопку Выход.
  11. Запустите службу таймера. Чтобы сделать это, выполните следующие действия.
    1. Нажмите кнопку Начало, выберите пункт Администрирование, а затем нажмите кнопку Службы.
    2. Щелкните правой кнопкой мыши Windows SharePoint Services таймера, а затем нажмите кнопку Начало.
    3. Закройте консоль службы.
    Примечание Кэш создается заново после выполнения этой процедуры. Убедитесь, что выполнить эту процедуру на всех серверах в ферме серверов.
  12. Убедитесь, что файл Cache.ini в папке GUID теперь содержит предыдущее значение. Например убедитесь, что значение файла Cache.ini не 1.
  13. Нажмите кнопку Начало, выберите пункт Программы, выберите пункт Администрирование, а затем нажмите кнопку Центр администрирования SharePoint 3.0.
  14. Нажмите кнопку Операции вкладки, а затем нажмите кнопку Состояние задания таймера Из списка Глобальные настройки.
  15. В списке заданий таймера, убедитесь, что состояние Обновление конфигурации запись Выполнено успешно.
  16. На Файл меню, нажмите кнопку Закрыть.

Свойства

Код статьи: 939308 - Последний отзыв: 22 сентября 2011 г. - Revision: 5.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows SharePoint Services 3.0
Ключевые слова: 
kberrmsg kbexpertiseinter kbprb kbtshoot kbmt KB939308 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:939308

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com