Chybové hlásenie pri pokuse o úpravu alebo odstráňte alternatívne priradenie prístupu v aplikácii Windows SharePoint Services 3.0: "nastal konflikt aktualizácie, a musíte skúste túto akciu"

Preklady článku Preklady článku
ID článku: 939308 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Príznaky

Vykonáte obnovenie systému Microsoft Windows SharePoint Services 3.0 v ktorom konfiguračnej databázy je obnovená. Potom si skúste upravte alebo odstráňte alternatívne priradenie prístupu.

Keď to urobíte, dostanete chybové hlásenie, podobné nasledovné chybové hlásenie:
Nastal konflikt aktualizácie, a musíte skúste túto akciu. Objekt SPAlternateUrlCollection meno = WEBAPPLICATION rodič = SPFarm názov = SharePoint_Config je aktualizovaný podľa DomainName\UserName1, v w3wp procese, na stroji Názov_servera. Pre viac informácií o konflikte v denníku sledovania.
Pri zobrazení súborov denníka služby Unified Logging Service (ULS), zobrazí položka podobná položke:
Dátum Čas w3wp.exe (0x1620) 0x1988 Windows SharePoint Services topológie 8xqz stredne aktualizácia triedu SPPersistedObject SPAlternateUrlCollection meno = WEBAPPLICATION rodič = SPFarm Name = SharePoint_Config. Verzia: 16449 zabezpečenie: 0, HashCode: 30474330, Id: 609b3309-241a-4193-8289-1bba6a70be50, zásobník: v Microsoft.SharePoint.Administration.SPPersistedObject.Update() v Microsoft.SharePoint.Administration.SPAlternateUrlCollection.Update() v Microsoft.SharePoint.ApplicationPages.IncomingUrlPage.BtnSave_Click (objekt odosielateľa, EventArgs e) na System.Web.UI.WebControls.Button.OnClick (EventArgs e) v System.Web.UI.WebControls.Button.RaisePostBackEvent (String eventArgument) v System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent (String eventArgument) v System.Web.UI.Page.RaisePostBackEvent (IPostBackEventHandler sourceControl, reťazec eventArgument) v System.Web.UI.Page.RaisePostBackEvent (NameValueCollection postData) v System.Web.UI.Page.ProcessRequestMain (logická includeStagesBeforeAsyncPoint, logická includeStagesAfterAsyncPoint) v System.Web.UI.Page.ProcessRequest (logická includeStagesBeforeAsyncPoint, logická includeStagesAfterAsyncPoint) v System.Web.UI.Page.ProcessRequest() v System.Web.UI.Page.ProcessRequestWithNoAssert (HttpContext súvislosti) v System.Web.UI.Page.ProcessRequest (HttpContext súvislosti) v ASP._admin_editincomingurl_aspx.ProcessRequest (HttpContext súvislosti) v System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() v System.Web.HttpApplication.ExecuteStep (IExecutionStep krok, Boolean & completedSynchronously) v System.Web.HttpApplication.ResumeSteps (výnimka chyba) v System.Web.HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest (HttpContext súvislosti, AsyncCallback cb, objekt extraData) v System.Web.HttpRuntime.ProcessRequestInternal (HttpWorkerRequest wr) v System.Web.HttpRuntime.ProcessRequestNoDemand (HttpWorkerRequest wr) v System.Web.Hosting.ISAPIRuntime.ProcessRequest (IntPtr ecb, Int32 iWRType) 06/06/2007 14:36:31.51 w3wp.exe (0x1620) 0x1988 Windows SharePoint Services topológie 75bd vysoký UpdatedConcurrencyException: objekt SPAlternateUrlCollection meno = WEBAPPLICATION rodič = SPFarm názov = SharePoint_Config bol aktualizovaný iným používateľom. Určiť, ak tieto zmeny bude konflikt, odstráňte prípadné rozdiely a znova použite druhú zmenu. Táto chyba môže signalizovať aj chybu programovania spôsobená získaním dvoch kópií rovnakého objektu v jednom vlákne. Predchádzajúce aktualizácie informácií: používateľ: DomainName\UserName1 Postup: w3wp stroje:Názov_servera Čas:Dátum Čas Aktuálne informácie o aktualizáciách: používateľ: DomainName\UserName2 Postup: w3wp stroje:Názov_serveraDátum Čas w3wp.exe (0x1620) 0x1988 Windows SharePoint Services topológie 8xqy vysoký ConcurrencyException: stará verzia: 16449 nová verzia: 0

Príčina

Tento problém sa vyskytne, ak obsah vyrovnávacej pamäte systému súborov na klientske servery sú novšie než obsah databázy konfigurácie. Po vykonaní obnovenie systému, musíte manuálne vymazať vyrovnávaciu pamäť systému súborov na lokálnom serveri.

Riešenie

Ak chcete vyriešiť tento problém, zrušte vyrovnávacia pamäť systému súborov na všetky servery v serverovej farme, na ktorom je spustená služba časovača služby Windows SharePoint. Robiť to, postupujte nasledovne:
  1. Zastavenie služby časovača. Robiť to, postupujte nasledovne:
    1. Kliknite na tlačidlo Štart, ukážte na položku Administratívne nástroje, a potom kliknite na tlačidlo Služby.
    2. Kliknite pravým tlačidlom myši Windows SharePoint Services časovač, a potom kliknite na tlačidlo zastaviť.
    3. Zatvorte konzolu Services.
  2. V počítači so systémom Microsoft Office SharePoint Server 2007 a na ktorom hosťuje Táto lokalita centrálnej správy, kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typ Prieskumník, a potom stlačte kláves ENTER.
  3. V programe Windows Prieskumník vyhľadajte a dvakrát kliknite na nasledujúci priečinok:
    Disk: \Documents and Settings\All Users\Application Data\Microsoft\SharePoint\Config\IDENTIFIKÁTOR GUID
    Poznámky
    • Na Disk zástupný znak určuje písmeno jednotky, na ktorej je nainštalovaný systém Windows. V predvolenom nastavení Windows je nainštalovaný na jednotke C.
    • Na IDENTIFIKÁTOR GUID zástupný znak určuje identifikátor GUID priečinok.
    • Môže byť skrytý priečinok Application Data. Ak chcete zobraziť skryté priečinky, postupujte nasledovne:
      1. Na Nástroje ponuky, kliknite na tlačidlo Možnosti priečinka.
      2. Kliknite na tlačidlo Zobrazenie kartu.
      3. V Rozšírené nastavenia kliknite Zobraziť skryté súbory a priečinky podľa Skryté súbory a priečinky, a potom kliknite na tlačidlo ok.
    • V systéme Windows Server 2008, vyrovnávaciu pamäť konfigurácie sa v nasledujúcom umiestnení:
      Disk: \ProgramData\Microsoft\SharePoint\Config\IDENTIFIKÁTOR GUID
  4. Zálohovať súbor Cache.ini.
  5. Odstrániť všetky konfiguračné súbory XML v priečinku GUID. To tak, že si môžete overiť, že priečinok GUID nahrádza nové konfiguračné súbory XML pri cache je prestavaný.

    Poznámka Keď vyprázdnite vyrovnávaciu pamäť konfigurácie v priečinku GUID, uistite sa, aby ste neodstraňovali GUID zložku a súbor Cache.ini, ktorý sa nachádza v priečinku GUID.
  6. Dvakrát kliknite na súbor Cache.ini.
  7. Na Upraviť ponuky, kliknite na tlačidlo Vybrať všetky.
  8. Na Upraviť ponuky, kliknite na tlačidlo Odstrániť.
  9. Typ 1, a potom kliknite na tlačidlo Uložiť na Súbor menu.
  10. Na Súbor ponuky, kliknite na tlačidlo Výstupu.
  11. Spustenie služby časovača. Robiť to, postupujte nasledovne:
    1. Kliknite na tlačidlo Štart, ukážte na položku Administratívne nástroje, a potom kliknite na tlačidlo Služby.
    2. Kliknite pravým tlačidlom myši Windows SharePoint Services časovač, a potom kliknite na tlačidlo Štart.
    3. Zatvorte konzolu Services.
    Poznámka Po vykonaní tohto postupu je re-vytvorený vyrovnávacia pamäť systému súborov. Uistite sa, že vykonaním tohto postupu na všetky servery v serverovej farme.
  12. Uistite sa, že bol aktualizovaný súbor Cache.ini. Napríklad už malo 1 Ak cache bol aktualizovaný.
  13. Kliknite na tlačidlo Štart, ukážte na položku Programy, ukážte na položku Administratívne nástroje, a potom kliknite na tlačidlo Centrálnej správe služby SharePoint 3.0.
  14. Kliknite na tlačidlo Operácie kartu a potom kliknite na tlačidlo Stav úlohy časovača podľa Globálna konfigurácia.
  15. V zozname úloh časovača Skontrolujte stav Obnovenie konfigurácie položka Podarilo.
  16. Na Súbor ponuky, kliknite na tlačidlo Zavrieť.

Vlastnosti

ID článku: 939308 - Posledná kontrola: 4. februára 2013 - Revízia: 0.2
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows SharePoint Services 3.0
  • Microsoft Office SharePoint Server 2007
  • Microsoft SharePoint Foundation 2010
  • Microsoft SharePoint Server 2010
  • Microsoft SharePoint Foundation 2013
  • Microsoft SharePoint Server 2013
Kľúčové slová: 
kberrmsg kbexpertiseinter kbprb kbtshoot kbmt KB939308 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 939308

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com